Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 PICOTES VOIP em MPLS

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
rmmc.s



Número de Mensagens : 3
Reputação : 1
Pontos : 2
Data de inscrição : 16/06/2008

MensagemAssunto: PICOTES VOIP em MPLS   Sex Dez 12, 2008 11:27 pm

Estou com o seguinte problema:

Utilizando QOS na minha rede cisco com frame-relay , utilizo as seguintes configuraçoes:
OBS:FUNCIONA PERFEITAMENTE A VOZ SEM PICOTES
ip cef
!
class-map match-all voice-signaling
match access-group 103
class-map match-all trafego-email
match access-group 104
class-map match-all voice-trafego
match access-group 102
!
!
policy-map voice-qos
class voice-trafego
priority 53
set ip precedence 5
class voice-signaling
set ip precedence 3
class trafego-email
set ip precedence 0
class class-default
fair-queue
set ip precedence 0
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
ip address 192.168.45.15 255.255.255.0
ip access-group 111 in
speed auto
full-duplex
h323-gateway voip interface
h323-gateway voip id RO-CDA ipaddr 192.168.0.16 1718
h323-gateway voip h323-id RO-PER-CDA@zema.com.br
h323-gateway voip tech-prefix 40451
h323-gateway voip tech-prefix 40452
h323-gateway voip bind srcaddr 192.168.45.15
!
interface Serial0
bandwidth 128
no ip address
encapsulation frame-relay
no ip mroute-cache
load-interval 30
frame-relay traffic-shaping
frame-relay lmi-type ansi
frame-relay ip rtp header-compression
ip rtp reserve 16384 100
!
interface Serial0.1 point-to-point
description Circuito entre Eletro Perdoes - CDA
bandwidth 128
ip address 10.1.3.150 255.255.255.252
frame-relay interface-dlci 51
class VoIPovFR1
frame-relay ip rtp header-compression
ip rtp reserve 16384 100
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0.1
no ip http server
ip pim bidir-enable
!
!
map-class frame-relay VoIPovFR1
frame-relay cir 96000
frame-relay bc 960
frame-relay be 0
frame-relay mincir 96000
no frame-relay adaptive-shaping
service-policy output voice-qos
frame-relay fragment 160
frame-relay ip rtp priority 16384 16383 30
access-list 102 permit udp any any range 16384 32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
access-list 104 permit tcp any eq 22 any
access-list 104 permit tcp any eq telnet any
access-list 104 permit tcp any eq 5631 any
access-list 104 permit tcp any eq 5632 any
access-list 104 permit tcp any eq 3389 any
access-list 104 permit tcp any eq pop3 any
access-list 104 permit tcp any eq smtp any
access-list 104 permit tcp any any eq www
access-list 104 permit tcp any any eq 3128
access-list 104 permit tcp any any eq 1433
access-list 104 permit tcp any any eq ftp
access-list 104 permit tcp any eq ftp-data any gt 1024
access-list 104 permit tcp any any eq 5631
access-list 104 permit tcp any host 172.30.0.34
access-list 104 permit tcp any any eq 139
access-list 104 permit udp any any eq netbios-ns
access-list 104 permit udp any any eq netbios-dgm
access-list 104 permit icmp any any
access-list 104 permit tcp any eq 5800 any
access-list 104 permit tcp any eq 5900 any
!
call rsvp-sync
!
voice-port 2/0
echo-cancel coverage 16
!
voice-port 2/1
echo-cancel coverage 16
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 1 voip
destination-pattern 1...
session target ipv4:192.168.0.16
!
dial-peer voice 4 voip
destination-pattern 4....
session target ras
!
dial-peer voice 11 voip
destination-pattern 0T
session target ipv4:192.168.0.16
!
dial-peer voice 12 voip
destination-pattern 9
session target ipv4:192.168.0.16
!
dial-peer voice 4451 pots
destination-pattern 40451
port 2/0
!
dial-peer voice 4452 pots
destination-pattern 40452
port 2/1
!
gateway


Utilizando QOS na minha rede cisco com MPLS , utilizo as seguintes configuraçoes:
OBS: VOZ COM PICOTES

ip cef
!
class-map match-all voice-signaling
match access-group 103
match ip dscp 26
class-map match-all trafego-email
match access-group 104
match ip dscp 10
class-map match-all voice-trafego
match access-group 102
match ip dscp 46
!
!
policy-map voice-qos
class voice-trafego
priority 53
set ip dscp 46
class voice-signaling
set ip dscp 26
class trafego-email
set ip dscp 10
class class-default
fair-queue
set ip dscp 0
!
!
!
!
!
!
!
!
!
!
!
interface Multilink1
ip address 189.43.191.50 255.255.255.252
ip access-group 111 in
ip access-group 111 out
ip tcp header-compression iphc-format
service-policy output voice-qos
no cdp enable
ppp multilink
ppp multilink fragment-delay 1
ppp multilink interleave
multilink-group 1
ip rtp header-compression iphc-format
ip rtp priority 16384 16383 43
!
interface FastEthernet0
ip address 192.168.30.15 255.255.255.0
ip access-group 111 in
ip access-group 111 out
speed auto
full-duplex
service-policy output voice-qos
h323-gateway voip interface
h323-gateway voip id RO-CDA ipaddr 192.168.0.16 1718
h323-gateway voip h323-id RO-CAV-CDA@zema.com.br
h323-gateway voip tech-prefix 40301
h323-gateway voip tech-prefix 40302
h323-gateway voip bind srcaddr 192.168.30.15
!
interface Serial0
bandwidth 128
no ip address
ip access-group 111 in
ip access-group 111 out
encapsulation ppp
no ip mroute-cache
load-interval 30
no fair-queue
ppp multilink
multilink-group 1
ip rtp priority 16384 16383 53
!
ip classless
ip route 0.0.0.0 0.0.0.0 Multilink1
no ip http server
ip pim bidir-enable
!
access-list 102 remark QOS DE SAIDA*service-policy*
access-list 102 permit udp any any range 16384 32767
access-list 102 permit tcp any any range 1718 1720
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
access-list 103 permit ip any any dscp cs3
access-list 104 permit tcp any eq 22 any
access-list 104 permit tcp any eq telnet any
access-list 104 permit tcp any eq 5631 any
access-list 104 permit tcp any eq 5632 any
access-list 104 permit tcp any eq 3389 any
access-list 104 permit tcp any eq pop3 any
access-list 104 permit tcp any eq smtp any
access-list 104 permit tcp any eq 9100 any
access-list 104 permit tcp any any eq www
access-list 104 permit tcp any any eq 3128
access-list 104 permit tcp any any eq 1433
access-list 104 permit tcp any any eq ftp
access-list 104 permit tcp any eq ftp-data any gt 1024
access-list 104 permit tcp any any eq 5631
access-list 104 permit tcp any host 172.30.0.34
access-list 104 permit tcp any any eq 139
access-list 104 permit udp any any eq netbios-ns
access-list 104 permit udp any any eq netbios-dgm
access-list 104 permit icmp any any
access-list 104 permit tcp any eq 5800 any
access-list 104 permit tcp any eq 5900 any
access-list 111 remark QOS DE ENTRADA*ip access-group 111 in*
access-list 111 permit udp any any dscp ef
access-list 111 permit tcp any any dscp af31
access-list 111 permit udp any any range 16384 32767 dscp ef
access-list 111 permit tcp any any range 1718 1720 dscp ef
access-list 111 permit tcp any eq 1720 any dscp ef
access-list 111 permit tcp any any eq 1720 dscp ef
access-list 111 permit tcp any eq 22 any dscp af31
access-list 111 permit tcp any eq telnet any dscp default
access-list 111 permit tcp any eq 5631 any dscp af31
access-list 111 permit tcp any eq 5632 any dscp af31
access-list 111 permit tcp any eq 3389 any dscp af31
access-list 111 permit tcp any eq pop3 any dscp af31
access-list 111 permit tcp any eq smtp any dscp af31
access-list 111 permit tcp any eq 9100 any dscp default
access-list 111 permit tcp any any eq www dscp af11
access-list 111 permit tcp any any eq 3128 dscp af11
access-list 111 permit tcp any any eq 1433 dscp af11
access-list 111 permit tcp any any eq ftp dscp af11
access-list 111 permit tcp any eq ftp-data any gt 1024 dscp af11
access-list 111 permit tcp any any eq 5631 dscp af11
access-list 111 permit tcp any host 172.30.0.34 dscp af11
access-list 111 permit tcp any any eq 139 dscp af11
access-list 111 permit udp any any eq netbios-ns dscp af11
access-list 111 permit udp any any eq netbios-dgm dscp af11
access-list 111 permit icmp any any dscp default
access-list 111 permit tcp any eq 5800 any dscp af11
access-list 111 permit tcp any eq 5900 any dscp af11
access-list 111 permit tcp any any
access-list 111 permit udp any any
access-list 111 permit ip any any dscp ef
access-list 111 permit ip any any dscp af11
access-list 111 permit ip any any dscp af31
access-list 111 permit ip any any dscp default
access-list 111 permit udp any any precedence network
access-list 111 permit tcp any any precedence flash
access-list 111 permit udp any any range 16384 32767 precedence network
access-list 111 permit tcp any eq 1720 any precedence flash
access-list 111 permit tcp any any eq 1720 precedence flash
access-list 111 permit tcp any eq 22 any precedence flash
access-list 111 permit tcp any eq telnet any precedence routine
access-list 111 permit tcp any eq 5631 any precedence flash
access-list 111 permit tcp any eq 5632 any precedence flash
access-list 111 permit tcp any eq 3389 any precedence flash
access-list 111 permit tcp any eq pop3 any precedence flash
access-list 111 permit tcp any eq smtp any precedence flash
access-list 111 permit tcp any eq 9100 any precedence routine
access-list 111 permit tcp any any eq www precedence flash
access-list 111 permit tcp any any eq 3128 precedence flash
access-list 111 permit tcp any any eq 1433 precedence flash
access-list 111 permit tcp any any eq ftp precedence flash
access-list 111 permit tcp any eq ftp-data any gt 1024 precedence flash
access-list 111 permit tcp any any eq 5631 precedence flash
access-list 111 permit tcp any host 172.30.0.34 precedence flash
access-list 111 permit tcp any any eq 139 precedence flash
access-list 111 permit udp any any eq netbios-ns precedence flash
access-list 111 permit udp any any eq netbios-dgm precedence flash
access-list 111 permit icmp any any precedence routine
access-list 111 permit tcp any eq 5800 any precedence flash
access-list 111 permit tcp any eq 5900 any precedence flash
access-list 111 permit ip any any precedence network
dialer-list 1 protocol ip permit
!
snmp-server community zemasnmp RO
snmp-server community zema@2k5#1 RW
call rsvp-sync
!
voice-port 2/0
echo-cancel coverage 16
!
voice-port 2/1
echo-cancel coverage 16
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 4301 pots
destination-pattern 40301
port 2/0
!
dial-peer voice 4302 pots
destination-pattern 40302
port 2/1
!
dial-peer voice 1 voip
destination-pattern 1...
session target ipv4:192.168.0.16
!
dial-peer voice 4 voip
destination-pattern 4....
session target ras
!
dial-peer voice 11 voip
destination-pattern 0T
session target ipv4:192.168.0.16
!
dial-peer voice 12 voip
destination-pattern 9
session target ipv4:192.168.0.16
!
gateway

NA REDE DA OPERADORA ESTÁ APLICADO QOS NOS ROTEADORES,já atualizei vários IOS mas nada, lembrando que o problema ocorre em todos meus roteadores com MPLS(1750,1751V e 2801)

CONFIGURAÇAO DO GATEKEPER(ROTEADOR CENTRAL - c3845)



Alguem tem alguma dica .......
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: PICOTES VOIP em MPLS   Dom Dez 14, 2008 8:46 pm

Ola boa noite,

Existem diversos meios de fazer uma configuração de qos, mas a sua apesar de estar um pouco simples esta correta. Uma das alterações que você pode tentar é alterar o valor de fragmentação:

ppp multilink fragment-delay 1

por

ppp multilink fragment-delay 10

Outra coisa que você pode estudar é a aplicação de CBWFQ em todas as classes, deste modo caso ocorra alta utilização do link o QoS será mais efetivo, ex:


policy-map voice-qos
class voice-trafego
priority X
police X conform-action set-dscp-transmit X exceed-action drop
class voice-signaling
bandwith X
police X conform-action set-dscp-transmit X exceed-action set-dscp-transmit X violated-action X
class trafego-email
bandwith X
police X conform-action set-dscp-transmit X exceed-action set-dscp-transmit default violated-action drop
class class-default
fair-queue
bandwith X
police X conform-action set-dscp-transmit X exceed-action set-dscp-transmit default violated-action drop

E por ultimo, você pode alterar o valor do max-reserved bandwitdh do multilink:

interface Multilink1
max-reserved bandwitdh 95%

O valor default de uma interface multilink seria 75%, com isso se você tem um link de 128 Kbps a soma de banda entre todas as classes de serviço será 128*0.75=96Kbps

Logico que qualquer destas alterações deve ser feita no PE e no CE.

Segundo você pode habilitar o ip route-cache flow em ambas as pontas (Os dois CEs que estão estabelecendo a ligação), após habilitar ele no multilink executa o comando show ip cache verbose flow, este comando mostra o valor do TOS, tenta observar se os ips estão chegando com a marcação correta (0xB8), pois pode haver alguma falha de configuração no backbone que esteja retirando a marcação.
obs. o comando ip route-cache flow mostra o trafego inbound.
obs2. lembre-se de desabilitar este comando, pois ele consome processamento do CPE.

Outro teste possivel é efetuar um ping extendido entre os CES, quando você for efetuar este ping extendido existe um campo chamado TOS, marca ele como 0xB8. Este ping irá marcado como se fosse um pacote de voz e você poderá verificar se existe alguma perda de pacote, assim como a latência ou jitter da classe.

Outro teste seria executar o comando show policy-map interface multilink X e verificar se existe algum drop na classe de voz.


abs.

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
rmmc.s



Número de Mensagens : 3
Reputação : 1
Pontos : 2
Data de inscrição : 16/06/2008

MensagemAssunto: map class   Seg Dez 15, 2008 8:00 pm

Boa noite !

No caso do map class tem alguma diferença eu usar : class-map match-all ou class-map match-any ?

VC poderia me dar um exemplo de como ficaria a situaçao abaixo utilizando um link de 128k e outro de 4MB ?

policy-map voice-qos
class voice-trafego
priority X
police X conform-action set-dscp-transmit X exceed-action drop
class voice-signaling
bandwith X
police X conform-action set-dscp-transmit X exceed-action set-dscp-transmit X violated-action X
class trafego-email
bandwith X
police X conform-action set-dscp-transmit X exceed-action set-dscp-transmit default violated-action drop
class class-default
fair-queue
bandwith X
police X conform-action set-dscp-transmit X exceed-action set-dscp-transmit default violated-action drop


Desde já agradeço pela ajuda...

Att: Rodiney Alen Ribeiro
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: PICOTES VOIP em MPLS   Qua Dez 24, 2008 9:17 am

Bom dia,

Sim existe uma diferença entre o class-map match-all e o class-map match-all, eu gosto de associar com portas OR e AND.
Escrevi um tópico explicando isso:

http://cisco.forumeiros.com/quality-of-service-f50/configurando-cos-t175.htm

A reserva de banda de cada classe pode variar de acordo com sua necessidade, especialmente na classe de voz.
Para dimensionar a classe de voz é necessário saber quanto canais você deseja utilizar simultaneamente e o codec utilizado.

Na policy que você havia informado a reserva para tráfego de audio era de 53Kbps, então vou dar o exemplo utilizando este valor.

policy-map voice-qos
class voice-trafego
priority 53
police 53000 6625 6625 conform-action set-dscp-transmit ef exceed-action drop
class voice-signaling
bandwith 8
police 8000 1000 1000 conform-action set-dscp-transmit af31 exceed-action set-dscp-transmit af31 violated-action drop
class trafego-email
bandwith 60
police 60000 7500 7500 conform-action set-dscp-transmit default exceed-action set-dscp-transmit default violated-action drop
class class-default
random-detect dscp-based
random-detect dscp 0 162 486 1
set ip dscp default

Se esta configuração afetar muito o tráfego de e-mail você pode alterar a violação para "set-dscp-transmit default", mas com isso seria interessante pelo menos aplicar um WRED na classe:

policy-map voice-qos
class voice-trafego
priority 53
police 53000 6625 6625 conform-action set-dscp-transmit ef exceed-action drop
class voice-signaling
bandwith 8
police 8000 1000 1000 conform-action set-dscp-transmit af31 exceed-action set-dscp-transmit af31 violated-action drop
class trafego-email
bandwith 60
police 60000 7500 7500 conform-action set-dscp-transmit default exceed-action set-dscp-transmit default violated-action set-dscp-transmit default
random-detect dscp-based
random-detect dscp 0 162 486 1
class class-default
random-detect dscp-based
random-detect dscp 0 162 486 1
set ip dscp default


abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
Conteúdo patrocinado




MensagemAssunto: Re: PICOTES VOIP em MPLS   Hoje à(s) 12:50 am

Voltar ao Topo Ir em baixo
 
PICOTES VOIP em MPLS
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» COMO MONTAR SERVIDOR VOIP
» Redirecionar dominio por ip
» Script para priorizar trafego voip...
» Vendo Audiocodes Mp-124 Voip Gateway 24 Fxs Ports R$ 1,200.00
» IP DSLAM + MIKROTIK + VOIP, como seria isso ?

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: