Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 Teste VOIP (FXO)

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
alexandre.toledo



Número de Mensagens : 20
Idade : 31
Localização : Sorocaba - SP
Reputação : 3
Pontos : 27
Data de inscrição : 17/09/2010

MensagemAssunto: Teste VOIP (FXO)   Qua Out 06, 2010 3:23 pm


Boa tarde, galera!

Estou estudando VOIP com um Cisco 2801 com uma placa FXO.


O teste que eu gostaria de fazer é bem simples (mas nao estou conseguindo rsrs)...

Quero fazer uma ligação do meu notebook, usando Netmeeting, para algum telefone externo. A linha telefonica de casa está conectada na FXO.

No Netmeeting configurei o gateway apontando para o endereço da F0/0 do router. Mas quando tento fazer a ligação aparece uma msg falando que o gateway nao pode atender a chamada.


Configuração router:

interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.0.1

voice-port 0/0/0
cptone BR

dial-peer voice 1000 pots
destination-pattern 21012100
port 0/0/0

gateway
timer receive-rtp 1200

Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandre.toledo



Número de Mensagens : 20
Idade : 31
Localização : Sorocaba - SP
Reputação : 3
Pontos : 27
Data de inscrição : 17/09/2010

MensagemAssunto: Re: Teste VOIP (FXO)   Qua Out 06, 2010 3:25 pm

Ahhhhhh e quando eu gero a ligação pelo netmeeting o LED da placa FXO acende mas nao completa a ligação
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: Teste VOIP (FXO)   Dom Out 10, 2010 11:59 pm

Bom, eu acho estranho pois esta faltando algo para o retorno do pacote.

Quando o pacote sai do seu note ele bate no router e vai para a fxo, mas como o pacote de reotnro saberia voltar para seu note?

De qualquer jeito, como a FXO esta ligada na rede publica, você precisa configurar o "direct-inward-dial"

Outra coisa que pode te ajudar é forçar para que todos os digitos sejam encaminhados para a rede publica "forward-digits all".

Com isso a config do teu dial-peer ficaria assim:

dial-peer voice 1000 pots
destination-pattern 21012100
port 0/0/0
direct-inward-dial
forward-digits all

abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
alexandre.toledo



Número de Mensagens : 20
Idade : 31
Localização : Sorocaba - SP
Reputação : 3
Pontos : 27
Data de inscrição : 17/09/2010

MensagemAssunto: Tópico: Teste VOIP (FXO)   Seg Out 11, 2010 9:19 am

Fiz varios testes aqui.....adicionei uns comandos descritos no site da cisco para tentar funcionar com o netmeeting (http://www.cisco.com/en/US/tech/tk1077/technologies_configuration_example09186a00800b4c4a.shtml). Depois criei uma dial-peer 2 voip com destination para .T....e uma dial-peer 1 pots com destination 21012100......veja se esta certo meu raciocinio... ligacao com destino 21012100 sera a dial -peer 1 e tudo que nao for 21012101 sera a dial-peer 2 ( note=192.168.0.2).

Segue a config em seguida o debug de uma ligacao usando essa config.

Router#show running-config
Building configuration...

Current configuration : 1247 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$myh/$QHqp03k532/W/Gl/PI19M0
!
no aaa new-model
ip cef
!
!
!
!
multilink bundle-name authenticated
!
!
voice-card 0
!
!
!
voice service voip
h323
h245 tunnel disable
h245 caps mode restricted
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 192.168.0.1
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/3/0
no ip address
shutdown
clock rate 2000000
!
ip forward-protocol nd
!
!
no ip http server
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0
cptone BR
!
voice-port 0/0/1
!
!
!
!
!
dial-peer voice 1 pots
destination-pattern 21012100
direct-inward-dial
port 0/0/0
forward-digits all
!
dial-peer voice 2 voip
destination-pattern .T
session target ipv4:192.168.0.2
codec g711ulaw
!
!
gateway
timer receive-rtp 1200
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
scheduler allocate 20000 1000
end

------------------------------------------------------------------------------------------

Router#
*Oct 11 12:25:24.255: //-1/C0EC173D881E/CCAPI/cc_api_display_ie_subfields:
cc_api_call_setup_ind_common:
cisco-username=Alexandre Toledo
----- ccCallInfo IE subfields -----
cisco-ani=
cisco-anitype=0
cisco-aniplan=0
cisco-anipi=0
cisco-anisi=0
dest=21012100
cisco-desttype=0
cisco-destplan=1
cisco-rdie=FFFFFFFF
cisco-rdn=
cisco-rdntype=-1
cisco-rdnplan=-1
cisco-rdnpi=-1
cisco-rdnsi=-1
cisco-redirectreason=-1 fwd_final_type =0
final_redirectNumber =
hunt_group_timeout =0

*Oct 11 12:25:24.255: //-1/C0EC173D881E/CCAPI/cc_api_call_setup_ind_common:
Interface=0x653BF15C, Call Info(
Calling Number=,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
Called Number=21012100(TON=Unknown, NPI=ISDN),
Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,
Incoming Dial-peer=0, Progress Indication=NULL(0), Calling IE Present=FALSE,
Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=29
*Oct 11 12:25:24.259: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Oct 11 12:25:24.259: :cc_get_feature_vsa malloc success
*Oct 11 12:25:24.259: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Oct 11 12:25:24.259: cc_get_feature_vsa count is 1
*Oct 11 12:25:24.259: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Oct 11 12:25:24.259: :FEATURE_VSA attributes are: feature_name:0,feature_time:1691103728,feature_id:29
*Oct 11 12:25:24.259: //29/C0EC173D881E/CCAPI/cc_api_call_setup_ind_common:
Set Up Event Sent;
Call Info(Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
Called Number=21012100(TON=Unknown, NPI=ISDN))
*Oct 11 12:25:24.259: //29/C0EC173D881E/CCAPI/cc_process_call_setup_ind:
Event=0x65079B90
*Oct 11 12:25:24.259: //29/C0EC173D881E/CCAPI/ccCallSetContext:
Context=0x64301C08
*Oct 11 12:25:24.259: //29/C0EC173D881E/CCAPI/cc_process_call_setup_ind:
>>>>CCAPI handed cid 29 with tag 0 to app "_ManagedAppProcess_Default"
*Oct 11 12:25:24.259: //29/C0EC173D881E/CCAPI/ccCallProceeding:
Progress Indication=NULL(0)
*Oct 11 12:25:24.263: //29/C0EC173D881E/CCAPI/ccCallSetupRequest:
Destination=, Calling IE Present=FALSE, Mode=0,
Outgoing Dial-peer=1, Params=0x64300DE0, Progress Indication=NULL(0)
*Oct 11 12:25:24.263: //29/C0EC173D881E/CCAPI/ccCheckClipClir:
In: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
*Oct 11 12:25:24.263: //29/C0EC173D881E/CCAPI/ccCheckClipClir:
Out: Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed)
*Oct 11 12:25:24.263: //29/C0EC173D881E/CCAPI/ccCallSetupRequest:
Destination Pattern=21012100, Called Number=21012100, Digit Strip=TRUE
*Oct 11 12:25:24.263: //29/C0EC173D881E/CCAPI/ccCallSetupRequest:
Calling Number=(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
Called Number=21012100(TON=Unknown, NPI=ISDN),
Redirect Number=, Display Info=Alexandre Toledo
Account Number=Alexandre Toledo, Final Destination Flag=TRUE,
Guid=C0EC173D-5011-2A48-881E-A6D34B72C93C, Outgoing Dial-peer=1
*Oct 11 12:25:24.263: //29/C0EC173D881E/CCAPI/cc_api_display_ie_subfields:
ccCallSetupRequest:
cisco-username=Alexandre Toledo
----- ccCallInfo IE subfields -----
cisco-ani=
cisco-anitype=0
cisco-aniplan=0
cisco-anipi=0
cisco-anisi=0
dest=21012100
cisco-desttype=0
cisco-destplan=1
cisco-rdie=FFFFFFFF
cisco-rdn=
cisco-rdntype=-1
cisco-rdnplan=-1
cisco-rdnpi=-1
cisco-rdnsi=-1
cisco-redirectreason=-1 fwd_final_type =0
final_redirectNumber =
hunt_group_timeout =0

*Oct 11 12:25:24.263: //29/C0EC173D881E/CCAPI/ccIFCallSetupRequestPrivate:
Interface=0x64CD4C0C, Interface Type=6, Destination=, Mode=0x0,
Call Params(Calling Number=,(Calling Name=Alexandre Toledo)(TON=Unknown, NPI=Unknown, Screening=Not Screened, Presentation=Allowed),
Called Number=21012100(TON=Unknown, NPI=ISDN), Calling Translated=FALSE,
Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE, Outgoing Dial-peer=1, Call Count On=FALSE,
Source Trkgrp Route Label=, Target Trkgrp Route Label=, tg_label_flag=0, Application Call Id=)
*Oct 11 12:25:24.267: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Oct 11 12:25:24.267: :cc_get_feature_vsa malloc success
*Oct 11 12:25:24.267: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Oct 11 12:25:24.267: cc_get_feature_vsa count is 2
*Oct 11 12:25:24.267: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

*Oct 11 12:25:24.267: :FEATURE_VSA attributes are: feature_name:0,feature_time:1691103512,feature_id:30
*Oct 11 12:25:24.267: //30/C0EC173D881E/CCAPI/ccIFCallSetupRequestPrivate:
SPI Call Setup Request Is Success; Interface Type=6, FlowMode=1
*Oct 11 12:25:24.267: //30/C0EC173D881E/CCAPI/ccCallSetContext:
Context=0x64300D90
*Oct 11 12:25:24.267: //29/C0EC173D881E/CCAPI/ccSaveDialpeerTag:
Outgoing Dial-peer=1
*Oct 11 12:25:24.271: //30/C0EC173D881E/CCAPI/cc_api_call_proceeding:
Interface=0x64CD4C0C, Progress Indication=NULL(0)
*Oct 11 12:25:25.523: //30/C0EC173D881E/CCAPI/cc_api_call_disconnected:
Cause Value=34, Interface=0x64CD4C0C, Call Id=30
*Oct 11 12:25:25.523: //30/C0EC173D881E/CCAPI/cc_api_call_disconnected:
Call Entry(Responsed=TRUE, Cause Value=34, Retry Count=0)
*Oct 11 12:25:25.523: //29/xxxxxxxxxxxx/CCAPI/ccCallReleaseResources:
release reserved xcoding resource.
*Oct 11 12:25:25.523: //30/C0EC173D881E/CCAPI/ccCallSetAAA_Accounting:
Accounting=1, Call Id=30
*Oct 11 12:25:25.523: //30/C0EC173D881E/CCAPI/ccCallDisconnect:
Cause Value=34, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=34)
*Oct 11 12:25:25.523: //30/C0EC173D881E/CCAPI/ccCallDisconnect:
Cause Value=34, Call Entry(Responsed=TRUE, Cause Value=34)
*Oct 11 12:25:25.527: //30/C0EC173D881E/CCAPI/cc_api_call_disconnect_done:
Disposition=0, Interface=0x64CD4C0C, Tag=0x0, Call Id=30,
Call Entry(Disconnect Cause=34, Voice Class Cause Code=0, Retry Count=0)
*Oct 11 12:25:25.527: //30/C0EC173D881E/CCAPI/cc_api_call_disconnect_done:
Call Disconnect Event Sent
*Oct 11 12:25:25.527: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Oct 11 12:25:25.527: :cc_free_feature_vsa freeing 64CC3110
*Oct 11 12:25:25.527: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Oct 11 12:25:25.527: vsacount in free is 1
*Oct 11 12:25:25.531: //29/C0EC173D881E/CCAPI/ccCallDisconnect:
Cause Value=34, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
*Oct 11 12:25:25.531: //29/C0EC173D881E/CCAPI/ccCallDisconnect:
Cause Value=34, Call Entry(Responsed=TRUE, Cause Value=34)
*Oct 11 12:25:25.531: //29/C0EC173D881E/CCAPI/cc_api_get_transfer_info:
Transfer Number Is Null
*Oct 11 12:25:25.547: //29/C0EC173D881E/CCAPI/cc_api_call_disconnect_done:
Disposition=0, Interface=0x653BF15C, Tag=0x0, Call Id=29,
Call Entry(Disconnect Cause=34, Voice Class Cause Code=0, Retry Count=0)
*Oct 11 12:25:25.547: //29/C0EC173D881E/CCAPI/cc_api_call_disconnect_done:
Call Disconnect Event Sent
*Oct 11 12:25:25.547: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Oct 11 12:25:25.547: :cc_free_feature_vsa freeing 64CC31E8
*Oct 11 12:25:25.547: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

*Oct 11 12:25:25.547: vsacount in free is 0
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: Teste VOIP (FXO)   Ter Out 12, 2010 7:14 pm

Aparentemente ele esta encaminhando para o dial-peer e saindo.

Um teste básico. Se você fizer um csim start 21012100, o telefone chega a tocar?

abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
alexandre.toledo



Número de Mensagens : 20
Idade : 31
Localização : Sorocaba - SP
Reputação : 3
Pontos : 27
Data de inscrição : 17/09/2010

MensagemAssunto: Re: Teste VOIP (FXO)   Qua Out 13, 2010 8:36 am

Resolvido ja! (uma das causas da ate vergonha de falar mas enfim rsrsrs)


1ª Solução foi o comando "forward-digits all" dentro da dial-peer pots, que o Nakano sugeriu colocar.

2ª Solução foi trocar o cabo da linha telefonica para a FXO, eu estava utilizando o cabo de um telefone da Alcatel que uso para testa rádio acesso mas a pinagem é diferente Sad rsrs mas ta bom!

valeu pela Nakano!

abraço

Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Teste VOIP (FXO)   Hoje à(s) 7:16 pm

Voltar ao Topo Ir em baixo
 
Teste VOIP (FXO)
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Teste do GameMaker Não Abre!
» Teste do Touch Screen e as Demais Funções dos BADA
» COMO MONTAR SERVIDOR VOIP
» teste de manipulação
» Teste teste som som

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: