Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 ip dns server não funciona!

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
supercisco



Número de Mensagens : 3
Idade : 35
Localização : São Luis MA Brasil
Reputação : 0
Pontos : 7
Data de inscrição : 18/04/2012

MensagemAssunto: ip dns server não funciona!   Qua Abr 18, 2012 9:40 pm

Prezados,

Já tive um roteador cisco 837 e agora estou com um 1721 com uma placa ADSL. Tudo funciona perfeitamente: firewall, conexão pppoe, DHCP etc.

Um único item nunca tive sucesso, que foi o serviço de DNS Proxy (forwarding). Já ativei o servidor DNS (ip dns server), já utilizei servidores recebidos automaticamente pelo dialer (ppp ipcp dns request), já usei servidores fixos (ip name server x.x.x.x), já configurei as máquinas para utilizarem o roteador como dns, mas nada funciona.

Do roteador, a resolução de nomes funciona, ele resolve e pinga, mas das máquinas clientes, nunca funciona.

Vocês poderiam me dar uma luz? segue minha configuração:

Router#show config
Using 4802 out of 29688 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot system flash:c1700-advsecurityk9-mz124-19.bin
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
ip inspect name SDM_LOW cuseeme
ip inspect name SDM_LOW dns
ip inspect name SDM_LOW ftp
ip inspect name SDM_LOW h323
ip inspect name SDM_LOW https
ip inspect name SDM_LOW icmp
ip inspect name SDM_LOW imap
ip inspect name SDM_LOW pop3
ip inspect name SDM_LOW netshow
ip inspect name SDM_LOW rcmd
ip inspect name SDM_LOW realaudio
ip inspect name SDM_LOW rtsp
ip inspect name SDM_LOW esmtp
ip inspect name SDM_LOW sqlnet
ip inspect name SDM_LOW streamworks
ip inspect name SDM_LOW tftp
ip inspect name SDM_LOW tcp
ip inspect name SDM_LOW udp
ip inspect name SDM_LOW vdolive
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp pool cisco
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
lease infinite
!
!
vpdn enable
!
!
!
!
crypto pki trustpoint TP-self-signed-3666573180
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3666573180
revocation-check none
rsakeypair TP-self-signed-3666573180
!
!
crypto pki certificate chain TP-self-signed-3666573180
certificate self-signed 01 nvram:IOS-Self-Sig#3030.cer
username admin privilege 15 password 0 admin
!
!
!
!
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 0/33
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
description $FW_INSIDE$
ip address 192.168.1.1 255.255.255.0
ip access-group 103 in
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
speed auto
!
interface Dialer1
description $FW_OUTSIDE$
ip address negotiated
ip access-group 104 in
ip mtu 1492
ip inspect SDM_LOW out
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent-username xxxxx password 0 xxxx
ppp ipcp dns request
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
ip dns server
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 100 remark auto generated by SDM firewall configuration
access-list 100 remark SDM_ACL Category=1
access-list 100 deny ip host 255.255.255.255 any
access-list 100 deny ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 100 remark Domain/udp
access-list 100 permit udp any eq domain any
access-list 101 permit udp any eq domain any
access-list 101 permit udp any any eq domain
access-list 102 remark auto generated by SDM firewall configuration
access-list 102 remark SDM_ACL Category=1
access-list 102 permit udp host 200.222.145.84 eq domain any
access-list 102 permit udp host 200.149.55.142 eq domain any
access-list 102 deny ip 192.168.1.0 0.0.0.255 any
access-list 102 permit icmp any any echo-reply
access-list 102 permit icmp any any time-exceeded
access-list 102 permit icmp any any unreachable
access-list 102 deny ip 10.0.0.0 0.255.255.255 any
access-list 102 deny ip 172.16.0.0 0.15.255.255 any
access-list 102 deny ip 192.168.0.0 0.0.255.255 any
access-list 102 deny ip 127.0.0.0 0.255.255.255 any
access-list 102 deny ip host 255.255.255.255 any
access-list 102 deny ip host 0.0.0.0 any
access-list 102 deny ip any any log
access-list 102 permit udp any any eq domain
access-list 102 permit udp any eq domain any
access-list 103 remark auto generated by SDM firewall configuration
access-list 103 remark SDM_ACL Category=1
access-list 103 permit udp any eq domain any
access-list 103 deny ip host 255.255.255.255 any
access-list 103 deny ip 127.0.0.0 0.255.255.255 any
access-list 103 permit ip any any
access-list 104 remark auto generated by SDM firewall configuration
access-list 104 remark SDM_ACL Category=1
access-list 104 permit udp any eq domain any
access-list 104 deny ip 192.168.1.0 0.0.0.255 any
access-list 104 permit icmp any any echo-reply
access-list 104 permit icmp any any time-exceeded
access-list 104 permit icmp any any unreachable
access-list 104 deny ip 10.0.0.0 0.255.255.255 any
access-list 104 deny ip 172.16.0.0 0.15.255.255 any
access-list 104 deny ip 192.168.0.0 0.0.255.255 any
access-list 104 deny ip 127.0.0.0 0.255.255.255 any
access-list 104 deny ip host 255.255.255.255 any
access-list 104 deny ip host 0.0.0.0 any
access-list 104 deny ip any any log
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet
!
end

Obrigado!!!!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
brangel
Associate


Número de Mensagens : 59
Idade : 37
Localização : sao paulo
Reputação : 3
Pontos : 72
Data de inscrição : 17/04/2009

MensagemAssunto: Re: ip dns server não funciona!   Sab Abr 21, 2012 7:09 pm

Tenta colocar o endereço de DNS no seu Pool de DHCP

ip dhcp pool cisco
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 4.2.2.2 ! ou tenta o Ip do seu DNS de preferencia
Voltar ao Topo Ir em baixo
Ver perfil do usuário
supercisco



Número de Mensagens : 3
Idade : 35
Localização : São Luis MA Brasil
Reputação : 0
Pontos : 7
Data de inscrição : 18/04/2012

MensagemAssunto: Resolvido   Dom Abr 22, 2012 4:19 pm

Pessoal

Já havia tentado isso, entretanto, consegui resolver o problema.

A última regra do firewall estava barrando o DNS. Coloquei uma regra antes liberando o tráfego UDP para a porta 53.

Obrigado!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
brangel
Associate


Número de Mensagens : 59
Idade : 37
Localização : sao paulo
Reputação : 3
Pontos : 72
Data de inscrição : 17/04/2009

MensagemAssunto: Re: ip dns server não funciona!   Dom Abr 22, 2012 6:24 pm

Opa Legal SuperCisco!!!!

Obrigado por compartilhar
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: ip dns server não funciona!   Hoje à(s) 3:33 pm

Voltar ao Topo Ir em baixo
 
ip dns server não funciona!
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Duvida Server/Client multiplayer inline
» SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES
» como libera porta no mikrotik para criar um server de counter strike ???
» Alguém aqui joga Priston Tale!
» MTA San Andreas

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: