Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 Configurando DHCP server no Cisco IOS

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Configurando DHCP server no Cisco IOS   Dom Jul 22, 2007 3:36 pm

Configurando DHCP server no Cisco IOS


Aqui segue mais um exemplo de que o Cisco IOS é, muitas vezes, uma mão-na-roda. Para que gastar dinheiro com hardware e software, se o próprio roteador poderá prestar o papel de "DHCP server"? Ideal para pequenas redes, escritórios, SOHO, e home-offices.


Título: Configurando DHCP server no Cisco IOS
Público-alvo: Iniciantes
Objetivos:
• Funcionamento do DHCP service em roteadores Cisco
• Configuração do DHCP service

Embora existam diversas soluções para serviços DHCP bem mais robustas, o DHCP server do Cisco IOS é bastante útil em ambientes "SOHO", home-office, e pequenas redes, que dependem de somente um roteador para a conexão com a Internet ou à matriz corporativa. Este artigo descreverá o funcionamento básico deste serviço em roteadores Cisco voltados para esta área "broadband", tais como o Cisco série 800, SOHO e uBR900. Os conceitos demonstrados aqui poderão ser utilizados em outros modelos Cisco.
DHCP
DHCP significa "Dynamic Host Configuration Protocol", e o seu papel é configurar o endereço IP automaticamente para as estações de trabalho em uma rede. Além de configurar dinamicamente o endereço IP, o DHCP configura também diversos parâmetro do TCP/IP para estas estações, entre eles os servidores DNS, default gateway, WINS servers, entre outros. O DHCP possui diversas vantagens. Citaremos algumas:
• Simplifica a administração da rede, porque alivia a tarefa de configuração do TCP/IP por parte dos administradores da rede.
• Ajuda a controlar/monitorar a utilização do espaço de endereçamento IP.
• Qualquer tarefa que exigir a modificação do plano de endereçamento em uma rede poderá ser facilmente concluída com a utilização do DHCP. "Zero-trauma" para o administrador da rede.
• Uma mudança nos endereços IP dos servidores DNS de uma rede, por exemplo, não precisa ser modificada manualmente em cada estação de trabalho. Bastaria configurar este parâmetro no servidor DHCP, que este se encarregará de configurar as estações de trabalho, informando-os sobre os novos IPs dos servidores DNS.
• Para escritórios/SOHO, uma vantagem porque não representa custos adicionais, pois não é necessário dedicar um servidor somente para serviço DHCP. Basta licenciar o Cisco IOS para podermos usufruir de todos os benefícios oferecidos pelo software. Desta forma, estaríamos eliminando os custos com hardware e, em muitos casos, software também.
Estes foram apenas alguns exemplos. A configuração DHCP em roteadores Cisco é realmente muito simples, por este motivo este artigo será pequeno :-).
Configurando o DHCP
Vamos ao que interessa. Os seguintes componentes foram utilizados para a nossa demonstração:
• Cisco 806: Um roteador Cisco para pequenas redes, podendo ser um escritório, SOHO, ou small-office. Este roteador, embora seja pequeno, oferece a mesma classe de serviço dos top de linha da Cisco. Tudo isto é possível porque o IOS deste roteador contém diversos recursos presentes em roteadores mais robustos. Configuração: 32Mb RAM, 2 interfaces Ethernet.
• Cisco IOS: c806-k9osy6-mz.12.3-1a
O nosso diagrama ilustra a disposição da rede, utilizada para este cenário de configuração:

Este cenário é bastante comum em pequenas empresas, escritórios, e coisas deste tipo. Isto poderia ser adaptado para outros exemplos, entre eles a conexão de um escritório para a matriz corporativa, onde substituiríamos a "INTERNET" pelo link dedicado entre este escritório e a matriz (LPCD, Frame-Relay...), ou ainda, poderíamos incluir a VPN entre este escritório e a matriz, aproveitando-se do cenário Internet.
Os seguintes parâmetros DHCP foram informados durante as etapas de configuração:
• ip dhcp excluded-address: Representa a faixa de endereços IP que não estará disponível para as estações de trabalho. Alguns administradores de redes costumam reservar certos endereços IP para a configuração manual em servidores e afins; basta especificá-los neste comando.
• ip dhcp pool: Equivalente ao "Scope" do DHCP server no sistema operacional Windows.
• network: A faixa de endereços IP que será distribuída para a configuração automática das estações de trabalho.
• domain-name: Este é o parâmetro TCP/IP que configurará o nome do domínio (ex: ciscotrainingbr.com) nas estações de trabalho.
• dns-server: Informa o endereço IP dos servidores DNS para as estações de trabalho.
• netbios-name-server: Informa o endereço IP dos servidores WINS.
• ip address dhcp: Este parâmetro é configurado na interface do roteador Cisco. Isto coloca o roteador na posição de "client" DHCP.
• import all: Importa todos os parâmetros DHCP aprendidos pela interface cujo parâmetro "ip address dhcp" foi configurado, para o banco de dados DHCP deste roteador. Isto será mostrado mais a frente.
Configuração do equipamento:
ip dhcp excluded-address 192.168.168.1 192.168.168.10 | estes endereços IP estão reservados
!
ip dhcp pool DHCP | Cria o pool nomeado "DHCP", onde faremos a configuração do serviço DHCP
import all | Trabalha em conjunto com o parâmetro "ip address dhcp". Importa todos os parâmetros TCP/IP aprendidos pela interface Ethernet 1 para dentro do "pool DHCP".
network 192.168.168.0 255.255.255.0 | Configura a faixa de endereços IP para o DHCP service
default-router 192.168.168.254 | Configura o parâmetro "default gateway"
domain-name ciscotrainingbr.com | Configura o parâmetro "domain name"
lease infinite | Informa o período de renovação do endereço IP. Neste caso, informamos "infinito". Você poderá especificar entre 0 a 365 dias, ou então "infinite"
interface ethernet 1 | Aciona o modo de configuração da interface Ethernet 1. Esta interface está conectada ao modem que liga toda a rede à Internet
ip address dhcp | Informa ao roteador para obter o endereço IP para a interface Ethernet 1, via DHCP. Neste caso, o provedor Internet fornecerá o IP para a interface "WAN" (ethernet 1) de nosso roteador
Note que não informamos o "dns-server". Isto porque, neste cenário, não possuímos um servidor DNS dentro da rede. Portanto, dependemos dos servidores DNS de nosso provedor Internet. Ao utilizarmos o comando "import all", os dns servers do provedor serão incluídos automaticamente dentro do "pool DHCP", e fornecidos em seguida para as estações de trabalho em nossa rede. O comando "show ip dhcp import" lista os parâmetros TCP/IP que foram importados para o pool DHCP:
Cisco-806#show ip dhcp import

Address Pool Name: DHCP
Domain Name Server(s): 24.29.99.30 24.29.99.82
O DHCP server pode configurar diversos parâmetros TCP/IP para as estações de trabalho. Utilize os comandos adicionais para a sua rede, conforme necessário. Sugiro que voce use o "?" para descobrir a sintaxe destes comandos. O comando "option" é um bom exemplo disto: existem 255 parâmetros "option" que poderão ser configurados no seu Cisco IOS!
Monitorando o DHCP
Os seguintes comandos oferecem uma forma de administração do serviço DHCP no Cisco IOS.
• show ip dhcp binding: Lista os IPs já fornecidos para as estações de trabalho.
• show ip dhcp conflict: Lista eventuais conflitos de endereços IP.
• show ip dhcp database: Lista o DHCP database.
• show ip dhcp pool: Lista todo o conteúdo dos pools configurados.
• show ip dhcp relay information trusted-sources: Lista as informações sobre o relay DHCP.
• show ip dhcp server statistics: Mostra as estatísticas do tráfego DHCP.
Em situações onde nada funciona, as seguintes opções para debugging estão disponíveis:
• debug ip dhcp server events: Muito útil para mostrar os "empréstimos" e "expirations" dos endereços IP.
• debug ip dhcp server linkage: Server para diagnosticar eventos em situações onde existem relações entre dois ou mais servidores DHCP (esquema "parent/child", tais como radix tree).
• debug ip dhcp server packet: Mostra o tráfego DHCP em tempo real.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
 
Configurando DHCP server no Cisco IOS
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES
» Controle de banda por IP em DHCP Server
» DHCP Server Authoritative E Bootp
» Dhcp server status busy
» como bloquear dhcp vindo do cliente

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Artigos :: Artigos de usuários-
Ir para: