Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 Duvida DHCP Router

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
joaormv



Número de Mensagens : 24
Idade : 26
Localização : São Paulo
Reputação : 0
Pontos : 43
Data de inscrição : 28/04/2011

MensagemAssunto: Duvida DHCP Router   Seg Ago 01, 2011 12:28 pm

Pessoal estou com uma duvida sobre configuração de DHCP eem um router Cisco 2851.

Antes havia apenas um escopo criado e eu criei mais um escopo no router.
Porém o router ainda não distribuiu nenhum Ip deste novo escopo de modo automatico.
Somente Ips fixos foram distribuidos.


Oque pode estar acontecendo ?
Faltou aluma config no router?


Olhei guias de comandos Cisco e esta igualzinho como eles pedem.


Agraceço a ajuda.


Abraços.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: Duvida DHCP Router   Ter Ago 02, 2011 4:53 am

Sem você exibir suas configs ou colocar mais detalhes, não poderemos ajudar...

Passe mais informações para podermos ajudá-lo.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
joaormv



Número de Mensagens : 24
Idade : 26
Localização : São Paulo
Reputação : 0
Pontos : 43
Data de inscrição : 28/04/2011

MensagemAssunto: Configs   Qua Ago 03, 2011 5:29 pm



Ips excluidos da rede

ip dhcp excluded-address 10.10.64.2 10.10.64.70

Config do Pool

ip dhcp pool NewSub.com.br
network 10.10.64.0 255.255.255.0
default-router 10.10.64.1
domain-name MINHAEMPRESA.com.br
netbios-node-type h-node
dns-server 172.17.0.32 172.17.0.34
netbios-name-server 172.17.0.32 172.17.0.34
lease 8

Ip secundario da interface de lan do router

interface GigabitEthernet0/1
ip address 10.10.64.1 255.255.255.0 secondary
ip address 10.10.63.1 255.255.255.0
duplex full
speed 100

Será que falta alguma coisa ?

Shocked
Voltar ao Topo Ir em baixo
Ver perfil do usuário
joaormv



Número de Mensagens : 24
Idade : 26
Localização : São Paulo
Reputação : 0
Pontos : 43
Data de inscrição : 28/04/2011

MensagemAssunto: Faltou   Qua Ago 03, 2011 5:34 pm



Queria dizer que consigo pingar a interface lan do router e um sw que configurei com ip do novo pool.
Porém, as máquinas não pegam Ip dinamicamente como deveriam.



Abraços a todos.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: Duvida DHCP Router   Sex Ago 05, 2011 6:25 am

Aparentemente está ok!
Se você tem um outro DHCP pool para o IP primário, é ele que vai ser usado. aí explicaria o o motivo pelo qual seu DHCP para subnet 10.10.64.0/24 não está rolando.

Corrija o excluded IP. Você deve englobar o 10.10.64.1.

ip dhcp excluded-address 10.10.64.1 10.10.64.70


Abraços,
Voltar ao Topo Ir em baixo
Ver perfil do usuário
joaormv



Número de Mensagens : 24
Idade : 26
Localização : São Paulo
Reputação : 0
Pontos : 43
Data de inscrição : 28/04/2011

MensagemAssunto: Duvida DHCP Router   Sex Ago 05, 2011 10:23 am

Cara só me responda uma coisa.

Esse novo pool deve ser usado assim que os Ip's do outro acabar.
Correto ?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: Duvida DHCP Router   Sex Ago 05, 2011 8:41 pm

Correto.

Apenas quando acabar todos os IPs disponíveis para o primário é que ele fornecerá IPs referente ao secundário.

If the client is directly connected (the giaddr field is zero), the DHCP Server matches the DHCPDISCOVER with DHCP pool(s) that contain the subnet(s) configured on the receiving interface. If the interface has secondary IP addresses, the subnets associated with the secondary IP addresses are examined for possible allocation only after the subnet associated with the primary IP address (on the interface) is exhausted.

Talvez valha uma tentativa de reproduzir isso em laboratório: GNS3


Configure um /30 na interface e um DHCP pool de apenas 1 IP.
Configure outro DHCP pool, o qual será atrelado ao IP secundário.

Configure a interface com o IP primário send pertencente a subnet /30
Ative um host e veja qual IP ele pega. (esperamos pegar o do primário, terminando assim os IPs do pool primário).
Ative um segundo host e veja se ele pega um IP referente ao pool do IP secundário.

Só não fiz, pois meu notebook morreu hoje, 10 minutos atrás hehe..
Neste que estou agora, não tenho o GNS3

Abraços,
Voltar ao Topo Ir em baixo
Ver perfil do usuário
joaormv



Número de Mensagens : 24
Idade : 26
Localização : São Paulo
Reputação : 0
Pontos : 43
Data de inscrição : 28/04/2011

MensagemAssunto: Obrigado   Seg Ago 08, 2011 11:44 am


Origado pela ajuda manim.
Sanou minha duvida.


Abraços.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: Duvida DHCP Router   Seg Ago 08, 2011 11:18 pm

Fiz o teste e funcionou:

IP primário: 10.10.10.1/30 (1 host disponível, já que o .1 é do gateway)
IP Secundário: 20.20.20.1/24


CONFIG:

ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 20.20.20.1 20.20.20.70


ip dhcp pool NewSub.com.br
network 10.10.10.0 255.255.255.252
default-router 10.10.10.1
domain-name MINHAEMPRESA.com.br
netbios-node-type h-node
dns-server 172.17.0.32 172.17.0.34
netbios-name-server 172.17.0.32 172.17.0.34
lease 8

ip dhcp pool NewSubSec.com.br
network 20.20.20.0 255.255.255.0
default-router 20.20.20.1
domain-name MINHAEMPRESASEC.com.br
netbios-node-type h-node
dns-server 172.17.0.32 172.17.0.34
netbios-name-server 172.17.0.32 172.17.0.34
lease 8

int f0/0
no switchport
ip add 10.10.10.1 255.255.255.252
ip add 20.20.20.1 255.255.255.0 sec
no shut


===================

Debugando para ver o flow:

R1#debug ip dhcp server pac


Ligando o primeiro host:

*Mar 1 00:03:03.723: DHCPD: DHCPDISCOVER received from client 0100.aa00.7561.00 on interface FastEthernet0/0.
*Mar 1 00:03:03.727: DHCPD: Allocate an address without class information (10.10.10.0)
R1#
*Mar 1 00:03:05.727: DHCPD: Sending DHCPOFFER to client 0100.aa00.7561.00 (10.10.10.2).
*Mar 1 00:03:05.727: DHCPD: creating ARP entry (10.10.10.2, 00aa.0075.6100).
*Mar 1 00:03:05.731: DHCPD: unicasting BOOTREPLY to client 00aa.0075.6100 (10.10.10.2).
*Mar 1 00:03:05.867: DHCPD: DHCPREQUEST received from client 0100.aa00.7561.00.
*Mar 1 00:03:05.867: DHCPD: Appending default domain from pool
*Mar 1 00:03:05.867: DHCPD: Using hostname 'box.MINHAEMPRESA.com.br.' for dynamic update (from hostname option)
*Mar 1 00:03:05.867: DHCPD: Sending DHCPACK to client 0100.aa00.7561.00 (10.10.10.2).
*Mar 1 00:03:05.871: DHCPD: creating ARP entry (10.10.10.2, 00aa.0075.6100).
R1#
*Mar 1 00:03:05.871: DHCPD: unicasting BOOTREPLY to client 00aa.0075.6100 (10.10.10.2).
R1#


Ligando o segundo host:

R1#
*Mar 1 00:04:20.547: DHCPD: DHCPDISCOVER received from client 0100.aa00.db8e.00 on interface FastEthernet0/0.
*Mar 1 00:04:20.551: DHCPD: Allocate an address without class information (10.10.10.0)
*Mar 1 00:04:20.551: DHCPD: Allocate an address without class information (20.20.20.0)
R1#
*Mar 1 00:04:22.551: DHCPD: Sending DHCPOFFER to client 0100.aa00.db8e.00 (20.20.20.71).
*Mar 1 00:04:22.551: DHCPD: creating ARP entry (20.20.20.71, 00aa.00db.8e00).
*Mar 1 00:04:22.555: DHCPD: unicasting BOOTREPLY to client 00aa.00db.8e00 (20.20.20.71).
*Mar 1 00:04:22.587: DHCPD: DHCPREQUEST received from client 0100.aa00.db8e.00.
*Mar 1 00:04:22.591: DHCPD: Appending default domain from pool
*Mar 1 00:04:22.591: DHCPD: Using hostname 'box.MINHAEMPRESASEC.com.br.' for dynamic update (from hostname option)
*Mar 1 00:04:22.591: DHCPD: Sending DHCPACK to client 0100.aa00.db8e.00 (20.20.20.71).
R1#
*Mar 1 00:04:22.591: DHCPD: creating ARP entry (20.20.20.71, 00aa.00db.8e00).
*Mar 1 00:04:22.595: DHCPD: unicasting BOOTREPLY to client 00aa.00db.8e00 (20.20.20.71).



Checando o DHCP:

R1#sh ip dhcp bi
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
10.10.10.2 0100.aa00.7561.00 Mar 09 2002 12:03 AM Automatic
20.20.20.71 0100.aa00.db8e.00 Mar 09 2002 12:04 AM Automatic


Pingando:

R1#ping 10.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/25/44 ms


R1#ping 20.20.20.71

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 20.20.20.71, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/91/328 ms





Como visto acima, funfa beleza!!!!

Se tiver DHCP pool configurado para o IP primário e outro para o secundário, só quando acabarem os IPs disponíveis do pool primário é que o pool do IP secundário irá fornecer IPs.

Abraços,
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Duvida DHCP Router   Hoje à(s) 12:58 pm

Voltar ao Topo Ir em baixo
 
Duvida DHCP Router
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Repetidor AP Router
» [Resolvido]Duvida com jogo online
» [DUVIDA] Teria como colocar Boot para punbb
» Duvida com submenu
» Duvida GPS

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: