Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 como especificar dhcp para que o host pegue ip do dhcp certo

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
almirf
Associate


Número de Mensagens : 56
Idade : 42
Localização : Teresopolis - RJ
Reputação : 1
Pontos : 128
Data de inscrição : 02/11/2009

MensagemAssunto: como especificar dhcp para que o host pegue ip do dhcp certo   Sex Abr 02, 2010 12:47 pm

Amigos

tenho 2 dhcps. um é de dados e outro é de voz
o de dados é a rede 10.135.30.0
o de voz é a rede 10.135.44.0

funciona assim. chega um cabo de rede ao telefone ip . e do telefone ip vai um caboao pc, ou seja um unico cabo sai do switch pros dois devices!
a vlan de voz é vlan 2 e a vlan de dados é vlan 10

como é um unico cabo que alimenta o tel e o pc eu tenho que por o switch em trunk
e este switch esta ligado ao router em trunk!

e algumas estacoes de voz estao pegando ip no dhcp de dados
e a vlan de voz esta configurado na porta corretamente que é a vlan 2 (em vlan voice)

1* - entao como fazer para impedir que telefones ip peguem ip no dhcp de dados??

2* - existe algum comando especial para dizer que o dhcp dakela estação é o ip X afim de nao pegar ip em outro dhcp ?

Grato
Almir
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: como especificar dhcp para que o host pegue ip do dhcp certo   Qua Abr 07, 2010 4:43 am

Que switch você está usando (marca/modelo)?

Se for cisco, há várias maneiras...

switchport voice {detect cisco-phone [full-duplex] | vlan {vlan-id | dot1p | none | untagged}}

Configure how the Cisco IP Phone carries voice traffic:

•detect—Configure the interface to detect and recognize a Cisco IP phone.

•cisco-phone—When you initially implement the switchport voice detect command, this is the only allowed option. The default is no switchport voice detect cisco-phone [full-duplex].

•full-duplex—(Optional) Configure the switch to only accept a full-duplex Cisco IP phone.

•vlan-id—Configure the phone to forward all voice traffic through the specified VLAN. By default, the Cisco IP Phone forwards the voice traffic with an IEEE 802.1Q priority of 5. Valid VLAN IDs are 1 to 4094.

•dot1p—Configure the phone to use IEEE 802.1p priority tagging for voice traffic and to use the default native VLAN (VLAN 0) to carry all traffic. By default, the Cisco IP Phone forwards the voice traffic with an IEEE 802.1p priority of 5.

•none—Allow the phone to use its own configuration to send untagged voice traffic.

•untagged—Configure the phone to send untagged voice traffic.



Geralmente, usa-se untagged vlan. Para tanto, deve-se definir uma native vlan na interface. Untagged packets vão para a native vlan (voz), dessa forma, separando a vlan de voz e dados.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
almirf
Associate


Número de Mensagens : 56
Idade : 42
Localização : Teresopolis - RJ
Reputação : 1
Pontos : 128
Data de inscrição : 02/11/2009

MensagemAssunto: Re: como especificar dhcp para que o host pegue ip do dhcp certo   Qua Abr 07, 2010 9:45 pm

Vamos la

estou usando um cisco 2621 ! e swtches 2960 24p
o telefone ip é da siemens e permite cadastrar a vlan no telefone

o telefone naos endo cisco como sera o melhor jeito de configurar no switch 2960 ?

Grato
Almir
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: como especificar dhcp para que o host pegue ip do dhcp certo   Qui Abr 08, 2010 8:50 am

Bom eu sei um jeito de forçar uma entrada estatica dentro do escopo DHCP, fiz um lab estes dias para entender como funciona... Segue:

Referente a configuração de entrada estática em DHCP, segue informação e referência da Cisco:

"Some DHCP clients send a client identifier (DHCP option 61) in the DHCP packet. To configure manual bindings for such clients, you must enter the client-identifier DHCP pool configuration command with the appropriate hexadecimal values identifying the DHCP client. To configure manual bindings for clients who do not send a client identifier option, you must enter the hardware-address DHCP pool configuration command with the appropriate hexadecimal hardware address of the client. "

http://www.cisco.com/en/US/docs/ios/ipaddr/configuration/guide/iad_dhcp_svr_cfg.html

Quando o host encaminha a identificação de DHCP (61) o comando correto é o client-identifier ou client-id.

Se quisermos criar um pool para cada entrada estática, usamos o client-identifier, se quisermos utilizar o mesmo pool usamos o client-id.

Quando o host não encaminhar a identificação o comando correto é o hardware-address.

Com isso segue script testado em laboratório:

ip dhcp pool TESTE
network 1.1.1.0 255.255.255.0
default-router 1.1.1.1
dns-server 208.67.220.220 208.67.222.222
domain-name cisco
address 1.1.1.123 client-id 0100.90f5.7bf8.82

Para detectar se o host manda ou não o client, primeiro plugamos ele na rede e deixamos o dhcp fornecer um ip dinamico:

Switch#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
1.1.1.4 0100.1906.5c99.64 Mar 02 1993 12:27 AM Automatic

Como podemos observar o host forneceu esta entrada (0100.1906.5c99.64) o MAC normal seria (0019.065c.9964), logo, vamos usar o client identifier:

Switch#conf t
Switch(config)#ip dhcp pool TESTE
Switch(config-dhcp)#address 1.1.1.130 client-id 0100.1906.5c99.64
Switch(config-dhcp)#end
ip dhcp pool TESTE
network 1.1.1.0 255.255.255.0
default-router 1.1.1.1
dns-server 208.67.220.220 208.67.222.222
domain-name cisco
address 1.1.1.123 client-id 0100.90f5.7bf8.82
address 1.1.1.130 client-id 0100.1906.5c99.64
lease infinite
Os testes foram efetuados com o IOS c3560-ipservicesk9-mz.122-50.SE.bin

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
Conteúdo patrocinado




MensagemAssunto: Re: como especificar dhcp para que o host pegue ip do dhcp certo   Hoje à(s) 7:29 am

Voltar ao Topo Ir em baixo
 
como especificar dhcp para que o host pegue ip do dhcp certo
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Como faço para colocar pessonagem no Game marke
» [Resolvido] Como colocar categoria para rank específico.
» Como faço para aumentar essa imagem?
» [DUVIDA] Teria como colocar Boot para punbb
» Como colocar icone para cada TÓPICO no fórum?

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: