Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 Rotas indo pelo caminho errado. me ajudem

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
almirf
Associate


Número de Mensagens : 56
Idade : 42
Localização : Teresopolis - RJ
Reputação : 1
Pontos : 128
Data de inscrição : 02/11/2009

MensagemAssunto: Rotas indo pelo caminho errado. me ajudem    Qua Mar 21, 2012 8:46 am

Amigos

Tenho dois roteadores de frame relay. cada um tem uma subinterface atm . o Roteador 1 é o principal e o 2 é o de backup (contigencia).

as duas atms estao ligados no mesmo roteador e que chegam na outra ponta que é um cisco 2621 atraves de um unico cabo serial.

Porem ao fazer o tracert para o outro lado tenho problemas

ao fazer tracer para a loopback do roteador do outro lado ele esta indo Pelo Roteador 2. E no roteador tenho duas subinterfaces. f0/0.10 e f0/0.20 .

Ao fazer tracert para um switch1 ele vai pelo roteador 1. Ao fazer tracert para um switch2 ele vai pelo roteador 2. como resolver isso ?

Oo roteador de backup tem a metrica maior na configuracao das rotas estaticas (200), ma snao esta resolvendo !

como resolver isso ? As configuraçoes seguem abaixo

*** No Roteador 1 - Principal lado de ca
interface ATM1/0.995 point-to-point
bandwidth 512
ip address 10.132.255.93 255.255.255.252
pvc RJ0995 0/995
class-vc 512k
service-policy output PRIORIZA_512

ip route 10.132.0.105 255.255.255.255 ATM1/0.995
ip route 10.132.213.0 255.255.255.0 ATM1/0.995
ip route 10.132.214.0 255.255.255.0 ATM1/0.995

*** No Roteador 2 - Backup lado de cá

No Roteador Principal
interface ATM1/0.995 point-to-point
bandwidth 512
ip address 10.132.255.93 255.255.255.252
pvc RJ0995 0/995
class-vc 512k
service-policy output PRIORIZA_512

ip route 10.132.0.105 255.255.255.255 ATM1/0.995 200
ip route 10.132.213.0 255.255.255.0 ATM1/0.995 200
ip route 10.132.214.0 255.255.255.0 ATM1/0.995 200

*** No roteador da outra ponta. aonde esta chegando uma unica serial mas que possui dois dlci's

interface Serial0/1
bandwidth 512
no ip address
max-reserved-bandwidth 90
encapsulation frame-relay IETF
ip route-cache flow
no ip mroute-cache
load-interval 30
no fair-queue
frame-relay traffic-shaping
frame-relay lmi-type ansi
!
!
! interface s0/1.16 ligada ao roteador 1 - PRINCIPAL - dlci 16 é a principal
!
interface Serial0/1.16 point-to-point
bandwidth 512
ip address 10.132.255.90 255.255.255.252
frame-relay interface-dlci 16
class FRELAY
!
! interface s0/1.17 ligada ao roteador 2 - BACKUP - dlci 17 é a de backup
!
interface Serial0/1.17 point-to-point
bandwidth 512
ip address 10.132.255.94 255.255.255.252
frame-relay interface-dlci 17
class FRELAY
!
!
Roteamento
!
!
ip route 0.0.0.0 0.0.0.0 serial0/1.16
ip route 0.0.0.0 0.0.0.0 serial0/1.17 200
!
!
Segue na topologia
!
!
http://imageshack.us/photo/my-images/207/dlci2.jpg
Voltar ao Topo Ir em baixo
Ver perfil do usuário
marcelosguerra
Admin


Número de Mensagens : 81
Idade : 33
Localização : Sao Paulo - SP
Reputação : 16
Pontos : 80
Data de inscrição : 24/07/2007

MensagemAssunto: Re: Rotas indo pelo caminho errado. me ajudem    Seg Mar 26, 2012 12:24 pm

almirf, tudo bem?

Entendi o objetivo, mas não ficou muito claro de onde você esta realizando os testes e os ips dos equipamento envolvidos.

Qual é a relação desta looback com as subs f0/0.10 e f0/0.20?

Onde está este Switch1 e Switch2 que você menciona?

Isso é cenário real ou um LAB?

Resumo:
Conforme Figura, acredito que sua topologia está assim:

Conexão Principal:
---------------------

Hosts.CPD(Almir) --- Sw_CPD1---RTCore1----LinkFrame1----RT2621--SW--hostscliente


Conexão Backup:
--------------------

Hosts.CPD(Almir) --- Sw_CPD2---RTCore2----LinkFrame2----RT2621--SW--hostscliente


Perguntas:
Quais são os Ips de Looback dos Routers, switches nesta topologia?
Qual é o Ip do Hosts.CPD(Almir)?
Qual é o Ip do hostscliente?
De quem é a loopback que voce fez o tracert e de onde vc fez tracert?

Testes:
Tracert de Hosts.CPD(Almir) para hostscliente - Funcionou pelo principal?
Tracert de RTCore1 para hostscliente - Funcionou pelo principal?
Tracert de hostscliente para Hosts.CPD(Almir) - Funcionou pelo principal?

Adicione abaixo os logs do seus testes e de qual equipamento foram feitos:


Abraços,
Marcelo Guerra
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: Rotas indo pelo caminho errado. me ajudem    Ter Mar 27, 2012 1:48 am

Não costumo fazer isso, de dar respostas rápidas e imprecisas, mas estou sem tempo. Aí vai minha contribuição.

Quando temos um flow, temos que pensar que temos a ida e a volta!!!

Tem que analisar como o tráfego se compo


Primeiro: O valor que você coloca na rota estática, logo após a rota, é a distância administrativa.
Basicamente, ela só vai ser utilizada para comparar com outras rotas no próprio roteador (se vc tem uma rota com AD 1 (padrão) e outra com 254, a 254 só vai ser usada quando a com AD 1 estiver inativa. Isso se chama floating route.
Você aplicou isso em dois diferentes routers, o qual não vai ter efeito algum, já que eles não interagem entre si.

Como resolveria:

HSRP ou VRRP configurado na interface LAN dos roteadores conectados ao switch.
Defina o gateway dos hosts sendo o IP virtual do HSRP.
Defina o principal com um priority maior.
Faça tracking da interface WAN do roteador principal.
Quando ocorrer uma falha na interface LAN, se o roteador principal cair ou se a interface WAN do router principal cair, a conexão é comutada para o roteador secundário.



Visualizo outras possibilidades melhores, como rodar protocolo dinâmico, já que, dependendo da situação, se cair uma das interfaces, com rota estática,pode-se ter o pacote enviado para um next hop que não conheça a rede.

Exemplo:

Imagine que a interface LAN do seu router principal está down.
O router secundário assume do ponto de vista da LAN
Um usuário da LAN envia um request para um destino remoto.
O pacote chega no destino
Destino envia a resposta
Roteador recebe o pacote, analisa a tabela de roteamento e acha uma rota estática apontando para o roteador primário, que possui a interface LAN down.
Roteador primario recebe, mas como ele está com sua interface LAN down, não terá rota em sua tabela de roteamento para o endereço de origem. Portanto, ele dropará o pacote.

(Lembre-se: Ida e Volta!!!. No exemplo acima, a ida foi com sucesso, mas o retorno deu problema)



Como disse, não expliquei muito bem, pois estou sem tempo esses dias. Apenas bati o olho e já visualizei alguns problemas em seu ambiente.

Espero ter ajudado de alguma forma.

Abraços
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: Rotas indo pelo caminho errado. me ajudem    Sex Abr 13, 2012 4:23 pm

Você colou a configuração errado ou esta errado no router mesmo (acho que vc só colou errado)?
Observe:
No Roteador 1 vc esta com o IP 10.132.255.93/30
No roteador 2 vc também esta com o IP 10.132.255.93/30
Pela configuração do router remoto, o roteador 1 deveria ser 10.132.255.89/30

Pelo que entendi:
Quando vc faz o tracert do Router-PT (2621) para seu core ele esta indo correto.
O problema é no sentido CORE -> remoto, correto?

Nesse caso seu problema esta antes desses routers CORE de que vc esta informando.
Esse switch CORE é layer 3?
Ele deve estar balanceando o trafego, isso explicaria porque um destino vai por um caminho e o outro destino por outro (balanceamento por fluxo).

abs,

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
Conteúdo patrocinado




MensagemAssunto: Re: Rotas indo pelo caminho errado. me ajudem    Hoje à(s) 11:10 pm

Voltar ao Topo Ir em baixo
 
Rotas indo pelo caminho errado. me ajudem
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» endereço eletronico errado
» Desesperoo!! pessoal me ajudem por favor
» Salvando temas Baixados pelo Kies
» [Tutorial] Como fazer icones pelo photoshop!
» Ajudem com inventario diferente???

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: