Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 Dois IPs externos em uma fast ethernet

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
tcarvalho



Número de Mensagens : 5
Idade : 42
Localização : Rio de Janeiro
Reputação : 0
Pontos : 7
Data de inscrição : 15/03/2012

MensagemAssunto: Dois IPs externos em uma fast ethernet   Qui Mar 15, 2012 10:03 pm

Senhores,

Tenho um roteador com duas interfaces fast ethernet, uma estou utilizando para a rede interna, a outra possui dois IPs de duas operadoras diferentes, ou seja, um IP primário (operadora A) e um IP secundário (operadora B). O roteador está conectada em um switch onde estão os roteadores das duas operadoras.
O problema é, quando desconecto o link da operadora B consigo o roteamento default funciona normalmente pela operadora A, porém, quando desconecto o link da operadora A, não consigo rotear os pacotes, mesmo utilizando duas rotas default, uma com o IP do próximo salto de cada operadora.
Alguém sabe se existe alguma limitação?

ip route 0.0.0.0 0.0.0.0 [ip próximo salto operadora A]
ip route 0.0.0.0 0.0.0.0 [ip próximo salto operadora B]
Voltar ao Topo Ir em baixo
Ver perfil do usuário
marcelosguerra
Admin


Número de Mensagens : 81
Idade : 33
Localização : Sao Paulo - SP
Reputação : 16
Pontos : 80
Data de inscrição : 24/07/2007

MensagemAssunto: Re: Dois IPs externos em uma fast ethernet   Qui Mar 22, 2012 4:45 am

tcarvalho, boa tarde.

Problemas assim podem acontecer quando há uma queda no meio do caminho e a interface local ou acesso local continua ativos.
Com isso as rotas continuam ativas, mesmo que link não funcione.

Como pode ser o exemplo da rota default ativa na operadora A.

Se este é o seu caso, existe uma solucão de contorno que utilizo IP SLA Monitor ou a Criação de Tunnel para monitorar.

Procure sobre o assunto: "IP SLA Monitor"

Algumas dicas sobre IP SLA:
http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/813-cisco-router-ipsla-basic.html

http://blog.nexthop.com.br/2009/02/um-roteador-dois-provedores-e-alguma.html


Tenho alguns roteadores assim, config exemplo:
----------------------------------------------------------------
Versão1 - Exemplo de configuração Simples.
----------------------------------------------------------------

ip sla monitor responder
ip sla monitor 5
type echo protocol ipIcmpEcho (ip próximo salto operadora A)
request-data-size 10
timeout 2000
frequency 2
ip sla monitor schedule 5 life forever start-time now
ip sla monitor 6
type echo protocol ipIcmpEcho (ip próximo salto operadora B)
request-data-size 10
timeout 2000
frequency 2


track 5 rtr 5 reachability
delay down 8 up 30
!
track 6 rtr 6 reachability
delay down 8 up 30


ip route 0.0.0.0 0.0.0.0 [ip próximo salto operadora A] track 5
ip route 0.0.0.0 0.0.0.0 [ip próximo salto operadora B] track 6

------------------------------------------------------------------



Considerações:
1º - Está acima é a configuração simples.
2º - Caso sua topologia for site to site, se ocorrer uma falha,
no meio de rede da operadora, não vai funcionar.
3º - Para a topologia Site to Site, vou fazer um resumo.
---

CPD_SP ---- Via Operadora A ----- Filial_RJ
CPD_SP ---- Via Operadora B ----- Filial_RJ



****************************************************************
Versão2 - Exemplo de configuração site to site.
Config no router do Site: CPD_SP

--------------------------------------------------------------
ip sla monitor responder
ip sla monitor 5
type echo protocol ipIcmpEcho 192.168.11.1 "Via link operadora A"
request-data-size 10
timeout 2000
frequency 2
ip sla monitor schedule 5 life forever start-time now
ip sla monitor 6
type echo protocol ipIcmpEcho 192.168.50.50 "Via link operadora B"
request-data-size 10
timeout 2000
frequency 2


track 5 rtr 5 reachability
delay down 8 up 30
!
track 6 rtr 6 reachability
delay down 8 up 30


ip route 0.0.0.0 0.0.0.0 [salto op A Filial_RJ) track 5
ip route 0.0.0.0 0.0.0.0 [salto op B Filial_RJ) track 6
ip route 192.168.11.1 255.255.255.255 [salto op A Filial_RJ)]
ip route 192.168.50.1 255.255.255.255 [salto op B Filial_RJ)]



-----------------------------------------
Filial_RJ - Configurar os IP na filial.
------------------------------------------
interface Loopback 11
description Monitorar a conexão da operadora A
ip address 192.168.11.1 255.255.255.255

interface Loopback 50
description Monitorar a conexão da operadora B
ip address 192.168.50.1 255.255.255.255


-----------------------------------------
Filial_RJ - Configurar acl - para evitar o trafego da opera A.
------------------------------------------
1º)
access-list 120 deny icmp host 192.168.11.1 any
access-list 120 permit ip any any

2º)
Associar ACL 120 na na interface da operadora B.

****************************************************************


Portanto,

Recomendo estudar direitinho o caso, sobre IP SLA ou Tunel.
Também alerto para tomar cuidado caso não tenha conhecimento em redes.


Abraços,
Marcelo Guerra.

Voltar ao Topo Ir em baixo
Ver perfil do usuário
tcarvalho



Número de Mensagens : 5
Idade : 42
Localização : Rio de Janeiro
Reputação : 0
Pontos : 7
Data de inscrição : 15/03/2012

MensagemAssunto: Re: Dois IPs externos em uma fast ethernet   Qui Mar 22, 2012 11:35 am

Oi Marcelo,

Muito obrigado por sua resposta, eu já havia utilizado o IP SLA e a alteração da rota foi bem executada, mesmo assim não funciona.
Porém, vi que em um dos seus exemplos você utilizou LOOPBACK, vou caminhar nesse sentido e depois passarei a respota.

Muito obrigado.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
tcarvalho



Número de Mensagens : 5
Idade : 42
Localização : Rio de Janeiro
Reputação : 0
Pontos : 7
Data de inscrição : 15/03/2012

MensagemAssunto: Re: Dois IPs externos em uma fast ethernet   Sex Mar 23, 2012 10:15 am

Marcelo,

Como já havia falado, a configuração do IP SLA funciona perfeitamente e as rotas default são alterada conforme previsto.
Porém, continuo com o mesmo problema. Quando o link do IP primário cai, o secundário também cai. Só relembrando estou utilizando apenas uma fast ethernet com os IPs primário e secundário.

interface FastEthernet0/0
description "External"$ETH-WAN$
ip address 189.xxx.xxx.172 255.255.255.240 secondary
ip address 200.xxx.xxx.10 255.255.255.192
ip access-group 111 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip virtual-reassembly
no ip route-cache cef
no ip route-cache
ip tcp adjust-mss 1300
duplex auto
speed auto
no mop enabled
Voltar ao Topo Ir em baixo
Ver perfil do usuário
marcelosguerra
Admin


Número de Mensagens : 81
Idade : 33
Localização : Sao Paulo - SP
Reputação : 16
Pontos : 80
Data de inscrição : 24/07/2007

MensagemAssunto: Re: Dois IPs externos em uma fast ethernet   Seg Mar 26, 2012 11:07 am

Temos que levar em consideração que você usou o mesma fast para agregar duas operadoras, não sei porque foi feito isso, se foi por ausência de porta fast no router, ou qual o motivo, isso poderia ser feito com sub-interface para cada operadora e vlans no switch.

Outro ponto, é que temos que entender, como foi feito este projeto e está este projeto, conexão física, roteamento, qual a finalidade dos links, se liga uma ou mais filiais, pois o pessoal do fórum precisa entender como tudo está relacionado.

Mas chegamos na etapa que você deve entender porque motivo está parando e agora não é uma questão de comutação automática e sim de conectividade.

Use: comandos ping com source ou traceroute, para identificar onde e porque está parando quando isola a operadora A.

Segue:
1-Descreva a sua topologia? é um core ligando varias filiais? o que é? para que é? Existe protocolo de roteamento?
Primeiro de tudo temos que saber como esta sua topologia, do inicio ao fim.

2-Sem configurar SLA ou derrubar o link, se você retirar a rota default A, continua funcionando através da B?
--> Use Ping / Tracert (CMD) e Traceroute (Router) / sh ip route | Para verificar onde está parando.

3- Deixe A e B ativas, se fizer um ping para destino com source de B, funciona?
Ex: ping (IP_Dest.Filial) source 189.xxx.xxx.172
Pode ser problema de roteamento na operadora B.

4-Somente pela operadora B já funcionou algum dia?, se voce deixar somente a operadora B configurada(Sem rota default de A) funciona? (Use ping...etc). Caso não onde para?

5-Como você está isolando a rede da Opera A? físico ou logico? tendo em vista que em um determinado ponto as operadora A e B utilizam o mesmo caminho?


Abraços,
Marcelo Guerra
Voltar ao Topo Ir em baixo
Ver perfil do usuário
tcarvalho



Número de Mensagens : 5
Idade : 42
Localização : Rio de Janeiro
Reputação : 0
Pontos : 7
Data de inscrição : 15/03/2012

MensagemAssunto: Re: Dois IPs externos em uma fast ethernet   Qui Mar 29, 2012 5:10 pm

Marcelo,

Muito obrigado por sua ajuda, segue as inforções solicitadas.

Deveríamos utilizar um link serial e um ethernet, porém, a empresa responsável pela entrega do serial, entrengou ethernet, por esse motivo, e pela falta de uma outra interface fast, estamos utilizando dois IP em uma interface.
Estou utilizando um switch para concentrar o roteador em questão e os dois links das operadoras. Já pensei em utilizar VLAN, mas o switch não suporta.
Segue:
1-Descreva a sua topologia? é um core ligando varias filiais? o que é? para que é? Existe protocolo de roteamento?
Primeiro de tudo temos que saber como esta sua topologia, do inicio ao fim.
Esse roteador está em uma filial, é fechado um túnel com a matriz (que está funcionando perfeitamente), o acesso a internet é por um NAT (que também está funcionando).

2-Sem configurar SLA ou derrubar o link, se você retirar a rota default A, continua funcionando através da B?
--> Use Ping / Tracert (CMD) e Traceroute (Router) / sh ip route | Para verificar onde está parando.

Se retirar a rota da operadora A, continua funcionando pela operadora B, porém, verifiquei com o TRACEROUTE que o próximo salto é o da operadora A.

3- Deixe A e B ativas, se fizer um ping para destino com source de B, funciona?
Ex: ping (IP_Dest.Filial) source 189.xxx.xxx.172
Pode ser problema de roteamento na operadora B.
Funciona. Também descarto problemas no roteamento da operadora B pois, quando o coloco com o IP primário na interface, o problema inverte.

4-Somente pela operadora B já funcionou algum dia?, se voce deixar somente a operadora B configurada(Sem rota default de A) funciona? (Use ping...etc). Caso não onde para?
Funciona apenas se o IP estiver como primário, ou se não derrubar o link da operadora A. sempre o pacote está saindo pelo próximo salto do IP primário.

5-Como você está isolando a rede da Opera A? físico ou logico? tendo em vista que em um determinado ponto as operadora A e B utilizam o mesmo caminho?
Para testes, desligo o cabo da operadora A do switch.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
marcelosguerra
Admin


Número de Mensagens : 81
Idade : 33
Localização : Sao Paulo - SP
Reputação : 16
Pontos : 80
Data de inscrição : 24/07/2007

MensagemAssunto: Re: Dois IPs externos em uma fast ethernet   Sab Mar 31, 2012 8:25 pm

tcarvalho,

Entendi, fiz uma simulação no GNS3 e realmente estava ocorrendo na forme que mencionou.
Devido a rota default que estava ativa, não deixa o trafego escoar para a outra conexão no momento da queda, pois ela não entende que o link ficou down e continua enviando os pacotes para o IP da operadora que ficou down.

Para funcionar criei o script abaixo, e a comutação ficou automática.
Simulei diversas vezes no GNS3 e comutou normalmente.


Script:
Não esqueça de alterar os IPs da Operadoras.



IPWAN_Operadora_A: 200.200.200.11
IPWAN_Operadora_B: 189.189.189.173

=============================================================
ip sla monitor responder
ip sla monitor 5
type echo protocol ipIcmpEcho 200.200.200.11
request-data-size 10
timeout 2000
frequency 2
ip sla monitor schedule 5 life forever start-time now
ip sla monitor 6
type echo protocol ipIcmpEcho 189.189.189.173
request-data-size 10
timeout 2000
frequency 2
ip sla monitor schedule 6 life forever start-time now
!
!
track 5 rtr 5 reachability
delay down 8 up 15
!
track 6 rtr 6 reachability
delay down 8 up 15
!
!
ip route 0.0.0.0 0.0.0.0 200.200.200.11 track 5
ip route 0.0.0.0 0.0.0.0 189.189.189.173 track 6
==============================================================


Testes:
1) Depois que voce adicionou o script, antes de derrubar o link, faça:
-> show track [ Os dois tracks 5 e 6 tem que estar UP - OK
-> Sh ip route [ Mostrará que as duas rotas default estão ativas]

2) Faça o comando:#terminal monitor

3) Agora quando voce derrubar o link, após 15seg comutará para outra operadora.

4) Com uma das operadora isolada, faça os comandos;
-> show track [ Mostrará um track em down ]
-> Sh ip route [ Mostrará somente a rota default da operadora ativa]


Considerações:

Caso funcione avise que mando um script mais elaborado para abordar a comutação por completo no seu site.

Caso não funcione: Este script foi feito com base na sua topologia descrita no forum, entretanto caso ainda continue com problema, acredito que seja mais lógico o acionamento de um consultor conhecido, para verificar suas configurações, topologia com mais detalhes, estudar calmamente o seu atual projeto, pois pode haver outras particularidades na sua topologia que pode está bloqueando a comutação.

Abraços,
Marcelo Guerra
Voltar ao Topo Ir em baixo
Ver perfil do usuário
tcarvalho



Número de Mensagens : 5
Idade : 42
Localização : Rio de Janeiro
Reputação : 0
Pontos : 7
Data de inscrição : 15/03/2012

MensagemAssunto: Re: Dois IPs externos em uma fast ethernet   Qua Maio 16, 2012 11:00 am

Marcelo,

Muito obrigado pela ajuda.
Conforme já havia dito o script funciona, e já havia utilizado, porém, tive que utilizar subinterface com VLAN para não dar problema na troca dos links.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Dois IPs externos em uma fast ethernet   Hoje à(s) 11:04 pm

Voltar ao Topo Ir em baixo
 
Dois IPs externos em uma fast ethernet
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Dois jogos de NES que eu adoraria jogar de novo
» Preloader - Loader do Stage e de aquivos externos
» [DUVIDA] Manipulando arquivos externos em arquivo ZIP
» [Resolvido] Estranho bug ao executar arquivos externos
» Fundir dois fóruns

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: