Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 como por o switch na rede diferente do roteador ???

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
almirf
Associate


Número de Mensagens : 56
Idade : 42
Localização : Teresopolis - RJ
Reputação : 1
Pontos : 128
Data de inscrição : 02/11/2009

MensagemAssunto: como por o switch na rede diferente do roteador ???   Sex Set 02, 2011 9:18 am

Dear Friends

tenho um roteador cisco 7200 com o ip 10.132.1.6 e um switcl 2960 com o ip 10.132.1.53

preciso colocar o ip 10.135.50.3 no switch para criar uma rede diferente para separar o trafego da rede.

como posso fazer isso ??? pus a configuracao abaixo mas nao deu certo, me ajudem.. quero fazer sem precisar criar a vlan 1 (vlan default).

***** in router
interface GigabitEthernet0/3
bandwidth 1000000
ip access-group 100 in
duplex auto
speed auto
media-type rj45
negotiation auto
no keepalive

interface GigabitEthernet0/3.50
encapsulation dot1Q 50
ip address 10.135.50.1 255.255.255.0
ip access-group 100 in
ip helper-address 10.132.5.81

***** in switch (in ip 10.135.50.3)

interface FastEthernet0/1
switchport mode trunk
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: como por o switch na rede diferente do roteador ???   Dom Set 04, 2011 2:56 am

Cria outra subinterface no seu router, coloque um endereço IP nela, sendo este, o default-gateway dos hosts que estão nesta VLAN/subnet.

No switch, apenas adicione outra vlan e configure as portas que pertencem a esta vlan.

Por adicionar outra vlan, você não precisa criar uma interface vlan no switch. No caso de switch puramente layer 2, ele permite apenas a criação de uma interface vlan para ser usada como gerência. Esta, não precisa ser a VLAN 1. É até recomendado que a VLAN 1 não seja usada.

Abraços,

Voltar ao Topo Ir em baixo
Ver perfil do usuário
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: como por o switch na rede diferente do roteador ???   Dom Set 04, 2011 3:01 am

Confirme se seu switch é multilayer ou apenas layer 2.

Expplique melhor sua topologia.

Confirme se você está usando o que chamamos de router on a stick, onde não possui roteamento no switch, possuindo apenas no roteador.

Abraços,
Voltar ao Topo Ir em baixo
Ver perfil do usuário
almirf
Associate


Número de Mensagens : 56
Idade : 42
Localização : Teresopolis - RJ
Reputação : 1
Pontos : 128
Data de inscrição : 02/11/2009

MensagemAssunto: Re: como por o switch na rede diferente do roteador ???   Ter Set 06, 2011 1:53 am

Amigo

o switch é um layer 2 modelo 2960!
a outra vlan sera a vlan da rede dos hosts ne que ficara na portas do switch?
esta vlan ja esta configuracada em outra sub-interface. ex : f0/2.38
eu nao posso aproveita-la ?

qual sera entao a vlan de gerencia do switch ?? pode ser a 50 e por o ip 10.135.50.3 ??
neste caso terei que criar a vlan 50 no switch e por este ip na vlan ne ?

Grato
Almir



ronaldobf escreveu:
Cria outra subinterface no seu router, coloque um endereço IP nela, sendo este, o default-gateway dos hosts que estão nesta VLAN/subnet.

No switch, apenas adicione outra vlan e configure as portas que pertencem a esta vlan.

Por adicionar outra vlan, você não precisa criar uma interface vlan no switch. No caso de switch puramente layer 2, ele permite apenas a criação de uma interface vlan para ser usada como gerência. Esta, não precisa ser a VLAN 1. É até recomendado que a VLAN 1 não seja usada.

Abraços,

Voltar ao Topo Ir em baixo
Ver perfil do usuário
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: como por o switch na rede diferente do roteador ???   Ter Set 06, 2011 4:50 am

O que escrevo aqui vai parecer um tanto quanto longo, mas é para deixar claro para outros que tenham dúvidas similares e que venham consultar...



Na verdade, dependendo da versão de IOS, você pode até criar mais de 1 interface vlan (SVI) no 2960. Ele pode até fazer roteamento (com várias restrições), se usar o SDM com "lanbase-routing" e a versão correta de IOS - 12.2(55)SE ou mais recente (não sendo com IOS LAN lite).

Se ele suportar, pode-se criar uma interface vlan (SVI) para cada vlan e fazer roteamento estático entre seu switch e o outro equipamento.

Interface SVI (interface vlan) é interessante para roteamento e gerenciamento. Como o 2960 não é multilayer por padrão, isto é, não faz roteamento, a única razão para se ter uma interface vlan (SVI) configurada, é simplesmente por razões de gerenciamento.
Para gerenciamento, normalmente, não é necessário ter mais do que um IP por equipamento.


Partindo do princípio de que este não é seu caso e que você quer algo mais simples...

Se você não possui uma vlan separada/dedicada para gerenciamento, pode-se usar um IP dentro do range da vlan de dados mesmo.

* Exemplos de uso de IP de gerência: acesso remoto (telnet/ssh) e monitoração.


Exemplo:

VLAN 10 - 10.10.10.0/24
VLAN 20 - 10.20.20.0/24

O IP de gerência do switch 2960 será o 10.10.10.2/24
O IP 10.10.10.1/24 será o default gateway da vlan 10
O IP 10.20.20.1/24 será o default gateway da vlan 20


No switch 2960:

Criando as vlans:

conf t
vlan 10
name VL_DADOS1
vlan 20
name VL_DADOS2


Removendo a interface vlan1 (svi):

no int vlan 1


Adicionando a vlan para gerência:

int vlan 10
ip address 10.10.10.2 255.255.255.0



Seguindo o exemplo, agora, defina quais interfaces do seu equipamento serão usadas para a vlan 10 e quais serão para a vlan 20.

int fa0/2
switchport mode access
switchport access vlan 10
description USER ACCESS PORT
no shut

int fa0/20
switchport mode access
switchport access vlan 20
description USER ACCESS PORT
no shut


* normalmente, para switches, as interfaces estão habilitadas por padrão, não precisando usar o "no shutdown".


Se quiser configurar múltiplas interfaces, pode-se usar o range. No exemplo abaixo, usamos o o range da fa0/2 a fa0/9:

int range fa0/2 - 9
switchport mode access
switchport access vlan 10
description USER ACCESS PORT
no shut



Agora, as interfaces não usadas, pode-se deixá-las na VLAN1 e administrativamente down.


int fa0/21
switchport mode access
switchport access vlan 1
no description
shut



Ainda no 2960, na interface conectada ao seu equipamento de camada 3, configure o trunk.
Imaginemos que seja a fast ethernet 0/1:

int fa0/1
description TO LAYER3 DEVICE - INT FA0/10
switchport mode trunk
no shut


* Normalmente, configuramos outras coisas, como duplex, speed, as vlans que são permitidas no trunk, tipo de encapsulamento, vlan nativa, etc... que não vem ao caso agora. Se quiser, depois mande uma msg aqui mesmo e colocaremos. Por agora, estamos focado nas coisas básicas.
Também, pode-se configurar o VTP e o gateway do switch, bem como configurar as interfaces access com portfast.





Agora, no seu equipamento layer 3:

imaginemos que a interface conectada ao seu 2960 seja a fa0/10:

int fa0/10
Description TO SWITCH 2960 - FA0/1
no shut

int fa0/10.10
description VLAN DE DADOS 1
encap dot1q 10
ip add 10.10.10.1 255.255.255.0
no shut

int fa0/10.20
description VLAN DE DADOS 2
encap dot1q 20
ip address 10.20.20.1 255.255.255.0
no shut



Neste caso, o IP 10.20.20.1 deve ser usado como default gateway para os hosts que estão na vlan 20, bem como o IP 10.10.10.1 deve ser usado como o default gateway para os hosts que se encontram na vlan 10.



*** Caso esteja usando serviço de DHCP, não se esqueça de retirar do escopo de DHCP os IPs usados nas interfaces.


Abraços,
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: como por o switch na rede diferente do roteador ???   Ter Set 06, 2011 5:00 am

Outro ambiente...
Se simplesmente você quer separar o tráfego do router e do switch, isto é, Se você possui apenas uma subnet/vlan no switch... Se o todos os hosts do switch estiverem dentro de uma subnet e todos os hosts do roteador estiverem em outra subnet, sem ter multiplas vlans, basta configurar apenas uma única vlan no switch, então configure a interface do seu 2960 como access para a vlan de dados do switch a interface conectada ao roteador.
Já no roteador, configure a interface física mesmo conectada ao switch com o IP do default gateway. Não precisa nem de trunk.
Também, verifique se a access-list aplicada nela não está bloqueando o tráfego...


Com a interface diretamente conectada, o roteador fará o roteamento sem problemas.
Se você quiser que o roteador divulgue esta rota, use roteamento dinâmico ou mesmo crie rotas estáticas nos equipamentos remotos.

Abraços,
Voltar ao Topo Ir em baixo
Ver perfil do usuário
almirf
Associate


Número de Mensagens : 56
Idade : 42
Localização : Teresopolis - RJ
Reputação : 1
Pontos : 128
Data de inscrição : 02/11/2009

MensagemAssunto: Re: como por o switch na rede diferente do roteador ???   Ter Set 06, 2011 6:33 am

Beleza

Agora uma outra pergunta

caso eu va usar a fa0/2 criando as subinterfaces f0/2.40 e f0/2.50 , e supondo que eu tabem tenha uma outra subinterface (rede) criada na fa0/3 (f0/3.38) e sendo usada para um outro switch .

Ai eu pergunto posso aproveitar esta vlan 38 que é de outra subinterface e aplicar esta vlan em algumas portas deste switch e usa-la ???

Grato
Almir

Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: como por o switch na rede diferente do roteador ???   Hoje à(s) 7:14 pm

Voltar ao Topo Ir em baixo
 
como por o switch na rede diferente do roteador ???
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» como usar a switch
» Como adicionar essa barra de cores diferente ?
» COMO COLOCAR 3 LINKS DE VELOCIDADE DIFERENTE NA RB 750..
» Como acesso Bullit fora da rede
» 2 Links de 15MB no MK, tem como virar 30mb em uma rede só ?

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: