Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 Load Balance OSPF

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
aguimar6



Número de Mensagens : 22
Idade : 37
Localização : Salvador/BA
Reputação : 4
Pontos : 62
Data de inscrição : 26/05/2010

MensagemAssunto: Load Balance OSPF   Seg Mar 21, 2011 10:30 am

Pessoal, bom dia!

Estou sem LAB mais preparei o script básico para fazer um balanceamento OSPF. O meu ambiente é seguinte:

Tenho um roteador (A) que está ligado a outro (B) por dois links distintos (metro ethernet) e preciso que o meu roteador A divulgue a sua rede interna para os dois limks usando a mesma métrica... A idéia é usar os 2 links de 5Mb simultaneamente e que na queda de um deles, o cliente não tenha impacto.

Segue abaixo o script básico apenas com as config (incompletas ainda pois o principal é a Idéia)

####################################################

Config Router A:

f0
ip add 1.1.1.1 255.255.255.252

f1
ip add 2.2.2.1 255.255.255.252

f2
descricao: Rede Interna
ip add 192.168.4.254 255.255.255.0

router ospf 1
router-id 1.1.1.1
network 192.168.4.254 0.0.0.0 area 0

router ospf 2
router-id 2.2.2.1
network 192.168.4.254 0.0.0.0 area 0
####################################################

Config Router B:

f0
ip add 1.1.1.2 255.255.255.252

f1
ip add 2.2.2.2 255.255.255.252

router ospf 3
router-id 1.1.1.2

router ospf 4
router-id 2.2.2.2
####################################################

O script acima fará com que a rede interna do router A seja divulgada pelos 2 links com mesma métrica?

grato,
Anderson
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: Load Balance OSPF   Ter Mar 22, 2011 8:48 am

Apenas este script não fará isso, pois você precisa dizer para o OSPF que ele deve fazer o balanceamento.
Além disso esta configuração esta errada, pois o router-id deve ser uma interface do seu roteador, de preferencia uma loopback para que o processo não caia se a interface cair.

####################################################

Config Router A:

Interface Loopback0
ip address 1.1.1.1 255.255.255.255

Interface FastEthernet0/0
ip ospf cost 100
ip address 10.0.0.1 255.255.255.252

Interface FastEthernet0/1
ip ospf cost 100
ip address 11.0.0.1 255.255.255.252

Interface FastEthernet0/2
description Rede Interna
ip address 192.168.4.254 255.255.255.0

router ospf 1
router-id 1.1.1.1
network 10.0.0.0 0.0.0.3 area 0
network 11.0.0.0 0.0.0.3 area 0
network 192.168.4.0 0.0.0.255 area 0
maximum-paths 2

####################################################

Config Router B:

Interface Loopback0
ip address 2.2.2.2 255.255.255.255

Interface FastEthernet0/0
ip ospf cost 100
ip address 10.0.0.2 255.255.255.252

Interface FastEthernet0/1
ip ospf cost 100
ip address 11.0.0.2 255.255.255.252

Interface FastEthernet0/2
description Rede Interna
ip address 192.168.5.254 255.255.255.0

router ospf 1
router-id 2.2.2.2
network 10.0.0.0 0.0.0.3 area 0
network 11.0.0.0 0.0.0.3 area 0
network 192.168.5.0 0.0.0.255 area 0
maximum-paths 2

####################################################

Seguem mais algumas observações:
1 - Certifique que o bandwith esta igual nos 2 links;
2 - Certifique que o custo está igual nos 2 links (se o bandwith estiver igual e não tiver custo configurado ele estará igual).
Você pode conferir isso com o comando show ip ospf interface X/X
Caso prefira você pode forçar o custo em ambos os links com o comando ip ospf cost X dentro das interfaces, neste caso não precisa se preocupar com o bandwith;
3 - Configure o "maximum-paths" dentro do processo OSPF

Isso deve fazer com que o OSPF faça o balanceamento.


abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
aguimar6



Número de Mensagens : 22
Idade : 37
Localização : Salvador/BA
Reputação : 4
Pontos : 62
Data de inscrição : 26/05/2010

MensagemAssunto: Valeu!   Sex Abr 01, 2011 10:14 am

Obrigado!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Load Balance OSPF   Hoje à(s) 3:35 pm

Voltar ao Topo Ir em baixo
 
Load Balance OSPF
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Fazendo um "Load Game"
» Load Externo
» Criar load de sons no jogo(duvida/ajuda)
» Efeito On-Load na pagina como Neste forum.

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: