Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 [Ajuda] Redundancia de Link - Serial e Fast.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
gilsonf



Número de Mensagens : 16
Idade : 29
Localização : Espirito Santo
Reputação : 0
Pontos : 24
Data de inscrição : 19/01/2011

MensagemAssunto: [Ajuda] Redundancia de Link - Serial e Fast.   Qua Jan 19, 2011 8:45 am

Pessoal,

to com um problema, to implementando links de redundância nas filiais da empresa, e o Gestor de TI aprovo a idéia de usarmos um link da OI (Velox)1mg para atender.


Utilizamos roteadores Cisco 2800 em todas as filiais, eu consegui colocar o cisco funcionando com o velox, e todas vez que o link cai fazemos a mudança manualmente tirando a serial da Embratel e colocando o velox na fast do roteador.


Me disseram que existe uma forma dele fazer isso automaticamente, peço desculpas, mais sou novo nessa área ainda, to estudando pra tirar meu CCNA (rsrs), vi alguns protocolos que atenderiam nessa questão, tais como HSRP. Alguém poderia me dar uma ajuda nessa questão?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Qui Jan 20, 2011 7:02 pm

Existe sim!

Se eu entendi o seu ambiente...

- Você simplesmente conecta ambos os links diretamente em seu roteador (único 2800).
- Defina uma rota, com AD menor, para o link que você quer que seja o principal.
- Defina outra rota, com AD maior, para o link secundário.

Quando o link primário cair, a rota será retirada da tabela de roteamento e a com AD maior, assumirá, roteando, automaticamente, para o link secundário.

exemplo de rota flutuante (float) usando default:

ip route 0.0.0.0 0.0.0.0 se0/0 (embratel)
ip route 0.0.0.0 0.0.0.0 <IP NEXT HOP> fa0/0 254 (velox)

como vc liga na fast ethernet (ambiente multiaccess), é aconselhável colocar o IP do next hop e a interface para evitar que todo e qualquer ip faça o ARP toda vez que um ip não for encontrado na tabela, forçando sair diretamente pelo IP do next hop.


Se entendi seu ambiente, acho que, com isso, resolveria.

O ideal seria vc postar mais detalhes a as formas que você usa pra conectar ambos os links.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gilsonf



Número de Mensagens : 16
Idade : 29
Localização : Espirito Santo
Reputação : 0
Pontos : 24
Data de inscrição : 19/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Seg Jan 31, 2011 8:27 am

Eu entendi, mais gostaria de saber o sequinte,

Como a Fast vai monitorar a serail , para saber se ta UP ou não?

Em caso de falha na serial, a Fast assumiria, e se a Serial ficar UP novamente? Ela reassumiria?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gilsonf



Número de Mensagens : 16
Idade : 29
Localização : Espirito Santo
Reputação : 0
Pontos : 24
Data de inscrição : 19/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Seg Jan 31, 2011 9:19 am

Olha a Configuração do Router


interface Multilink35
ip address X.X.X.X X.X.X.X
ip tcp header-compression iphc-format
ppp multilink
ppp multilink group 35
ip rtp header-compression iphc-format
!
interface FastEthernet0/0
description CONEXAO COM Lan
ip address 192.168.35.254 255.255.255.0
ip nat inside
no ip virtual-reassembly
ip tcp adjust-mss 1452
duplex auto
speed auto
!
interface FastEthernet0/1
description CONEXAO COM VELOX
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
!
interface Serial0/3/0
bandwidth 512
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 35
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
no ip virtual-reassembly
encapsulation ppp
no ip route-cache cef
no ip route-cache
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username 1111111@telemar.com.br password 0 11111111
crypto map VPN

!
router bgp XXXXX
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor X.X.X.X remote-as XXXX
neighbor X.X.X.X allowas-in
no auto-summary
!
ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Multilink35

ip route 0.0.0.0 0.0.0.0 Dialer1


Voltar ao Topo Ir em baixo
Ver perfil do usuário
andreirapuru
Associate


Número de Mensagens : 54
Idade : 34
Localização : São Paulo/SP
Reputação : 13
Pontos : 67
Data de inscrição : 27/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Seg Jan 31, 2011 9:54 am

Se você seguir a configuração que o ronaldobf sugeriu, o que vai acontecer é que o roteador vai perceber que a interface principal (serial) não está disponível e vai tirar a rota da tabela de roteamento.
Com isso a rota com peso maior (pela f0/0) vai se tornar a principal.

Quando a interface serial voltar a rota também volta, e o tráfego passará a ser enviado usando esta rota novamente.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://www.brainwork.bom.br/blog
gilsonf



Número de Mensagens : 16
Idade : 29
Localização : Espirito Santo
Reputação : 0
Pontos : 24
Data de inscrição : 19/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Seg Jan 31, 2011 10:08 am

andreirapuru escreveu:
Se você seguir a configuração que o ronaldobf sugeriu, o que vai acontecer é que o roteador vai perceber que a interface principal (serial) não está disponível e vai tirar a rota da tabela de roteamento.
Com isso a rota com peso maior (pela f0/0) vai se tornar a principal.

Quando a interface serial voltar a rota também volta, e o tráfego passará a ser enviado usando esta rota novamente.

Amigao, desculpa minha pergunta, mais como ficaria no caso? eu apontaria para interface? Porque minha serial e a fast que fica com o velox não tem IP.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
andreirapuru
Associate


Número de Mensagens : 54
Idade : 34
Localização : São Paulo/SP
Reputação : 13
Pontos : 67
Data de inscrição : 27/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Seg Jan 31, 2011 2:48 pm

Isso.
Não é recomendado apontar a rota para a interface, mas como é IP dinâmico pode configurar a rota apontando para a interface.

Voltar ao Topo Ir em baixo
Ver perfil do usuário http://www.brainwork.bom.br/blog
gilsonf



Número de Mensagens : 16
Idade : 29
Localização : Espirito Santo
Reputação : 0
Pontos : 24
Data de inscrição : 19/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Seg Jan 31, 2011 3:41 pm

ronaldobf escreveu:
Existe sim!

Se eu entendi o seu ambiente...

- Você simplesmente conecta ambos os links diretamente em seu roteador (único 2800).
- Defina uma rota, com AD menor, para o link que você quer que seja o principal.
- Defina outra rota, com AD maior, para o link secundário.

Quando o link primário cair, a rota será retirada da tabela de roteamento e a com AD maior, assumirá, roteando, automaticamente, para o link secundário.

exemplo de rota flutuante (float) usando default:

ip route 0.0.0.0 0.0.0.0 se0/0 (embratel)
ip route 0.0.0.0 0.0.0.0 <IP NEXT HOP> fa0/0 254 (velox)

como vc liga na fast ethernet (ambiente multiaccess), é aconselhável colocar o IP do next hop e a interface para evitar que todo e qualquer ip faça o ARP toda vez que um ip não for encontrado na tabela, forçando sair diretamente pelo IP do next hop.


Se entendi seu ambiente, acho que, com isso, resolveria.

O ideal seria vc postar mais detalhes a as formas que você usa pra conectar ambos os links.


Cara com as configurações que postei, deixa ve se eu entendi.... eu teria que apenas adicionar o comando na rota? Teria que colocar algo a mais nas interfaces?

Se possivel, voce poderia me mostrar como ficaria a questao da rota.

Voltar ao Topo Ir em baixo
Ver perfil do usuário
gilsonf



Número de Mensagens : 16
Idade : 29
Localização : Espirito Santo
Reputação : 0
Pontos : 24
Data de inscrição : 19/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Seg Jan 31, 2011 3:48 pm

Pessoal....


Dessa forma funcionaria?


interface Serial0/3/0
bandwidth 512
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 35
standby 1 ip multilink35
standby 1 priority 120
standby 1 preempt
standby 2 ip Dialer1
standby 2 preempt
standby 1 track s1/1 30
no shut


!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
no ip virtual-reassembly
encapsulation ppp
no ip route-cache cef
no ip route-cache
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username 1111111@telemar.com.br password 0 11111111
crypto map VPN
standby 2 dialer1
standby 2 priority 120
standby 2 preempt
standby 1 multlink35
standby 1 preempt
standby 2 track s1/2 30
no shut

ip route 0.0.0.0 0.0.0.0 Multilink35

ip route 0.0.0.0 0.0.0.0 Dialer1 - Fiquei em duvida aqui.....
Voltar ao Topo Ir em baixo
Ver perfil do usuário
andreirapuru
Associate


Número de Mensagens : 54
Idade : 34
Localização : São Paulo/SP
Reputação : 13
Pontos : 67
Data de inscrição : 27/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Ter Fev 01, 2011 11:27 am

ip route 0.0.0.0 0.0.0.0 Dialer1 50 (ou outro valor)

OBS: Também teria que fazer configurações de NAT, mas como já está funcionando manualmente, imagino que esta parte esteja ok.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://www.brainwork.bom.br/blog
gilsonf



Número de Mensagens : 16
Idade : 29
Localização : Espirito Santo
Reputação : 0
Pontos : 24
Data de inscrição : 19/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Ter Fev 01, 2011 12:58 pm

andreirapuru escreveu:
ip route 0.0.0.0 0.0.0.0 Dialer1 50 (ou outro valor)

OBS: Também teria que fazer configurações de NAT, mas como já está funcionando manualmente, imagino que esta parte esteja ok.

A configuração das duas acho que nas interfaces ta ok entao ne?

Voltar ao Topo Ir em baixo
Ver perfil do usuário
andreirapuru
Associate


Número de Mensagens : 54
Idade : 34
Localização : São Paulo/SP
Reputação : 13
Pontos : 67
Data de inscrição : 27/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Ter Fev 01, 2011 1:40 pm

To começando a ficar confuso...
Já não está funcionando atualmente?
Nem me preocupei com o resto.
Esta configuração é apenas para o link secundário assumir automaticamente.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://www.brainwork.bom.br/blog
gilsonf



Número de Mensagens : 16
Idade : 29
Localização : Espirito Santo
Reputação : 0
Pontos : 24
Data de inscrição : 19/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Ter Fev 01, 2011 1:45 pm

andreirapuru escreveu:
To começando a ficar confuso...
Já não está funcionando atualmente?
Nem me preocupei com o resto.
Esta configuração é apenas para o link secundário assumir automaticamente.

Desculpa amigo.....eu precisaria apenas adicionar esse comando da rota ja resolveria?

Atualmente hoje esta assim:

interface Serial0/3/0
bandwidth 512
no ip address
encapsulation ppp
no fair-queue
ppp multilink
ppp multilink group 35
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
no ip virtual-reassembly
encapsulation ppp
no ip route-cache cef
no ip route-cache
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username 1111111@telemar.com.br password 0 11111111
crypto map VPN


ip route 0.0.0.0 0.0.0.0 Multilink35
ip route 0.0.0.0 0.0.0.0 Dialer1 50 - Adicionando.

Nas interfaces não preciso configurar nada entao?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
andreirapuru
Associate


Número de Mensagens : 54
Idade : 34
Localização : São Paulo/SP
Reputação : 13
Pontos : 67
Data de inscrição : 27/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Ter Fev 01, 2011 1:50 pm

isso. adicione e teste. qualquer coisa avise.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://www.brainwork.bom.br/blog
gilsonf



Número de Mensagens : 16
Idade : 29
Localização : Espirito Santo
Reputação : 0
Pontos : 24
Data de inscrição : 19/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Seg Fev 07, 2011 9:16 am

andreirapuru escreveu:
isso. adicione e teste. qualquer coisa avise.

A pricniono funcionou, porem fica uma duvida....

Eu fis o teste desligando o modem da embratel isso deixa a interface serial down e o protocolo down....dessa forma a rota alternativa assumil....minha pergunta...se a interface fica Up e o protocolo Down, a rota alternativa assume tambem?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
andreirapuru
Associate


Número de Mensagens : 54
Idade : 34
Localização : São Paulo/SP
Reputação : 13
Pontos : 67
Data de inscrição : 27/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Seg Fev 07, 2011 10:54 am

Sim, se o protocolo ficar down a rota já vai sair da tabela.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://www.brainwork.bom.br/blog
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Ter Fev 08, 2011 4:25 am

No seu caso, sem rotas mais específicas, você está usando um link como primário e o outro como secundário (standby).

Se quiser, pode, por exemplo, dividir tráfego para ambos os links...


Deixa essas rotas:
ip route 0.0.0.0 0.0.0.0 Multilink35
ip route 0.0.0.0 0.0.0.0 Dialer1 254

Adicione, por exemplo, rotas específicas:

ip route 10.1.1.0 255.255.255.0 Dialer1
ip route 10.2.1.0 255.255.255.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Multilink35
ip route 0.0.0.0 0.0.0.0 Dialer1 254

Neste caso, você estaria fazendo o que a gente chama de load sharing, onde você define certas subnets para um determinado link e o restante para outros.
Neste contexto, você estaria fazendo uso de ambos os links.

Regra básica: Rotas mais específicas tem preferência.

Isso que dizer que, no exemplo acima, as subnets 10.1.1.0/24 e 10.2.1.0/24 estão sendo roteadas para a Di1. Caso este link caia, elas sairão da tabela de roteamento. Não tendo mais rotas específicas, ela envia via default route para a Multilink.

No exemplo, qualquer subnet diferente de 10.1.1.0/24 e 10.2.1.0/24, será roteada para a interface Mu35, até que a multilink caia.

Voltar ao Topo Ir em baixo
Ver perfil do usuário
gilsonf



Número de Mensagens : 16
Idade : 29
Localização : Espirito Santo
Reputação : 0
Pontos : 24
Data de inscrição : 19/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Ter Fev 08, 2011 9:15 am

ronaldobf escreveu:
No seu caso, sem rotas mais específicas, você está usando um link como primário e o outro como secundário (standby).

Se quiser, pode, por exemplo, dividir tráfego para ambos os links...


Deixa essas rotas:
ip route 0.0.0.0 0.0.0.0 Multilink35
ip route 0.0.0.0 0.0.0.0 Dialer1 254

Adicione, por exemplo, rotas específicas:

ip route 10.1.1.0 255.255.255.0 Dialer1
ip route 10.2.1.0 255.255.255.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Multilink35
ip route 0.0.0.0 0.0.0.0 Dialer1 254

Neste caso, você estaria fazendo o que a gente chama de load sharing, onde você define certas subnets para um determinado link e o restante para outros.
Neste contexto, você estaria fazendo uso de ambos os links.

Regra básica: Rotas mais específicas tem preferência.

Isso que dizer que, no exemplo acima, as subnets 10.1.1.0/24 e 10.2.1.0/24 estão sendo roteadas para a Di1. Caso este link caia, elas sairão da tabela de roteamento. Não tendo mais rotas específicas, ela envia via default route para a Multilink.

No exemplo, qualquer subnet diferente de 10.1.1.0/24 e 10.2.1.0/24, será roteada para a interface Mu35, até que a multilink caia.


Amigao, quanto a essa parte funciono perfeitamente..muito obrigado pela ajuda de voces... Very Happy

Estou terminando de implementar e assim que acabar comento como ficou...vlws
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gilsonf



Número de Mensagens : 16
Idade : 29
Localização : Espirito Santo
Reputação : 0
Pontos : 24
Data de inscrição : 19/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Qui Mar 10, 2011 3:52 pm

ronaldobf escreveu:
No seu caso, sem rotas mais específicas, você está usando um link como primário e o outro como secundário (standby).

Se quiser, pode, por exemplo, dividir tráfego para ambos os links...


Deixa essas rotas:
ip route 0.0.0.0 0.0.0.0 Multilink35
ip route 0.0.0.0 0.0.0.0 Dialer1 254

Adicione, por exemplo, rotas específicas:

ip route 10.1.1.0 255.255.255.0 Dialer1
ip route 10.2.1.0 255.255.255.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Multilink35
ip route 0.0.0.0 0.0.0.0 Dialer1 254

Neste caso, você estaria fazendo o que a gente chama de load sharing, onde você define certas subnets para um determinado link e o restante para outros.
Neste contexto, você estaria fazendo uso de ambos os links.

Regra básica: Rotas mais específicas tem preferência.

Isso que dizer que, no exemplo acima, as subnets 10.1.1.0/24 e 10.2.1.0/24 estão sendo roteadas para a Di1. Caso este link caia, elas sairão da tabela de roteamento. Não tendo mais rotas específicas, ela envia via default route para a Multilink.

No exemplo, qualquer subnet diferente de 10.1.1.0/24 e 10.2.1.0/24, será roteada para a interface Mu35, até que a multilink caia.


Cara funciono, porem a conexao chega no Firewall e fazemos a autenticação manualmente. Gostaria de saber se existe uma forma dele autentica o IP Dinamico.

Firewall - Pix
Voltar ao Topo Ir em baixo
Ver perfil do usuário
andreirapuru
Associate


Número de Mensagens : 54
Idade : 34
Localização : São Paulo/SP
Reputação : 13
Pontos : 67
Data de inscrição : 27/01/2011

MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Sex Mar 11, 2011 11:27 am

Veja neste link o exemplo de configuração para PPPoE no PIX/ASA
http://www.cisco.com/en/US/products/ps6120/products_configuration_example09186a0080ab7ce9.shtml

Voltar ao Topo Ir em baixo
Ver perfil do usuário http://www.brainwork.bom.br/blog
Conteúdo patrocinado




MensagemAssunto: Re: [Ajuda] Redundancia de Link - Serial e Fast.   Hoje à(s) 2:50 am

Voltar ao Topo Ir em baixo
 
[Ajuda] Redundancia de Link - Serial e Fast.
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Ajuda Adfly Link Externo
» Ajuda como retirar do link da categoria os moderadores
» Como colocar link em palavra?
» Ajuda Ndrive
» ajuda ajuda kies

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: