Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 Problemas com DHCP

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
gilbertomt



Número de Mensagens : 5
Idade : 30
Localização : Criciúma
Reputação : 0
Pontos : 7
Data de inscrição : 29/12/2010

MensagemAssunto: Problemas com DHCP   Qui Dez 30, 2010 9:34 am

Bom Dia!

Estou com o seguinte problema, tenho um cisco 877w, o mesmo esta com todas as interfaces funcionando, porem quando utilizo configurações de DHCP o CPE me entrega apenas 1 IP, as outras maquinas não conseguem receber IP.

Estou utilizando as interfaces.

interface ATM0
interface Dot11Radio0
interface Vlan1
interface Dialer1
interface BVI1

Ja fiz os seguintes testes, atualização de IOS, atualmete utilizando c870-advipservicesk9-mz.124-24.T.bin, ja criei varias regras DHCP amarradas em varias vlans, desta forma cada vlan recebe um ip e nada mais que isso. ja quebrei a cabeça e não tem jeito dele funcionar, se eu fixar os IPs funcionam perfeitamente, porem preciso que funcione com DHCP, ja realizei testes com outro 877w e apresenta o mesmo caso.

Obrigado! Fico aguardando respostas.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
bruno sobreira
Associate


Número de Mensagens : 54
Idade : 30
Localização : joão pessoa - PB
Reputação : 0
Pontos : 58
Data de inscrição : 30/12/2009

MensagemAssunto: Re: Problemas com DHCP   Sex Dez 31, 2010 8:41 am

posta a configuraçao sera melhor para analisarmos
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gilbertomt



Número de Mensagens : 5
Idade : 30
Localização : Criciúma
Reputação : 0
Pontos : 7
Data de inscrição : 29/12/2010

MensagemAssunto: Ultimo Script   Dom Jan 02, 2011 4:52 pm

CRONOS(config)#do sh run
Building configuration...

Current configuration : 2617 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CRONOS
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid TeodoroFastLan
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 0 xxxxx
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool LAN
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 201.10.128.2 201.10.120.2 201.10.120.3 201.10.1.2
domain-name lan.cronos
!
ip dhcp pool WIRELESS
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 201.10.128.2 201.10.120.2 201.10.120.3 201.10.1.2
domain-name wireless.cronos
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
interface ATM0
description INTERFACE ADSL
no ip address
no atm ilmi-keepalive
pvc 0/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
ip address 192.168.1.1 255.255.255.0
ip access-group 101 in
ip nat inside
ip virtual-reassembly
!
encryption mode ciphers tkip
!
ssid TeodoroFastLan
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
no cdp enable
!
interface Vlan1
ip address 192.168.2.1 255.255.255.0
ip access-group 102 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
no ip mroute-cache
!
interface Dialer1
description INTERFACE DE AUTENTICACAO
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer remote-name redback
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname xxx@xxxx.xx.xx
ppp chap password 0 xxx
ppp pap sent-username xxx@xxxx.xx.xx password 0 xxx
ppp ipcp dns request
ppp ipcp wins request
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
ip nat inside source list 101 interface Dialer1 overload
ip nat inside source list 102 interface Dialer1 overload
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 permit ip 192.168.2.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end
Voltar ao Topo Ir em baixo
Ver perfil do usuário
bruno sobreira
Associate


Número de Mensagens : 54
Idade : 30
Localização : joão pessoa - PB
Reputação : 0
Pontos : 58
Data de inscrição : 30/12/2009

MensagemAssunto: Re: Problemas com DHCP   Seg Jan 03, 2011 8:44 pm

Bom seguinte pelo que eu sei o IOS (C870-ADVSECURITYK9-M), Version 12.4(4)T1 que é seu caso tem um bug com relaçao ao dchp, essa correçao foi realizada a parti das versoes
12.4(4.4), 12.4(4.4)T, 12.3(14)YT01.

tenho um amigo que ja passou pelo mesmo problema com o 870 e resolvie com o IOS 12.3
porem pode ser que eu esteja falando besteira por isso serio bom vc fazer um debug no DHCP, vc pode verificar o erro com base no debug abaixo:

debug dhcp detail:

*Feb 9 19:21:55.015: DHCP: SDiscover attempt # 2 for entry:

*Feb 9 19:21:55.015: Temp IP addr: 0.0.0.0 for peer on Interface: BVI1

*Feb 9 19:21:55.015: Temp sub net mask: 0.0.0.0

*Feb 9 19:21:55.015: DHCP Lease server: 0.0.0.0, state: 1 Selecting

*Feb 9 19:21:55.015: DHCP transaction id: 1925

*Feb 9 19:21:55.015: Lease: 0 secs, Renewal: 0 secs, Rebind: 0 secs

*Feb 9 19:21:55.015: Next timer fires after: 00:00:04

*Feb 9 19:21:55.015: Retry count: 2 Client-ID: 0015.c653.cd1b

*Feb 9 19:21:55.015: Client-ID hex dump: 0015C653CD1B

*Feb 9 19:21:55.015: Hostname: Router

*Feb 9 19:21:55.015: DHCP: SDiscover: sending 275 byte length DHCP packet

*Feb 9 19:21:55.015: DHCP: SDiscover 275 bytes

*Feb 9 19:21:55.015: B'cast on BVI1 interface from 0.0.0.0

*Feb 9 19:21:55.047: DHCP: Received a BOOTREP pkt

*Feb 9 19:21:55.047: DHCP: Scan: Message type: DHCP Offer

*Feb 9 19:21:55.047: DHCP: Scan: Server ID Option: (correct DHCP server IP) = C1E51C1B

*Feb 9 19:21:55.047: DHCP: Scan: Lease Time: 7200

*Feb 9 19:21:55.047: DHCP: Scan: bad FQDN option len 3

*Feb 9 19:21:55.047: DHCP: Error in pkt. punting

*Feb 9 19:21:59.015: DHCP: SDiscover attempt # 3 for entry:

espero ter ajudado...............
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gilbertomt



Número de Mensagens : 5
Idade : 30
Localização : Criciúma
Reputação : 0
Pontos : 7
Data de inscrição : 29/12/2010

MensagemAssunto: Ta complicado   Qui Fev 17, 2011 7:40 pm

Fiz esses procedimentos mas não tive sucesso, ja utilizei as seguintes IOS

c870-advipservicesk9-mz.123-8.YI2
c870-advipservicesk9-mz.123-14.YT1
c870-advipservicesk9-mz.124-9.T3
c870-advipservicesk9-mz.124-15.T10
c870-advipservicesk9-mz.124-15.T12
c870-advipservicesk9-mz.124-20.T2
c870-advipservicesk9-mz.124-22.T
c870-advipservicesk9-mz.124-24.T

Acabei de atualizar para c870-advipservicesk9-mz.150-1.M , sem sucesso

segue show version do router

CRONOS#sh ver
Cisco IOS Software, C870 Software (C870-ADVIPSERVICESK9-M), Version 15.0(1)M, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Wed 30-Sep-09 08:42 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE

CRONOS uptime is 18 minutes
System returned to ROM by reload
System image file is "flash:c870-advipservicesk9-mz.150-1.M.bin"
Last reload reason: Reload Command



This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 877W (MPC8272) processor (revision 4.0) with 118784K/12288K bytes of memory.
Processor board ID FHK142278T6
MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10
4 FastEthernet interfaces
1 ATM interface
1 Virtual Private Network (VPN) Module
1 802.11 Radio
128K bytes of non-volatile configuration memory.
28672K bytes of processor board System flash (Intel Strataflash)



Configuration register is 0x2102

CRONOS#


executei o comando debug no dhcp, mas não me apresentou nenhuma mensagem.

Agora estou com a cabeça fervendo.

Obrigado pela resposta, não respondi antes pois estava sem tempo para quebrar a cabeça nisso, mas tirei essa semana para efetuar os testes e foi teste.


Voltar ao Topo Ir em baixo
Ver perfil do usuário
marcelosguerra
Admin


Número de Mensagens : 81
Idade : 33
Localização : Sao Paulo - SP
Reputação : 16
Pontos : 80
Data de inscrição : 24/07/2007

MensagemAssunto: Re: Problemas com DHCP   Qui Fev 17, 2011 11:55 pm

Ola gilbertomt,

Pode fazer o seguinte teste?

- Inclua no DHCP a linha: import all.
-------------
- Exemplo:
-------------
---ip dhcp pool LAN
---import all
---network 192.168.2.0 255.255.255.0
---default-router 192.168.2.1
---dns-server 201.10.128.2 201.10.120.2 201.10.120.3 201.10.1.2
-------------
- Caso não funcione, retire da VLAN a ACL e teste.
- Qual é o unico IP que estava pegando?

Sds,
Marcelo Guerra
Voltar ao Topo Ir em baixo
Ver perfil do usuário
bruno sobreira
Associate


Número de Mensagens : 54
Idade : 30
Localização : joão pessoa - PB
Reputação : 0
Pontos : 58
Data de inscrição : 30/12/2009

MensagemAssunto: Re: Problemas com DHCP   Qui Fev 17, 2011 11:59 pm

boa ideia marcelosguerra estava agora msm estudando esse caso nos foruns americanos e todos usavam essa opçao maisssssssssssss pode ser q sim ou q nao vamos esperar
Voltar ao Topo Ir em baixo
Ver perfil do usuário
bruno sobreira
Associate


Número de Mensagens : 54
Idade : 30
Localização : joão pessoa - PB
Reputação : 0
Pontos : 58
Data de inscrição : 30/12/2009

MensagemAssunto: Re: Problemas com DHCP   Sex Fev 18, 2011 12:06 am

interface Vlan1
ip address 192.168.2.1 255.255.255.0
ip access-group 102 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
no ip mroute-cach
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gilbertomt



Número de Mensagens : 5
Idade : 30
Localização : Criciúma
Reputação : 0
Pontos : 7
Data de inscrição : 29/12/2010

MensagemAssunto: Eitchaaa!!!   Sex Fev 18, 2011 8:28 pm

cheers Basketball Basketball cheers
lol!


CONSEGUI!!!!

Doideira a parada...
Quem estava me incomodando era este comando

ip dhcp excluded-address 192.168.1.254

Fui fazer os testes que me passaram, nada feito, então zerei o router, larguei os scripts que tinha montado, coloquei 2 maquina na eth pingando para o gw e o notebook buscando a rede wireless.
comecei a configurar no braço, configurei a vlan1, depois ativei a int bv1, logo a dot11radio0, depois comecei a configurar o dhcp. logo percebi as maquinas que estavam na eth pegaram ip`s, apliquei o comando ip dhcp excluded-address elas começaram a se perder, tentei buscar pelo note nada feito, retirei o comando e eis que todas as maquinas pegaram os ip`s.

Em nenhum momento me passou pela cabeça isso, faz 4 anos que trabalho com CISCO e todos que configurei até o momento com dhcp usei os comando ip dhcp excluded-address e não me gerou esse problema, hoje mesmo configurei um 877 em um telecentro e não tive problemas.

Ja pegaram algo parecido?

Nunca trabalhei com esse 877W, sabem se é possivel aumentar a potência das antes dele?

segue config atual do router.

CRONOS(config)#do sh run

Building configuration...

Current configuration : 3159 bytes
!
! Last configuration change at 07:23:30 UTC Fri Mar 1 2002
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname CRONOS
!
boot-start-marker
boot-end-marker
!
enable secret xxxxxxxxxxxxxx
!
aaa new-model
!
!
aaa authentication login default local
!
aaa session-id common
!
!
dot11 syslog
!
dot11 ssid TeodoroFastLan
max-associations 10
authentication open
authentication key-management wpa
wpa-psk ascii xxxxxxxxxxxxxx
!
ip source-route
!
ip dhcp pool TEODORO
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
dns-server 8.8.8.8 201.10.128.2 201.10.1.2 201.10.120.3 201.10.120.2
domain-name cronos.betomt.com.br
!
ip cef
ip domain name betomt.com.br
no ipv6 cef
!
multilink bundle-name authenticated
!
username gilberto privilege 15 secret xxxxxxxxxxxxxx
!
ip ssh version 2
!
bridge irb
!
interface ATM0
description ** DSL **
no ip address
load-interval 30
no atm ilmi-keepalive
!
pvc 0/35
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
!
interface FastEthernet1
!
!
interface FastEthernet2
!
!
interface FastEthernet3
!
!
interface Dot11Radio0
description ** REDE SEM FIO **
no ip address
load-interval 30
!
encryption mode ciphers tkip
!
ssid TeodoroFastLan
!
speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0

basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
channel 2442
station-role root
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
!
interface Vlan1
description ** ETH`S ELETRICAS **
no ip address
load-interval 30
bridge-group 1
bridge-group 1 spanning-disabled
!
!
interface Dialer1
description ** AUTENTICACAO COM RADIUS **
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
load-interval 30
dialer pool 1
dialer remote-name redback
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname xxxxxxxxxxxxxx
ppp chap password xxxxxxxxxxxxxx
ppp pap sent-username xxxxxxxxxxxxxx password xxxxxxxxxxxxxx
ppp ipcp dns request
ppp ipcp wins request
!
!
interface BVI1
description ** BRIDGE INTERFACES Vlan1/Dot11Radio0 **
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1460
load-interval 30
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 101 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
control-plane
!
!
bridge 1 protocol vlan-bridge
bridge 1 route ip
!
line con 0
exec-timeout 0 0
no modem enable
transport preferred none
transport output all
line aux 0
line vty 0 4
transport preferred ssh
transport input ssh
transport output all
!
scheduler max-task-time 5000
end

CRONOS(config)#



Obrigado pela atenção dos amigos, sem ela teria abandonado o barco.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
bruno sobreira
Associate


Número de Mensagens : 54
Idade : 30
Localização : joão pessoa - PB
Reputação : 0
Pontos : 58
Data de inscrição : 30/12/2009

MensagemAssunto: Re: Problemas com DHCP   Sex Fev 18, 2011 10:43 pm

putis gilbertomt vc estava excluindo a propia rede ahuahuauahu tbm nao prestei atençao, parabens vei mais uma coisas q fica como experiencia para nos, abraçao e td d bom fico feliz por vc t+
Voltar ao Topo Ir em baixo
Ver perfil do usuário
marcelosguerra
Admin


Número de Mensagens : 81
Idade : 33
Localização : Sao Paulo - SP
Reputação : 16
Pontos : 80
Data de inscrição : 24/07/2007

MensagemAssunto: Re: Problemas com DHCP   Sab Fev 19, 2011 12:31 am

Gilbertomt,

Realmente concordo com você, também tive a oportunidade de efetuar configurações de DHCP em outros equipamentos cisco, e a linha: ip dhcp excluded-address, funcionava muito bem.

Pelo o que entendi quando você coloca a linha: ip dhcp excluded-address, neste 877w, independente do ip excluído, para de fornecer os ips certo?


Vou verificar se existe algo peculiar na implementação de DHCP para o 877w.


Sds,
Marcelo Guerra
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gilbertomt



Número de Mensagens : 5
Idade : 30
Localização : Criciúma
Reputação : 0
Pontos : 7
Data de inscrição : 29/12/2010

MensagemAssunto: Re: Problemas com DHCP   Sab Fev 19, 2011 6:05 pm

o router ta funcionando a todo vapor, fiz a mesma config em uma outro 877W que esta igual e esta funcionando, como mencionei anteriormente nesta sexta-feira fiz a seguinte config em um 877 e funcionou perfeitamente.

!
ip dhcp excluded-address 10.133.33.1 10.133.33.10
!
ip dhcp pool 10.133.33.0/24
network 10.133.33.0 255.255.255.0
default-router 10.133.33.1
dns-server 201.10.128.2 201.10.120.2
!

Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Problemas com DHCP   Hoje à(s) 11:04 am

Voltar ao Topo Ir em baixo
 
Problemas com DHCP
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» PROBLEMAS COM DHCP EM MIKROTIK
» problemas de aplicativos
» Problemas com fone de ouvido.
» Problemas com games
» problemas com jogo online e roteador

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: