Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 Problema de DNS em Vlan com Dhcp

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
luizcahue



Número de Mensagens : 7
Reputação : 0
Pontos : 15
Data de inscrição : 21/06/2008

MensagemAssunto: Problema de DNS em Vlan com Dhcp    Sab Set 11, 2010 6:20 pm

Salve galera, tenho uma rede com um 1841 como servidor DHCP, com algumas subinterfaces configuradas. Existe um cisco 2950T com algumas VLAN's e uma porta trunk configurada. Existem 3 vlan's configuradas e funcionando sem problemas, exceto por nao resolver nenhum tipo de solicitação DNS. Somente a vlan nomeada como 100 resolve nomes. Nas outras o DHCP entrega IP, mascara e DNS, porem não resolve camada 7. Li algumas coisas sobre um servidor WINS, mas nao tenho um 2003 server na rede, pra fazer lookup reverso. Alguem saberia ao certo o motivo dessa porcaria nao funcionar ? Segue o Sh Run do equipamento
R2#sh run
Building configuration...

Current configuration : 3061 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$b9PR$GT7Z0UMPWoeKMRIyNr2Ji0
!
aaa new-model
!
!
!
aaa session-id common
!
resource policy
!
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool VLAN100
network 192.168.1.0 255.255.255.0
default-router 192.168.1.2
dns-server 201.17.0.215
!
ip dhcp pool VLAN200
network 192.168.2.0 255.255.255.0
dns-server 4.2.2.2
default-router 192.168.2.1
netbios-name-server 4.2.2.2
!
ip dhcp pool VLAN300
network 192.168.3.0 255.255.255.0
default-router 192.168.3.1
dns-server 201.17.0.215
netbios-name-server 4.2.2.2
!
!
ip domain lookup source-interface FastEthernet0/0
ip domain name clearit.com.br
ip ssh time-out 30
ip ssh authentication-retries 5
ip ddns update method teste
HTTP
add http://*******:***********%40dynupdate.no-ip.info/nic/update%3Fhostname=*********
interval maximum 1 0 0 0
!
vpdn enable
!
vpdn-group 1
! Default PPTP VPDN group
accept-dialin
protocol pptp
virtual-template 1
!
!
!
!
username root privilege 15 password 7 0347681F03032D45400118574451

!
!
no crypto isakmp enable
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip ddns update teste
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1.100
encapsulation dot1Q 100
ip address 192.168.1.2 255.255.255.0
ip helper-address 192.168.1.2
ip flow ingress
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1.200
encapsulation dot1Q 200
ip address 192.168.2.1 255.255.255.0
ip helper-address 192.168.2.1
ip nat inside
ip virtual-reassembly
!
interface FastEthernet0/1.300
encapsulation dot1Q 300
ip address 192.168.3.1 255.255.255.0
ip helper-address 192.168.3.1
ip nat inside
ip virtual-reassembly
!
interface Serial0/0/0
no ip address
encapsulation frame-relay
shutdown
no fair-queue
clock rate 2000000
!
interface Serial0/0/1
no ip address
shutdown
clock rate 2000000
!
interface Virtual-Template1
ip unnumbered FastEthernet0/0
peer default ip address pool vpn
no keepalive
ppp encrypt mppe 128
ppp authentication ms-chap ms-chap-v2
!
ip local pool vpn 192.168.3.250 192.168.3.254
!
ip flow-top-talkers
top 20
sort-by packets
cache-timeout 1
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet0/0 overload
ip nat inside source list 101 interface FastEthernet0/0 overload
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
access-list 101 permit ip 192.168.2.0 0.0.0.255 any
access-list 101 permit ip 192.168.3.0 0.0.0.255 any

!
!
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
transport input ssh
!
scheduler allocate 20000 1000
end


Obrigado e abraços a galera ae
Voltar ao Topo Ir em baixo
Ver perfil do usuário
marcelosguerra
Admin


Número de Mensagens : 81
Idade : 33
Localização : Sao Paulo - SP
Reputação : 16
Pontos : 80
Data de inscrição : 24/07/2007

MensagemAssunto: Re: Problema de DNS em Vlan com Dhcp    Seg Set 13, 2010 11:31 am

Fala Luiz, tudo bem?

Como você disse que a VLAN 100 esta resolvendo nome, vamos
seguir esta linha de troubleshooting..

Porque a Vlan 100 resolve e as outras não?

---------------------------------------------------------
-> Você consegue chegar da Vlan 300 até o seu
servidor DNS? as maquinas ativas na VLAN300 consegue
chegar até os servidor DNS?

--Faça um ping estendido da Vlans 300(192.168.3.1) até o seu DNS server(201.17.0.215).
R2#ping 201.17.0.215 source 192.168.3.1
---------------------------------------------------------

Obs: Outra coisa, que não esta relacionado com o problema, mas futuramente pode ocorre conflito, não esqueça de excluir no DHCP pool, os ips que voce utiliza para o router e servidores.

Segue duas tutorias.
- http://cisco.forumeiros.com/artigos-de-usuarios-f40/configurando-dhcp-server-no-cisco-ios-t27.htm
- http://www.netip-sec.com.br/?p=218


Sds,
Marcelo Guerra
Voltar ao Topo Ir em baixo
Ver perfil do usuário
luizcahue



Número de Mensagens : 7
Reputação : 0
Pontos : 15
Data de inscrição : 21/06/2008

MensagemAssunto: dns   Ter Set 14, 2010 9:27 am

Cara, pelo que eu me lembro, esse endereço de DNS nao recebe pings, entao pingar pra ele nao nos ajuda. todos os endereços de IP, recebem o ping, mas qndo vc pinga o nome, ele nao chega, como eu disse anteriormente. Honestamente nao estou entendendo muito bem essa situação, tendo em vista que existe um endereço para resolver os nomes, nao existe motivo para isto acontecer. Eu vou realizar os testes novamente qndo estiver no cliente e posto aqui os resultados para continuarmos a avaliação. Muito obrigado @marcelosguerra
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Problema de DNS em Vlan com Dhcp    Hoje à(s) 11:01 am

Voltar ao Topo Ir em baixo
 
Problema de DNS em Vlan com Dhcp
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Problema com arquivos DOC e PDF
» Problema com carregamento de celular?
» Grande problema a 2T
» [Resolvido]Problema com terreno acidentado
» Problema de sinal

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: