Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 Redundancia via BGP, e Hsrp rodando com track CISCO IP SLA

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Mota



Número de Mensagens : 19
Idade : 38
Localização : São Paulo
Reputação : 0
Pontos : 25
Data de inscrição : 17/03/2010

MensagemAssunto: Redundancia via BGP, e Hsrp rodando com track CISCO IP SLA   Dom Jul 11, 2010 6:20 pm

Configurando o BGP

Apesar das varias utilidades postarei uma solução que acabei de utilizar em um cliente.
trata-se de dois links de 30 mb (um principal e outro backup), onde ambos utilizam protocolo de roteamento BGP com a operadora local.
Como troca-se bgp com a operadora a descida e a subida (rota default), é decidida atravéz de route-map no router de borda da operadora definindo qual link é principal e qual é backup ficando assim:


Borda operadora (link Principal)
router bgp 12345
neighbor 10.10.10.10 remote-as 45876
neighbor 10.10.10.10 description eBGP com usuario_30_mega_remoto
neighbor 10.10.10.10 activate
neighbor 10.10.10.10 default-originate
neighbor 10.10.10.10 remove-private-as
neighbor 10.10.10.10 soft-reconfiguration inbound
neighbor 10.10.10.10 route-map RCV_FROM_10.10.10.9 in
neighbor 10.10.10.10 route-map BGP_LIGHT out

Borda_operadora(princ)#show route-map RCV_FROM_10.10.10.9
route-map RCV_FROM_10.10.10.9, permit, sequence 10
Match clauses:
ip address prefix-lists: RCV_FROM_10.10.10.9
as-path (as-path filter): 1
Set clauses:
local-preference 150
community 12345:150 local-AS
Policy routing matches: 0 packets, 0 bytes

ip prefix-list RCV_FROM_10.10.10.9: 2 entries
seq 10 permit 192.168.0.0/24 le 32
seq 20 permit 192.168.1.0/24 le 32

Borda_operadora(princ)#show route-map BGP_LIGHT
route-map BGP_LIGHT, permit, sequence 10
Match clauses:
ip address prefix-lists: ROTA_DEFAULT
Set clauses:
metric 50
Policy routing matches: 0 packets, 0 bytes

Borda_operadora(princ)#sh ip prefix-list ROTA_DEFAULT
ip prefix-list ROTA_DEFAULT: 1 entries
seq 10 permit 0.0.0.0/0

Podemos observar atravéz do route-map RCV_FROM_10.10.10.9 que o mesmo chama uma prefix-list de mesmo nome e que esta prefix list recebe os ip's de lan do CPE e set para local-preference 150.como podemos ver a seguir que no backup esta sendo setado para local-preference 100, o maior local preference será eleito o principal.
O inverso ocorre com a diviulgação da rota defult para o CPE, onde ele pega a rora defult e seta para metrica 50 enquanto o backup é setado para 100.(Nota-Para métrica, inversamente do local preference, sempre terá preferencia a menor métrica.


Borda_operadora(backup)#show configuration | i 10.10.10.2
neighbor 10.10.10.2 remote-as 45876
neighbor 10.10.10.2 description eBGP com usuario_30_mg_backup
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 default-originate
neighbor 10.10.10.2 remove-private-as
neighbor 10.10.10.2 soft-reconfiguration inbound
neighbor 10.10.10.2 route-map RCV_FROM_10.10.10.2 in
neighbor 10.10.10.2 route-map BGP_LIGHT out

Borda_operadora(backup)#show route-map RCV_FROM_10.10.10.2
route-map RCV_FROM_10.10.10.2, permit, sequence 10
Match clauses:
ip address prefix-lists: RCV_FROM_10.10.10.2
as-path (as-path filter): 1
Set clauses:
local-preference 100
community 12345:190 local-AS
Policy routing matches: 0 packets, 0 bytes

Borda_operadora(backup)#show ip prefix-list RCV_FROM_10.10.10.2
ip prefix-list RCV_FROM_10.10.10.2: 2 entries
seq 10 permit 192.168.0.0/24 le 32
seq 20 permit 192.168.1.0/24 le 32

Borda_operadora(backup)#show route-map BGP_LIGHT
route-map BGP_LIGHT, permit, sequence 10
Match clauses:
ip address prefix-lists: ROTA_DEFAULT
Set clauses:
metric 100
Policy routing matches: 0 packets, 0 bytes

Borda_operadora(backup)#show ip prefix-list ROTA_DEFAULT
ip prefix-list ROTA_DEFAULT: 1 entries
seq 10 permit 0.0.0.0/0



CONFIGURANDO HSRP.

No ambiente do Cliente Final, Temos 2 routers para receber 1 link de 30 mb cada.
utilizaremos a configuração de HSRP para garantir que a lan do router B assuma em caso de queda do link de 30 MB do router A.
Geralmente é configurado assim:

Router_B#sh run interface GigabitEthernet0/1
Building configuration...

Current configuration : 210 bytes
!
interface GigabitEthernet0/1
description LAN
ip address 192.168.0.2 255.255.255.0
load-interval 30
duplex auto
speed 100
standby 10 ip 192.168.0.1
standby 10 priority 95
standby 10 preempt
end


Router_A#sh run int GigabitEthernet0/1
Building configuration...

Current configuration : 258 bytes
!
interface GigabitEthernet0/1
description LAN
ip address 192.168.0.3 255.255.255.0
load-interval 30
duplex auto
speed 100
standby 10 ip 192.168.0.1
standby 10 priority 100
standby 10 preempt
standby 10 track GigabitEthernet0/0 decrement 10
end

Note que existe o router B está configurado com a prioridade 95 e o router A está configurado com a prioridade 100, neste caso sempre a maior principal ficará no estado active e o menor no stado stand-by, além disso é comum utilizar uma track onde no caso de queda da interface fisica será decrementado 10 da prioridade do link principal, sendo assim ela fica menor que o link backup (100-10=90) e (90<95) fazendo com que a lan do link principal fique em stand-by e a lan do link backup assuma.Como a interface ficou down (no caso de falha) o bgp caí e o backbone da operadora passara a rotear os pacotes de descida para o router bgp de menor local preference, assumindo assim o router backup tanto para descida quanto subida dos pacotes.



Por fim, tive um problema(que me motivou a postar isso tudo)rsrs, onde a interface fisica não ficava down, porém perdia-se a conectividade com o router de borda principal da operadora.
Sendo assim adotamos uma configuração usando a feature Cisco Ip sla.

Cisco IP SLA

Conhecida antes da versão 12.4T como RTR (Response Time Report) e SAA (Service Assurance Agent), a ferramenta de monitoração Cisco IP SLA (Service Level Agent) é utilizada para fazer monitoração ativa de tempo de resposta via ICMP (ou utilizando outras aplicações como HTTP e DNS), jitter (inclusive jitter unidirecional), perda de pacotes, etc. diretamente em um roteador Cisco, ou seja, sem depender de um outro software ou servidor para fazer a coleta destas informações.

Configurando o IP SLA

Vamos ver um exemplo de configuração para testar conectividade entre CPE e PE. O funcionamento é bastante simples onde o router fica monitorado a conectividade através de pacotes ICMP.

criamos a monitoração numero 171(rsrsrs) onde o router verificará a conectividade ponto-a-ponto entre CPE e PE, em seguida definiremos a frequencia com que este pacote será enviado.

ip sla 171
icmp-echo 10.10.10.9 source-ip 10.10.10.10
frequency 10

Na sequencia ativaremos este monitoramente atravéz do comando abaixo

ip sla schedule 171 life forever start-time now


feito isso ja sera possivel verificar atravéz do comando abaixo as estatisticas do ip sla como quantidade de monitoramentos Ok ou com falha.

Router_A#sh ip sla statistics 171

Round Trip Time (RTT) for Index 171
Latest RTT: 1 milliseconds
Latest operation start time: 18:11:05.011 GMT Sun Jul 11 2010
Latest operation return code: OK
Number of successes: 280
Number of failures: 0
Operation time to live: Forever


Router_A#sh ip sla statistics 171

Round Trip Time (RTT) for Index 171
Latest RTT: 1 milliseconds
Latest operation start time: 18:11:25.011 GMT Sun Jul 11 2010
Latest operation return code: OK
Number of successes: 282
Number of failures: 0
Operation time to live: Forever


EM SEGUIDA CRIAREMOS UMA TRACK E ASSOCIAREMOS AO IP SLA E PODEMOS DEFINIR O DELAY PARA UP O DOWN NESTA TRACK DA SEGUINTE MANEIRA.

track 200 ip sla 171
delay down 25 up 10

POR ULTIMO BASTA INCLUIR ESTÁ TRACK NO HSRP ONDE NO CASO DE PERDA DE CONECTIVIDADE ENTRE OS DOIS PONTOS O IP SLA IRÁ PERCEBER ESTA PERCA DE CONECTIVIDADE E A TRACK TRATA-RA DE RECEBER ESTÁ NFORMAÇÃO E BASEADO NO DELAY CONFIGURADO DEFINIRÁ A SUBTRAÇÃO DA PRIORIDADE DA INTERFACE LAN QUE ESTA RODANDO O HSRP.


interface GigabitEthernet0/1
description LAN
ip address 201.63.208.17 255.255.255.240
load-interval 30
duplex auto
speed 100
standby 10 ip 201.63.208.19
standby 10 preempt
standby 10 track GigabitEthernet0/0
standby 10 track 200 decrement 10

SEGUE CONFIGURAÇÃO FINAL


ip sla 171
icmp-echo 189.44.158.181 source-ip 189.44.158.182
frequency 10
ip sla schedule 171 life forever start-time now


track 200 ip sla 171
delay down 25 up 10

interface GigabitEthernet0/1
description LAN
ip address 201.63.208.17 255.255.255.240
load-interval 30
duplex auto
speed 100
standby 10 ip 201.63.208.19
standby 10 preempt
standby 10 track GigabitEthernet0/0
standby 10 track 200 decrement 10

Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Redundancia via BGP, e Hsrp rodando com track CISCO IP SLA
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» wave 723 nao ta rodando vedeos do youtube
» [TUTORIAL] Aplicativos rodando em Background e Ativar Landscape e Rotate
» Wave 723 rodando Android.
» azamerica s1001 abrindo 43w ceu 70w c2 rodando liso iks sks
» 3DS já pode ser pirateado

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Artigos :: Artigos de usuários-
Ir para: