Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 NAT - alterando origem e destino do pacote

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
ShareBurner



Número de Mensagens : 10
Idade : 31
Localização : Rio de Janeiro
Reputação : 0
Pontos : 3
Data de inscrição : 01/02/2009

MensagemAssunto: NAT - alterando origem e destino do pacote   Sex Maio 28, 2010 10:05 pm

Olá pessoal ...

Estava vendo um dos tópicos sobre NAT e resolvi criar um LAB meio doido.

Estou tentando fazer com que dois roteadores se comuniquem sem que ambos se conheçam tanto em origem e destino.

Aí pensando !!! Mas como eles vão se falar se eles não se conhecem .

NAT .

Alterando a origem e destino ..

Segue a topologia

A <=> B <=> C

O Roteador B será o responsável pelo NAT.

Configuração do Roteador A

interface Loopback0
description SIMULANDO LAN
ip address 169.254.0.1 255.255.255.0
!
interface Serial0/0
description INTERCONEXAO B
ip address 172.16.0.1 255.255.255.252
ip route-cache flow
!
!
ip route 192.168.255.255 255.255.255.255 Serial0/0

Configuração Roteador B

interface Serial0/0
description INTERCONEXAO A
ip address 172.16.0.2 255.255.255.252
ip nat inside
ip route-cache flow
!
!
interface Serial0/1
description INTERCONEXAO C
ip address 192.168.254.1 255.255.255.252
ip nat outside
ip route-cache flow
!
!
ip nat inside source static 169.254.0.1 192.168.254.1
ip nat outside source static 10.1.1.1 192.168.255.255
!
ip route 169.254.0.0 255.255.255.0 Serial0/0
ip route 192.168.255.255 255.255.255.255 Serial0/1


Configuração Roteador C

interface Loopback0
description SIMULANDO LAN
ip address 10.1.1.1 255.255.255.0
!
!
interface Serial0/1
description INTERCONEXAO B
ip address 192.168.254.2 255.255.255.252
ip route-cache flow
!
!
ip route 192.168.254.1 255.255.255.255 Serial0/1


Bem ..

Analisando a mudança do endereço de destino

O roteador A possui uma rota estática para o IP 192.168.255.255 apontando para o roteador B.
Este IP 192.168.255.255 não pertence tanto no roteador B quanto no roteador C.

Quando o roteador A gera um pacote para o destino 192.168.255.255, o mesmo analisa em sua tabela de roteamento se este endereço é conhecido. Encontrado é realizado o next-hop para interface serial 0/0 que faz interconexão ao roteador B.

O roteador B recebendo este pacote com o destino 192.168.255.255 ira analisar também em sua tabela de roteamento se existe alguma rota para o destino, e encontra

ip route 192.168.255.255 255.255.255.255 Serial0/1

Logo encaminha o pacote para a interface Serial 0/1 de interconexão com C.

Quando a interface Serial0/1 recebe este pacote, e a mesma está com o comando nat outside, ela realiza a operação

ip nat outside source static 10.1.1.1 192.168.255.255

Fazendo com que qualquer pacote que a interface serial 0/1 do roteador B receba com o destino 192.168.255.255 sej alterado para o IP 10.1.1.1 que pertence realmente ao roteador C.

Lembrando que a operação de outside está aplicada na interface de interconexão com roteador C.

Logo, o pacote quando chega no roteador C, já chega com o destino correto 10.1.1.1

Isto então significa que o roteador A encaminhou um pacote para o roteador C sem realmente ter conhecimento de seu endereço de destino (10.1.1.1).


Analisando a mudança do endereço de origem

Esta operação já é comum de ser feita.

Pense naquele mesmo pacote gerado anteriormente, sendo que agora estamos tratando a origem.

O roteador A gerou um pacote com a origem 169.254.0.1.

Este pacote chegou ao roteador B pela interface serial0/0 onde possui ip nat inside

Com isso será realizado a operação

ip nat inside source static 169.254.0.1 192.168.254.1

assim que o pacote chegar no roteador B.

Ele ira trocar o endereço de origem de 169.254.0.1 para 192.168.254.1.

Este endereço é o Ip da interface serial 0/1 do roteador B que faz interconexão com o roteador C.

Assim, o pacote chega no roteador C com a origem 192.168.254.1 ao invés de 169.254.0.1 sendo o Ip do roteador A.

Analisando estas alterações com IP cache flow, quando gerando um pacote ICMP partindo do roteador A

origem
169.254.0.1

destino
192.168.255.255


pode ser visto este pacote chegando.

ping 192.168.255.255 source loopback 0 rep 10000

Type escape sequence to abort.
Sending 10000, 100-byte ICMP Echos to 192.168.255.255, timeout is 2 seconds:
Packet sent with a source address of 169.254.0.1
Success rate is 100 percent (10000/10000), round-trip min/avg/max = 1/40/248 ms

ROTEADOR A

SrcIf SrcIPaddress DstIf DstIPaddress Pr SrcP DstP Pkts
Se0/0 192.168.255.255 Local 169.254.0.1 01 0000 0000 2830
Se0/0 172.16.0.2 Local 172.16.0.1 06 4DF0 0017 17

ROTEADOR B

SrcIf SrcIPaddress DstIf DstIPaddress Pr SrcP DstP Pkts
Se0/1 10.1.1.1 Se0/0 192.168.254.1 01 0000 0000 459
Se0/0 169.254.0.1 Se0/1 192.168.255.255 01 0000 0800 472

ROTEADOR C

SrcIf SrcIPaddress DstIf DstIPaddress Pr SrcP DstP Pkts
Se0/1 192.168.254.1 Local 10.1.1.1 01 0000 0800 4397


Bem ... Agora tem que se feito o processo de NAT inverso .

de C => B => A

Alguém se habilita ?


Um abraço a todos ...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
NAT - alterando origem e destino do pacote
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» VENDO DTR-125 2003 (DE ORIGEM)
» Compro ponteira origem Crf450r 2004
» [Sonic Luan - Engines] pacote com 10 engines feitas por min
» Campo de perfil país de origem
» Origem das visitas em um widget

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: