Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 QoS no Cisco 1841 - multilink PPP - 2 link 1MB

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Elton Macedo Lima



Número de Mensagens : 2
Idade : 33
Localização : São Paulo
Reputação : 0
Pontos : 4
Data de inscrição : 10/11/2009

MensagemAssunto: QoS no Cisco 1841 - multilink PPP - 2 link 1MB   Ter Nov 10, 2009 9:07 am

Ola,

Acabei de entrar no forum, estava procurando algo para dar solução a uma programação de QoS que tenho em alguns roteadores Cisco e vi que nesse site temos bastantes pessoas interessadas em ajudar...vamos lá!!

Estou com um Cisco 1841 com dois links de 2MB e com multilink, o Qos foi programado em conjunto com Telefonica mas o cliente alega que nunca funcionou(PICOTES NAS LIGAÇÕES), alterei alguns parâmetros sugeridos forum e estou testando, gostaria de colocar a config do meu router e que alguem me falasse se a config está muito errada...



version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname XXXXX
!
boot-start-marker
boot-end-marker
!
logging rate-limit all 1 except informational
enable password XXXXXX
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
!
!
!
username XXXX privilege 15 secret 5 XXXX
!
!
class-map match-any Multimidia_VPN-IP
match ip dscp ef
match ip dscp cs5
match ip dscp af41
match ip dscp cs4
match access-group name MULTIMIDIA
match access-group name VoIP_IN
match access-group name VOIP
match access-group name VoIP-IN
match access-group 100
class-map match-any Video_IN
match access-group name MULTIMIDIA
match access-group name VoIP_IN
match access-group name VoIP-IN
match ip dscp ef
match ip dscp cs5
match ip dscp af41
match ip dscp cs4
class-map match-all class_VoIP
match ip dscp ef
match ip dscp cs5
match ip dscp af41
match ip dscp cs4
match access-group name VoIP-IN
class-map match-all class_Signaling
match dscp af41
!
!
policy-map VOICE_2048K_WAN
class Multimidia_VPN-IP
priority 1228
police cir 1228000
conform-action transmit
exceed-action drop
class class-default
-fair-queue
random-detect dscp-based

policy-map VOICE_2048K_LAN
class Video_IN
police cir 614000
conform-action set-dscp-transmit af41
exceed-action drop
class class-default
set dscp af11

policy-map WAN
class class_VoIP
priority 1232
police cir percent 30
conform-action transmit
conform-action set-dscp-transmit ef
exceed-action drop
class class_Signaling
bandwidth 48
class class-default
fair-queue
!
!
!
interface Multilink1
bandwidth 4096000
ip address XXXXXXXXX
no ip mroute-cache
no cdp enable
ppp multilink
ppp multilink fragment delay 10
ppp multilink group 1
service-policy output VOICE_2048K_WAN
!
interface MFR1
no ip address
!
interface FastEthernet0/0
description XXXXXXXXXX
ip address XXXXXXXXXXX
duplex auto
speed auto
!
interface FastEthernet0/1
description XXXXXXXXXXXX
ip address XXXXXXXXXXXX
speed 100
full-duplex
service-policy input VOICE_2048K_LAN
!
interface Serial0/0/0
description Multilink Link 1
bandwidth 2048000
no ip address
encapsulation ppp
no ip mroute-cache
no fair-queue
ppp multilink
ppp multilink group 1
max-reserved-bandwidth 95
!
interface Serial0/0/1
description Multilink Link 2
bandwidth 2048000
no ip address
encapsulation ppp
no ip mroute-cache
no fair-queue
ppp multilink
ppp multilink group 1
max-reserved-bandwidth 95

Atenciosamente
Elton
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ping-of-death



Número de Mensagens : 16
Idade : 31
Localização : Rio de Janeiro
Reputação : 0
Pontos : 16
Data de inscrição : 20/09/2007

MensagemAssunto: Re: QoS no Cisco 1841 - multilink PPP - 2 link 1MB   Seg Nov 16, 2009 8:49 pm

Olá Elton.
Realmente existem alguns problemas na sua configuração de QoS.

Na policy de ingresso que vc está usando na Fast0/1 ( VOICE_2048K_LAN ) vc está dando os mesmos macthes que na policy utilizada na multilink1, só que limitando todo o tráfego em 614K. Provalmente esta fila está com drops. Utilize o comando show policy-map interface < interface> para verificar possíveis drops nas filas.

class-map match-any Multimidia_VPN-IP
match ip dscp ef
match ip dscp cs5
match ip dscp af41
match ip dscp cs4

match access-group name MULTIMIDIA
match access-group name VoIP_IN
match access-group name VOIP
match access-group name VoIP-IN
match access-group 100


class-map match-any Video_IN
match access-group name MULTIMIDIA
match access-group name VoIP_IN
match access-group name VoIP-IN
match ip dscp ef
match ip dscp cs5
match ip dscp af41
match ip dscp cs4


Como voz e vídeo são ambos tráfegos realtime porém possuiem perfis diferentes de tráfego, recomendo utilizar uma classe diferente para cada fila para possibilitar uma forma fácil de alterá-las se necessário. VC pode também simplificar o esquema de Q.O.S no caso da multink1 ser o seu único uplink, aplicando apenas a policy de out na interface multilink 1 Segue uma sugestão:

ip access-list extended VOZ
permit ip < redes / ips / portas que fazem voip >

ip access-list extended VIDEO
permit ip < redes / ips / portas que fazem voip >

class-map match-any VOICE
match ip dscp < DSCP p/ pacotes já marcados >
match access-group name VOZ ( classificação para pacotes não-marcados )

class-map match-any VIDEO
match ip dscp < DSCP p/ pacotes já marcados >
match access-group name VIDEO ( classificação para pacotes não-marcados )



policy-map VOICE_2048K_WAN
class VOICE
priority <banda voz >
police <banda voz > conform-action set-dscp-transmit < DSCP p/remarcação > exceed-action drop
class VIDEO
priority <banda voz> <burst voz>
police <banda voz> < burst voz > conform-action set-dscp-transmit < DSCP p/ remarcação > exceed-action drop
class be
bandwidth < garanta pelo - 10% de banda para BE >
random-detect dscp-based
random-detect dscp 0 324 972 1
set ip dscp default

Além de verificar a conectividade da origem até o destino dependendo do tipo de serviço oferecido pela sua operadora seu QoS pode não ter efeito dentro do backbone do seu ISP. Se o serviço oferecido for uma VPN por exemplo, informe-se sobre as marcações utilizadas pelo seu ISP e configure o QoS de acordo dependendo a aplicação.

Ficou um pouco embolado + espero que ajude. Abçs! Razz
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Elton Macedo Lima



Número de Mensagens : 2
Idade : 33
Localização : São Paulo
Reputação : 0
Pontos : 4
Data de inscrição : 10/11/2009

MensagemAssunto: Re: QoS no Cisco 1841 - multilink PPP - 2 link 1MB   Seg Nov 16, 2009 9:01 pm

Obrigado pelo apoio meu brother,

Também cheguei nessa mesma conclusão quanto ao QoS no meu ISP, percebo que tudo vai bem se o link estiver com uma baixa utilização, simulei um teste inserindo trafego no link com o tfgen e vai tudo bem até inserir o tráfego, ou seja, o QOS não está segurando, só não se como vou provar para operadora que o problema é dela e não meu...mesmo assim vou fazer as mudanças solicitadas e testar novamente..

Mais uma vez obrigado pelo apoio

Atenciosamente
Elton
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: QoS no Cisco 1841 - multilink PPP - 2 link 1MB   Hoje à(s) 12:57 am

Voltar ao Topo Ir em baixo
 
QoS no Cisco 1841 - multilink PPP - 2 link 1MB
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» como configurar no-ip em cisco 1841
» Toon Link 3D!! [Formas][Colorido!]
» [Link]Tudo para seu Photoshop
» Sprites do Link para o meu jogo
» Link redirecionando

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: