Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 Ajuda com 2 Wan e balanciamento no cisco 2501

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
vh_emi



Número de Mensagens : 9
Idade : 27
Localização : Santo Anastácio - SP
Reputação : 0
Pontos : 13
Data de inscrição : 25/03/2009

MensagemAssunto: Ajuda com 2 Wan e balanciamento no cisco 2501   Qua Jul 15, 2009 2:58 pm

Galera, estou precisando de uma ajuda aqui com um cisco 2501.
é o seguinte nesse momento tenho uma LP de 2MB ligado a serial0
e na ethernet0 está ligado o mikrotik.
O mikrotik está em bridge, para eu poder colocar os clientes com ips publicos.
Ex.:
WAN remoto 123.123.123.1
WAN Local 123.123.123.2
IP LAN 100.200.100.100/29
IP LAN 2 100.200.200.100/26

Router cisco 2501:
Serial0 ip 123.123.123.2
Ethernet0 ip 100.200.100.101
route 0.0.0.0 0.0.0.0 123.123.123.1

Mikrotik
Link 100.200.100.102
Rede 100.200.100.103
Brindge em Link e Rede
NAT 192.168.0.0/16
e alguns clientes com ips publicos da faixa 100.200.100.100/26 que sobrou

tenho um problema, não sei como adicionar a segunda faixa de ips ( 100.200.200.100/26 ) no roteador para que funcione no mikrotik para os clientes, pois até agora só consegui fazer a primeira faixa que é a mesma que está na ethernet0 do cisco funcionar, então queria saber como faço para fazer ess segunda faixa de ips publicos funcionar e se tem como eu fazer isso sem ter que usar uma bridge no mikrotik.

o segundo problema é que está pra chegar outro link de 2MB da mesma operadora e não faço a minima ideia do que tenho que fazer para que esse link funcione no roteador, ou seja para que eu junte 2MB+2MB=4MB lembrando que os 2 links é da mesma operador, então não preciso fazer load balancing, e concerteza vamos receber uma outra faixa de ip LAN /29 e um ip WAN do ponto-a-ponto.

Galera preciso muito dessa ajudinha...
Obrigado!!!!!!!!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Qui Jul 16, 2009 6:09 pm

Ola boa noite

Para adicionar a segunda faixa de ips ( 100.200.200.100/26 ) no roteador, acho que apenas esta rota deva resolver:

ip route 100.200.200.64 255.255.255.192 100.200.100.103

Quanto ao balanceamento, ele pode ser feito de dois modos, o primeiro é devidindo sua subnet fazendo com que cada parte trafegue por um link e caso ocorra sua queda todo o trafego irá por outro link. (Me recordo de um outro topico aonde foi explicada esta config.).

Outra possibilidade é o balanceamento por pacotes ou por destino, mas para ambos os casos os dois links devem estar conectados ao mesmo PE.

abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
vh_emi



Número de Mensagens : 9
Idade : 27
Localização : Santo Anastácio - SP
Reputação : 0
Pontos : 13
Data de inscrição : 25/03/2009

MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Sex Jul 17, 2009 9:08 am

Ainda não consegui, adicionei essa faixa no roteador da cisco, e coloquei no ip address do mikrotik a faixa de ip para eu me conectar, mais mesmo assim não funcionou... estou precisando urgentemente dessa faixa de ips.
Obrigado mesmo assim pela ajuda!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Sex Jul 17, 2009 9:30 am

1) Verifica se tua rede lan 2 está realmente roteada no PE da operadora
Depois basta fazer como o nakano mencionou , rotear a mesma pra traz do ip do teu microtik

2) Sobre balanceamento, o 2501 por ser uma série de estudo, conta com pouco recurso de processador. Ja vi 2501 com 2 links de 2 mb balanceados por destino , estourando o limite do processador quando a banda chegava a no maximo 3 mb... As versoes de IOS que tentei inserir nele, nenhuma aceitava CEF... enfim, nao recomendo.
Caso insista, podes configurar as saidas via route-map's , (fazendo cada faixa lan sair por cada link), via Destino (fluxos de multiplas conexoes saindo alternadamente pelos 2 links, ja vem default no cisco e é melhor que o perpacket pra aplicativos sensiveis a jitter), via per packet (um pacote por link, ruim pra aplicativos sensiveis a jitter) ou via multilink (caso a versao dos pe's seja atual, seria o melhor) , q creio q o 2501 nao suporte.

Seguem exemplos.

1) Por destino
--------------------------------------------
interface serial 0
encap ppp
ip add x.x.x.x x.x.x.x
ip load-sharing per-destination
no shut

interface serial 1
encap ppp
ip add x.x.x.x x.x.x.x
ip load-sharing per-destination
no shut


ip route 0.0.0.0 0.0.0.0 serial 0
ip route 0.0.0.0 0.0.0.0 serial 1

---------------------------------------------

2) Por pacotes

---------------------------------------------
interface serial 0
encap ppp
ip add x.x.x.x x.x.x.x
ip load-sharing per-packet
no shut

interface serial 1
encap ppp
ip add x.x.x.x x.x.x.x
ip load-sharing per-packet
no shut

ip route 0.0.0.0 0.0.0.0 serial 0
ip route 0.0.0.0 0.0.0.0 serial 1

---------------------------------------------

3) Via Multilink

interface multilink 1
ppp multilink
ppp multilink group 1
ip address x.x.x.x x.x.x.x
no shut

interface serial 0
encapsulation ppp
ppp multilink
ppp multilink group 1
no shut

interface serial 1
encapsulation ppp
ppp multilink
ppp multilink group 1
no shut

ip route 0.0.0.0 0.0.0.0 multilink 1

----------------------------------------------------

Via route-map (nao balanceia, simplesmente envia cada lan pra cada link correspondente)

interface fastethernet 0
ip policy route-map SEGUNDO_LINK
ip address x.x.x.x x.x.x.x
no shut

interface serial 0
ip add x.x.x.x x.x.x.x
encap ppp
no shut
exi

interface serial 1
ip add x.x.x.x x.x.x.x
encap ppp
no shu
exi

ip route 0.0.0.0 0.0.0.0 serial 0

ip access-list extended SEGUNDO_LINK (Rede lan secundaria q saira pelo link da serial 1)
permit ip x.x.x.x x.x.x.x any
permit ip any x.x.x.x x.x.x.x

route-map SEGUNDO_LINK permit 10
match ip address SEGUNDO_LINK
set default interface serial 1
ou
set ip next-hop x.x.x.x (ip remoto do link da serial 1)
--------------------------------------------------


[b]nao esquece, pra cada tipo de load-balance configurado no teu cpe, o PE deve ser configurado da mesma forma (operadora). No caso do multilink, deve estar no mesmo slot do pe (caso usar sonet, solicitar pra que usem o mesmo KLM).

Abração e qualquer coisa prende o grito!!!

afro
Voltar ao Topo Ir em baixo
Ver perfil do usuário
vh_emi



Número de Mensagens : 9
Idade : 27
Localização : Santo Anastácio - SP
Reputação : 0
Pontos : 13
Data de inscrição : 25/03/2009

MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Sab Jul 18, 2009 1:10 pm

Concerteza não vou fazer por route-map, por que eu quero somar os dois links, e como é da mesma operadora, acho que vou fazer perpacket, ou o que já vem por default, vou tentar, e posto o resultado, obrigado!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
vh_emi



Número de Mensagens : 9
Idade : 27
Localização : Santo Anastácio - SP
Reputação : 0
Pontos : 13
Data de inscrição : 25/03/2009

MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Qua Jul 22, 2009 9:10 am

Estou tentando fazer essa Confg:

1) Por destino
--------------------------------------------
interface serial 0
encap ppp
ip add x.x.x.x x.x.x.x
ip load-sharing per-destination
no shut

interface serial 1
encap ppp
ip add x.x.x.x x.x.x.x
ip load-sharing per-destination
no shut


ip route 0.0.0.0 0.0.0.0 serial 0
ip route 0.0.0.0 0.0.0.0 serial 1


Mais o meu roteador não está respondendo aos comandos.
quando digito já no ip load-sharing per-destination ele já não aceita.
e outra eu acho que tenho que apagar todas as confg e fazer de novo pra ele aceitar as rotas, então com que faço para apagar as rotas que eu já fiz nele para adicionar essas confg, e claro para fazer funcionar, mesmo no modo privilegiado (enable) eu não consigo.

Valeu galera, estão me ajudando muito!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Qua Jul 22, 2009 10:55 am

se ele nao aceita eh pq o teu IOS eh antigo, entao o per-destination jah eh default, nao te preocupa. Só insere as rotas pras duas seriais e jah era!

abraço!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
vh_emi



Número de Mensagens : 9
Idade : 27
Localização : Santo Anastácio - SP
Reputação : 0
Pontos : 13
Data de inscrição : 25/03/2009

MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Qua Jul 22, 2009 11:03 am

Então eu inseri as rotas, coloquei a segunda rota agora que ligou a lp
por ex.
ip wan da nova lp 1.2.3.70

interface serial 0
ip add 1.2.3.4.70
no shut
ip route 0.0.0.0 0.0.0.0 1.2.3.4.69

ai quando dou o show run aparece as duas rotas 0.0.0.0 0.0.0.0 (ip wan serial 0)
0.0.0.0 0.0.0.0 (ip wan da serial 1)
mais não está somando os 2 links, pelo que estou vendo só está saindo na serial 0
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Qua Jul 22, 2009 11:07 am

1) verifica com tua operadora se foi balanceado no PE
2) O balanceamento por destino é desparelho, ora sai por um ora por outro, devido ao fato de trabalhar com fluxos
Voltar ao Topo Ir em baixo
Ver perfil do usuário
vh_emi



Número de Mensagens : 9
Idade : 27
Localização : Santo Anastácio - SP
Reputação : 0
Pontos : 13
Data de inscrição : 25/03/2009

MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Qua Jul 22, 2009 5:39 pm

Eu verifiquei com eles, o balanceamento tem que ser feito por destino mesmo.
mais mesmo assim não consigo somar os 2+2 para dar 4MB...
Parece que o problema está mesmo no Roteador.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Qui Jul 23, 2009 9:50 am

ocorre que por destino, se tu testar com apenas uma maquina ligada ao router, nao vais passar de 2 mb

tem que ter multiplas conexoes, sacou?

bota algumas maquinas usando o gateway 2501 e trafega bastante com elas q tu vai ver ele ir aos 4 mega

abraço
Voltar ao Topo Ir em baixo
Ver perfil do usuário
vh_emi



Número de Mensagens : 9
Idade : 27
Localização : Santo Anastácio - SP
Reputação : 0
Pontos : 13
Data de inscrição : 25/03/2009

MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Qui Jul 23, 2009 2:34 pm

joester.brondani escreveu:
ocorre que por destino, se tu testar com apenas uma maquina ligada ao router, nao vais passar de 2 mb

tem que ter multiplas conexoes, sacou?

bota algumas maquinas usando o gateway 2501 e trafega bastante com elas q tu vai ver ele ir aos 4 mega

abraço

Então o consumo de banda não está passando de 2MB, pelo mikrotik, muitos clientes estão com ips privados e outros com ips publicos, mais mesmo assim não está passando de 2MB...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Sex Jul 24, 2009 10:57 am

verifica tua versao de IOS
se for acima de 12.x.x jah tem o ip classless ativado
se nao, ative-o

config# ip classless



mas é como eu disse
25xx é linha de estudo, nao é recomendado pra essa aplicaçao.

um 1721 jah faz 6 mb tranqilamente!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Sex Nov 27, 2009 10:12 pm

por acaso, fui ver o datasheet da linha 2500 , nao processa mais do que 2.1 mb Wink

abracao.

_________________
Joéster
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Ajuda com 2 Wan e balanciamento no cisco 2501   Hoje à(s) 7:29 am

Voltar ao Topo Ir em baixo
 
Ajuda com 2 Wan e balanciamento no cisco 2501
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Ajuda Ndrive
» ajuda ajuda kies
» [Ajuda]Como fazer sistema de dinheiro "money"
» [Ajuda] Como faço isso?
» Ajuda com ranks

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: