Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
EMatias



Número de Mensagens : 11
Idade : 41
Localização : São Paulo
Reputação : 0
Pontos : 13
Data de inscrição : 07/07/2009

MensagemAssunto: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Ter Jul 07, 2009 12:24 pm

Boa Tarde a Todos,
Necessito de uma grande ajuda para configurar meu Cisco877.
Deixa explicar o cenario que tinha e o que quero fazer.
O Router estava ligado a um link ADLS pelo par telefonico, funciona perfeitamente.

O Problema é que mudamos nosso link e agora recebi um link ADSL via Fibra ou seja tem um Router que recebe a fibra e me libera um cabo Ethernet.

Como faço para que meu 877 autentique pppoe atraves de uma porta Fastethernet. Ja fiz todos os testes possiveis e não consegui, por isso recorro a voces.

Fico no aguardo de uma ajuda.

Abraço a todos.

Eduardo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Ter Jul 07, 2009 9:06 pm

Eu imaginei um caso semelhante utilizando um router com duas interfaces fast ethernet. No caso do 877, creio q ele tenha uma interface VLAN e 4 fast associadas, mesmo assim creio q nao mude muita coisa. Espero correçoes dos mais experts.

abraco



--------------------------------------------------------------------------------------

interface fastethernet0
description - conectar a fibra -
pppoe-client dial-pool number 1 service-name adsl
no shut
!
interface fastethernet 1
description - conecttar a intranet -
ip address x.x.x.x x.x.x.x (ip invalido - ex: 10.1.1.1/24)
no shut
ip nat inside
!
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username sidjsidhu@xxx.com.br password hushussu
no shut
!
ip route 0.0.0.0 0.0.0.0 dialer 0
ip nat inside source route-map ADSL interface dialer 0 overload
!
route-map ADSL
match ip address ADSL
set default-interface dialer0
!
ip access-list extended ADSL
permit ip any any
!
dialer-list 1 protocol ip permit
!
do wr

nunca tinha ouvido falar de adsl via fibra, ate pq adsl significa assimetric digital subscribber line, ou seja, LINHA digital assimetrica do assinante... Vc nao tah confundindo com um link metroethernet? enfim... a parte de autenticacao seria basicamente essa... ate porque a parte do PVC deve ficar no router que esta conectado a fibra, creio eu... (vpi-vci)... enfim, se for assim, basta que o cisco autentique dessa forma exemplificada acima... ja pensou na possibilidade de esse link ser um Metroethernet e/ou nao requerer autenticacao? hhuehue... enfim, se puder dar mais detalhes sobre teu link, ficaria melhor entende-lo

abracao!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Ter Jul 07, 2009 9:23 pm

pequeno lembrete

...caso seja um link metroethernet, e utilize meio SDH, em alguns casos o sdh eh interligado a rede metro via interfaces gbic sfp. Isso requer configuracao da mesma vlan criada no switch metro, no roteador do CLIENTE (vlan ID e encaps. dot1q) , para o funcionamento.

Abraco!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
EMatias



Número de Mensagens : 11
Idade : 41
Localização : São Paulo
Reputação : 0
Pontos : 13
Data de inscrição : 07/07/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Qua Jul 08, 2009 12:44 am

Pessoal, Me desculpa
Realmente falta informação para voces poderem ajudar.

É o seguinte, estou testando um link da Telefonica Speedy Extreme, pelo que entendi o serviço é da TVA e vem por fibra.

Instalaram aqui um Router da Huawei Echolife HG850 que tem 1 entrada de Fibra e 4 portas Ethernet's de saida.

Foi uma briga com a Telefonica, pois o proprio suporte da telefonica não sabia me dizer como realizava a conexão do meu PC com a internet (Omiti o fato de que tinha um router Cisco aqui).

Depois de muito me bater, o suporte da TVA me disse que tinha que criar uma nova conexão no meu PC, basicamente como um discador para autenticar na NET.

Não sei exatamente se é um link ADSL, segundo documentação da Telefonica sim, mas não posso afirmar.

Ja realizei varios testes aqui, mas realmente não consigo colocar meu Router no meio da brincadeira entre Huawei e PC.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Qua Jul 08, 2009 1:00 am

entao pode usar esse meu exemplo. o huawei ja tah fazendo a parte do pvc, basta mandar o cisco autenticar.

porem nao vejo o por que usar o cisco
podes usar o proprio xp mesmo
cria uma nova conexao (que exija nome de usuario e senha)

os drivers pppoe sao nativos no xp

abracao!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
EMatias



Número de Mensagens : 11
Idade : 41
Localização : São Paulo
Reputação : 0
Pontos : 13
Data de inscrição : 07/07/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Qua Jul 08, 2009 1:05 am

Obrigado Joester,

Vou testar, na realidade tenho 6 maquinas aqui em casa em uma rede. por iso quero que o cisco autentique, tenho um Switch Cisco interligado com o Router.

Valeu, obrigado pela ajuda, vou testar.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
EMatias



Número de Mensagens : 11
Idade : 41
Localização : São Paulo
Reputação : 0
Pontos : 13
Data de inscrição : 07/07/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Qua Jul 08, 2009 2:32 am

Joester,

Relizei a configuração que vc falou, mas nao rola.

Segue abaixo a config. do meu router, veja se vc pode me ajudar.

Obrigado.


Building configuration...

Current configuration : 4655 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterMatias
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!

dot11 syslog
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool sdm-pool
import all
network 10.10.10.0 255.255.255.248
default-router 10.10.10.1
lease 0 2
!
!
no ip domain lookup
ip domain name matias.com.br
!
!
!
archive
log config
hidekeys
!
!
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0
description Rede Interna
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
description Conexao Fibra
pppoe-client dial-pool-number 1
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Dialer0
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname emmatias@terra.com.br
ppp chap password 0 *******
ppp pap sent-username emmatias@terra.com.br password 0 ******
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source route-map ADSL interface Dialer0 overload
!
ip access-list extended ADSL
remark SDM_ACL Category=18
permit ip any any log
!
dialer-list 1 protocol ip permit
no cdp run
!
!
route-map ADSL permit 10
match ip address ADSL
set default interface Dialer0
!
!
control-plane
!
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
!
scheduler max-task-time 5000
end
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Qua Jul 08, 2009 11:39 am

nesse teu caso ocorre que a fast/ethernet q tu botou pra fibra pertence a inteface vlan 1


terias que trabalhar independentemente creio eu... nao manjo mto disso nao hehue

axo q o nakano eh o cara q vai te responder melhor


abraço!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Qua Jul 08, 2009 7:11 pm

Bom, antes de mais nada gostaria de agredecer ao Joester pela consideração rssss.

Acho que primeiro podemos eliminar este NAT dinâmico para testar, então antes de fazer com que toda a sua rede conecte, altera esta config de NAT de 1 para 1 e testa a partir de sua máquina.

NO ip nat inside source route-map ADSL interface Dialer0 overload
ip nat inside source static 10.10.10.x interface Dialer0

Se assim não funcionar tenta habilitar mais um comando em sua FastEthernet3

FastEthernet3
pppoe enable

Se continuar não funcionando, tenta tirar esta VLAN 1 ela não esta fazendo sentido na sua config.

no interface Vlan1
interface FastEthernet0
ip address 10.10.10.1 255.255.255.0
ip nat inside
no ip virtual-reassembly
ip tcp adjust-mss 1452

Se mesmo assim não funcionar vamos tentar uma config um pouco diferente (Estou mantendo o nat estático, se por acaso funcionar nós mudamos para dinâmico)

vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
interface FastEthernet0
ip address 10.10.10.1 255.255.255.0
ip nat inside
no ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface FastEthernet3
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer0
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap
ppp pap sent-username emmatias@terra.com.br password 0 ******
!
ip classless
dialer-list 1 protocol ip permit
ip nat inside source static 10.10.10.x interface Dialer0
ip route 0.0.0.0 0.0.0.0 dialer0

abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Qua Jul 08, 2009 7:19 pm

ahhh se mesmo com esta ultima config não funcionar tenta acessar a internet e coleta algumas informações do cisco:

show vpdn session all
show interface Dialer0
show dialer
show interface FastEthernet3

Sinceramente a maior parte das configurações eu escrevi meio que por dedução e não tenho nenhum 877 para testar rssss. Por isso estou pedindo estes outputs.


abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
EMatias



Número de Mensagens : 11
Idade : 41
Localização : São Paulo
Reputação : 0
Pontos : 13
Data de inscrição : 07/07/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Qui Jul 09, 2009 3:56 pm

Nakano, estava testando as configurações sugeridas por voce, e me deparei com mais uma duvida, o meu Router nao tem o comando "pppoe enable". O Router 877 da Cisco tenho aqui, ele tem 1 porta adsl e 4 fastehternet, sera que eu só consigo utilzar como porta WAN essa porta ADSL? É possivel utilizar alguma dessa porta fastehternet como WAN?

abs
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Qui Jul 09, 2009 4:07 pm

Amigo

Pra utilizares uma das fast como wan faça o seguinte:

Crie duas interfaces VLAN. Uma delas, ja vem nativa (interface vlan 1)
Coloque nela um ip pra comunicar com tua intranet.

Exemplo

!
Interface vlan 1
description INTRANET
ip address 10.10.10.1 255.255.255.0
no shut
!

Após, crie a interface vlan 2 que seria tua wan e usa as configs de PPPOE CLIENT na vlan 2 ao invés das fast.

!
interface vlan 2
description WAN
no ip address
pppoe-client dial-pool-number 1
no shut
!

Aí, cria as vlans e faz a associação de vlans - portas
Exemplo 1:
"criar vlans"
!
router-config#

vlan 1
said 1
media ethernet
state active
exit

vlan 2
said 2
media ethernet
state active

----------------------------------

exemplo 2:
Associar portas:
!
Interface fastEthernet0
description "bridge com vlan 1 para intranet"
switchport access vlan 1
no shut
!
interface fastEthernet1
description "bridge com vlan 1 para intranet"
switchport access vlan 1
no shut
!
interface fastEthernet2
description "bridge com vlan 1 para intranet"
switchport access vlan 1
no shut
!
interface fastEthernet 3
description "bridge com vlan 2 para wan"
switchport access vlan 2
no shut
!

Nesse caso, usarás as 3 primeiras portas FE pra conectar a tua intranet (switches, hub's ou pcs) e a ultima (fast3) para conectar ao modem q tá na fibra.

!

ps. Nao esqueça, as portas q tu associares a vlan 1 (ou o numero q tu quiser), pertencerao a interface vlan 1 (farao uma bridge), e consequentemente, as q tu associares a vlan 2 ou 3 etc etc, farao bridge com a interface vlan correspondente. Podem ser tratadas como interfaces distintas e indepententes.

Cada porta responderá pela config de sua interface vlan correspondente, como se fosse uma interface física independente.

Nao sei se te ajudará em específico, mas pro pessoal que quiser usar as portas separadamente , com ips diferentes e roteamento entre vlans, creio q vá servir!


Abraços!!!!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
EMatias



Número de Mensagens : 11
Idade : 41
Localização : São Paulo
Reputação : 0
Pontos : 13
Data de inscrição : 07/07/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Seg Jul 20, 2009 9:04 pm

Pessoal,

Ja tentei de tudo, e não rola.

Consegui fazer funcionar atraves de um link ADSL normal, funcionou perfeito, mas com o SpeedyExtreme ainda não consegui.

Abaixo segue a config que tenho funcionando aqui, por favor me ajudem o que tenho que alterar para que ao inves de utilizar a porta ADSL do router utilize o link atraves da FastEthernet3 por exemplo.

Estou tentando algumas coisas por exemplo substituir somente a parte do ATM por VLAN 300. mas nao deu muito certo


Building configuration...

Current configuration : 8076 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname MatiasRouter
!
boot-start-marker
boot-end-marker
!
logging buffered 51200
logging console critical
enable secret 5 $1$PN5c$0uQTeCAV84RKvYMoDbq.40
!
aaa new-model
!
!
aaa authentication login local_authen local
aaa authorization exec local_author local
!
!
aaa session-id common
clock timezone PCTime -3
!
crypto pki trustpoint TP-self-signed-3634811238
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3634811238
revocation-check none
rsakeypair TP-self-signed-3634811238
!
!
crypto pki certificate chain TP-self-signed-3634811238
certificate self-signed 01
3082025C 308201C5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 33363334 38313132 3338301E 170D3039 30373038 30343539
32365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 36333438
31313233 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100914A B5D5870A 2004FF5E 263CF7A9 2599BF91 C036E55E E351A895 B560350F
659F1ABE 51F5CC65 8459367C 9AB95B2C 03552EE7 6DFF0BD4 637D6C2F E288D494
87A60CFD AD3BBEBD B7E86392 9FA838A2 323E32E4 29675CCE ABE1AD54 FABCA9E5
9EB63765 48107685 C8B8FB68 D28B39A7 D4677ACA 4FDFA693 44A56C34 FFDBA46F
4C6D0203 010001A3 81833081 80300F06 03551D13 0101FF04 05300301 01FF302D
0603551D 11042630 24822243 4D4B526F 75746572 2E636D6B 70726F6A 65746F2E
686F6D65 6C696E75 782E6E65 74301F06 03551D23 04183016 801489E6 A2EA0A39
A8BBAD18 7046B7D2 54BE3422 DFC0301D 0603551D 0E041604 1489E6A2 EA0A39A8
BBAD1870 46B7D254 BE3422DF C0300D06 092A8648 86F70D01 01040500 03818100
556A3DBC 32C63AF6 24651AF4 47CB36A8 3D72D7BC 49249574 E010F76E E5F0D9D4
57E274AB 36548654 873AEBB1 B7526F5C F2837FAA DF6C3880 83C8C3DF 085CF1FF
1EA22547 03CC2D9A 16EFBC3F F572E40D 5349AADA EB484D28 53149660 B390A06C
8287F89E 032AF971 DC2A3FD7 10EB3F31 D55FFEEB C3FC35C5 03004985 F6941511
quit
dot11 syslog
no ip source-route
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.99
ip dhcp excluded-address 10.10.10.151 10.10.10.254
!
ip dhcp pool sdm-pool1
import all
network 10.10.10.0 255.255.255.0
dns-server 208.67.222.222 208.67.220.220
default-router 10.10.10.1
!
!
no ip bootp server
ip domain name Matiasprojeto.homelinux.net
ip name-server 208.67.222.222
ip name-server 208.67.220.220
!
!
!
username MatiasRoot privilege 15 secret 5 $1$ZCrB$gK8KKweMixCuszJoL750U1
!
!
archive
log config
hidekeys
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
class-map type inspect match-any sdm-cls-insp-traffic
match protocol cuseeme
match protocol dns
match protocol ftp
match protocol h323
match protocol https
match protocol icmp
match protocol imap
match protocol pop3
match protocol netshow
match protocol shell
match protocol realmedia
match protocol rtsp
match protocol smtp extended
match protocol sql-net
match protocol streamworks
match protocol tftp
match protocol vdolive
match protocol tcp
match protocol udp
class-map type inspect match-all sdm-insp-traffic
match class-map sdm-cls-insp-traffic
class-map type inspect match-any sdm-cls-icmp-access
match protocol icmp
match protocol tcp
match protocol udp
class-map type inspect match-all sdm-invalid-src
match access-group 100
class-map type inspect match-all sdm-icmp-access
match class-map sdm-cls-icmp-access
class-map type inspect match-all sdm-protocol-http
match protocol http
!
!
policy-map type inspect sdm-permit-icmpreply
class type inspect sdm-icmp-access
inspect
class class-default
pass
policy-map type inspect sdm-inspect
class type inspect sdm-invalid-src
drop log
class type inspect sdm-insp-traffic
inspect
class type inspect sdm-protocol-http
inspect
class class-default
policy-map type inspect sdm-permit
class class-default
!
zone security out-zone
zone security in-zone
zone-pair security sdm-zp-self-out source self destination out-zone
service-policy type inspect sdm-permit-icmpreply
zone-pair security sdm-zp-out-self source out-zone destination self
service-policy type inspect sdm-permit
zone-pair security sdm-zp-in-out source in-zone destination out-zone
service-policy type inspect sdm-inspect
!
!
!
interface Null0
no ip unreachables
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $ES_WAN$$FW_OUTSIDE$
no ip redirects
no ip unreachables
no ip proxy-arp
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
ip address 10.10.10.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
zone-member security in-zone
ip route-cache flow
ip tcp adjust-mss 1412
!
interface Dialer0
description $FW_OUTSIDE$
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip nat outside
ip virtual-reassembly
zone-member security out-zone
encapsulation ppp
ip route-cache flow
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname Matias.projetos@br.inter.net
ppp chap password 7 070C2C471F5B4A5142
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 2
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
!
logging trap debugging
logging 10.10.10.100
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 10.10.10.0 0.0.0.255
access-list 2 remark HTTP Access-class list
access-list 2 remark SDM_ACL Category=1
access-list 2 permit 10.10.10.0 0.0.0.255
access-list 2 deny any
access-list 100 remark SDM_ACL Category=128
access-list 100 permit ip host 255.255.255.255 any
access-list 100 permit ip 127.0.0.0 0.255.255.255 any
access-list 101 remark VTY Access-class list
access-list 101 remark SDM_ACL Category=1
access-list 101 permit ip 10.10.10.0 0.0.0.255 any
access-list 101 deny ip any any
dialer-list 1 protocol ip permit
no cdp run
!
!
!
control-plane
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Router and Security Device Manager (SDM) is installed on this device and
it provides the default username "cisco" for one-time use. If you have already
used the username "cisco" to login to the router and your IOS image supports the
"one-time" user option, then this username has already expired. You will not be
able to login to the router with this username after you exit this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you want to
use.

-----------------------------------------------------------------------
^C
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login authentication local_authen
no modem enable
transport output telnet
line aux 0
login authentication local_authen
transport output telnet
line vty 0 4
access-class 101 in
privilege level 15
authorization exec local_author
login authentication local_authen
transport input telnet ssh
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Ter Jul 21, 2009 8:44 am

Amigo

Se funcionar, me deves uma caixa de cerveja pois:

Fui no almox da empresa, peguei um cisco 877
Fui até o DG da OI , peguei uma porta adsl PPPOE
Fiz todos os testes até funcionar HEHE

Seguem algumas consideraçoes:

1) Teu adsl é PPPOE? Se for PPPOA, sao outras configuraçoes. (ppoe = residencial)
2) Teu modem/transceiver ja esta com o PVC configurado e está em modo bridge? Obrigatoriamente deve estar. Os pvc's varian de acordo com regiao/operadora. No caso daqui do sul, OI = vpi 1 vci 32, GVT 0/35, ETC.... Essa config deve ficar no modem q leva teu adsl , o mesmo deve estar em Bridge, nao em router.
3) Deve-se desabilitar o spanning-tree nas vlans do 877, senao ele fica bloqueando, pode ser esse um dos motivos do nao funcionamento.


Segue o exemplo que funcionou pra mim :

Modem ADSL = Nec Gs250S
Modo Bridge , vpI1, vcI32, LLC, ANSI

Router= Cisco 877

hostname Joester

ip dhcp pool joester
network 1.1.1.0 255.255.255.0
default-router 1.1.1.1
dns-server 201.10.1.2
!
no spanning-tree vlan 2
no spanning-tree vlan 10
!
interface atm 0
shutdown
exi
!
interface fastethernet0
switchport access vlan 10
no shut
!
interface fastethernet 1
switchport access vlan 10
no shut
!
interface fastethernet 2
switchport access vlan 10
no shut
!
interface fastethernet 3
description - Conectar ao ADSL -
switchport access vlan 2
no shut
!
interface vlan 1
description Nativa no 877
shutdown
!
interface vlan 2
description - Saida ADSL - Fe3
pppoe-client dial-pool-number 1
no shut
!
interface vlan 10
description - Intranet -
ip address 1.1.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no shut
!
interface dialer 1
description - Autenticaçao -
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username joester@joester.com.br password xxxxx
no shut
!
ip route 0.0.0.0 0.0.0.0 dialer 1
!
ip nat inside source list 1 interface dialer 1
!
access-list 1 permit any
dialer-list 1 protocol ip permit
!

end


Use PAP na dialer 1 ao invés de CHAP
Desative o spanning-tree nas vlans
Verifique as configs de vp/vc e o modo bridge

Tem que funcionar, aqui fiquei navegando dessa forma Smile

Ps:

As portas fastethernet 0, 1 e 2 ficaran pra tua intranet, e fornecendo DHCP

A porta fastethernet 3 ficou somente pra conectar ao adsl

Devido ao fato de estar em bridge, caso nao autentique , basta dar shutdown e no shutdown na interface dialer 1 até que suba.

A forma de se ver como autenticou é:

show int dia 1

ela tem que aparecer (protocolo up via spoofing) , e tem de criar uma interface virtual-access. Se nao aparecer a virtual-access, eh pq ainda nao autenticou. Aguarda um pouco e derruba a dialer 1 ', e torna a subir até que a virtual-access apareça.

e o principal:

SEMPRE, em todo e qualquer router novo da cisco, quando iniciar pela primeira vez, loga com user cisco, senha cisco, entra no modo enable e ZERA a configuraçao dele. "erase startup-config", enter, confirma, e desliga e liga o router.
O SDM deixa o router cheio de "sujeiras" q nao sao bem vindas e q as vezes impedem o funcionamento a contento.

Após zerar ele, usa a config q te mandei acima.

Abraçao!


Última edição por joester.brondani em Ter Jul 21, 2009 10:15 am, editado 1 vez(es)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Ter Jul 21, 2009 10:06 am

afro
Voltar ao Topo Ir em baixo
Ver perfil do usuário
EMatias



Número de Mensagens : 11
Idade : 41
Localização : São Paulo
Reputação : 0
Pontos : 13
Data de inscrição : 07/07/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Ter Jul 21, 2009 12:41 pm

Joester,

Obrigado pela ajuda, cara a caixa de cerveja ta certo. funcionando ou não so pela sua força.

Vou testar hoje a noite e depois coloco o resultado.

Abs
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Ter Jul 21, 2009 1:50 pm

kkk
eu tava brincando rapa
hueheu
de qqr forma, espero q funcione
a proposito
quando for testar, desliga o modem adsl e o cisco 877, depois torna a ligar. Essas porqueras em bridge as vezes nao se enchergan, principalmente se teu adsl tiveh ligado em outro equipamento...

e vai tentiando q uma hora vai subir

abraços!!!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
EMatias



Número de Mensagens : 11
Idade : 41
Localização : São Paulo
Reputação : 0
Pontos : 13
Data de inscrição : 07/07/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Ter Jul 21, 2009 9:31 pm

Joester,


Infelizmente não rola:
Algumas observações para ver se voce consegue me dar uma Luz.

o Commando pppoe-client dial-pool-number 1 Não é suportado pela VLAN, coloquei então na FastEther 3.

O Led PPP do Router não acende, acho que ele não esta com pppoe habilitado. Apesar da Cisco dizer em todos os manuais que o IOS 12.4(15)7T tem o commando pppoe enable, Não existe este comando no Router 877.

Segue abaixo sh e config.

MatiasRouter#sh interfaces di1
Dialer1 is up, line protocol is up (spoofing)
Hardware is Unknown
Description: Autenticacao
Internet address will be negotiated using IPCP
MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 1 seconds on reset
Last input never, output never, output hang never
Last clearing of "show interface" counters 00:09:29
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/16 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 42 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes
0 packets output, 0 bytes




CONFIG


!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname MatiasRouter
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
dot11 syslog
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool Matias_DHCP
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 208.67.222.222
!
no spanning-tree vlan 1
no spanning-tree vlan 300
username CmkRoot privilege 15
!
!
archive
log config
hidekeys
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
description PORTA EXTERNA
switchport access vlan 300
pppoe-client dial-pool-number 1
!
interface Vlan1
description PORTA INTERNA
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Vlan300
description VLAN EXTERNA
no ip address
!
interface Dialer1
description Autenticacao
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username Matias.projetos@br.inter.net password xxxxxxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit any
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end
Voltar ao Topo Ir em baixo
Ver perfil do usuário
EMatias



Número de Mensagens : 11
Idade : 41
Localização : São Paulo
Reputação : 0
Pontos : 13
Data de inscrição : 07/07/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Ter Jul 21, 2009 9:36 pm

O que me deixa mais puto e frustrado é que o lixo do LinkSys que tenho aqui autentica facil, facil.

Nao tem como te mandar a imagem, mas com p linksys funciona perfeito.

Tem como observar a porta e ver como o LinkSys esta se autenticando??
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Ter Jul 21, 2009 11:03 pm

cara
usei o ios c870-advipservicesk9-mz.124-22.T.bin
tenta ele Smile

e a vlan tem q aceitar o pppoe-client blablablabla

o pppoe enable nao se faz nessessario

mas o pppoe-client xxx tem q ta na vlan

e esquece a vlan 1, cria uma vlan 2 e associa as portas da intranet pra vlan 2 ... e deixa a 300 pra porta f3 como estah.

resumo:

o teu pppoe-client tem q ta na interface vlan 300

se nao aceitar, atualiza o IOS

usa uma vlan 2 3 4 50 100 pras portas 0 1 e 2 menos a 1
(nativa)

desliga o modem adsl, espera ele sincronizar e testa. derruba a dialer e sobe de novo, e aguarda, (ela demora uns 40 segundos as vezes pra autenticar)... verifica os leds de link no cisco pra ver se acendem normalmente, e se quiser debugar a dialer pra ver o erro q dah ....

aki o treco BUFOU heuhue...tem que dar cara!!!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
EMatias



Número de Mensagens : 11
Idade : 41
Localização : São Paulo
Reputação : 0
Pontos : 13
Data de inscrição : 07/07/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Qua Jul 22, 2009 7:45 am

Cara acho que descobri qual o problema.

Voce esta utilizando o Adv. Ip Service, eu estou com o Adv. Security.

Acho que este é o problema, so posso criar 2 VLAN's neste cara, e não é possivel deletar a VLAN1.

Vou ver se consigo atualizar para o ADV. IP SERVICE.

Realmente nesta versão não aceita PPOE dialer-XXXXX na VLAN. Acho que é preciso do ADV. IP Service para isso.


Assim que conseguir, informo. Obrigado.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Joester.Brondani
Specialist


Número de Mensagens : 106
Idade : 33
Localização : Rio Grande do Sul TCHE
Reputação : 6
Pontos : 121
Data de inscrição : 19/06/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Qua Jul 22, 2009 8:37 am

só por curiosidade vou meter um adv security e testar
heuehue
abraço!
ps. se quiser o IOS me add no msn
joesterdj@hotmail.com

ps2. Em nenhum router tu pode deletar a vlan 1 pois é nativa.
'
Basta criar uma 2 e uma 3 por exemplo...


Abraçao!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
EMatias



Número de Mensagens : 11
Idade : 41
Localização : São Paulo
Reputação : 0
Pontos : 13
Data de inscrição : 07/07/2009

MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Qua Jul 22, 2009 9:12 am

O Problema é que com o ADV Security não é possivel criar mais que 2 VLAN's como 1 VLAN ja é a Nativa, sobra somente 1 VL.



Ja Te adicionei no MSN, matias@unimicro.la
valeu.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet   Hoje à(s) 3:30 pm

Voltar ao Topo Ir em baixo
 
Cisco Router 877-K9 - PPPoE atraves de porta FastEthernet
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» LIBERAR PORTA DO GAME RANGER
» Redirecionamento de porta
» burst no pppoe
» Background do porta diferente do background do forum
» passo a passo para liberar porta no modem dsl td8816 para acessar o microtik fora da rede .

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: