Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 cisco 1841+QoS voip

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
Ir à página : 1, 2  Seguinte
AutorMensagem
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: cisco 1841+QoS voip   Sab Ago 02, 2008 11:06 am

Acho eu postei errado na sessão artigo então por favor moderador retira minha dúida de lá.


pegando esse wiki: QoS Cisco - voip-info.org estou tentando adaptar para meu caso e preciso da ajuda de vocês.Vamos lá ao meu cenário:


01-Cisco 1841 IOS 12.4
01-link embratel 1mb
01-Servidor linux(c/ ip válido firewall+proxy da rede interna(gateway da rede interna na segunda placa))
01-Servidor Asterisk voip com ip válido

OBS.: o ip válido dos servidores estão na mesma faixa da LAN do router cisco.


O que preciso: Priorizar a banda na metade para tudo que o Asterisk requisitar(SIP+RTP) então fiz o seguinte:






Prioridade para Sinalização SIP no Asterisk:


access-list 105 remark VOIP (SIP/IAX/IAX2) traffic gets top priority (5)
access-list 105 permit udp any any eq 5060
access-list 105 permit ip host proxy-nyc.broadvoice.com any #outbound_proxy_server
access-list 105 permit ip any host proxy-nyc.broadvoice.com #outbound_proxy_server
access-list 105 permit ip host sip.broadvoice.com any #registro sip broadvoice
access-list 105 permit ip any host sip.broadvoice.com #registro sip broadvoice

class-map match-any SIP
match access-group 105

policy-map QOS1
class SIP
priority 512





Prioridade para Voz no Asterisk:
access-list 118 remark VOIP (RTP) traffic gets top priority (5)
access-list 118 permit udp any any range 10000 20000
access-list 118 permit udp any any range 16384 32767

class-map match-any voice-traffic
match access-group 118
policy-map QOS2
class voice-traffic
priority 512


agora preciso dar prioridade para os dois grupos 105 e 118 para metade do meu link e não sei o que alterar pois se deixar do jeito que está acho que eke vai dar prioridade em todo o link (1mb) pois ele está pegando 512k para o grupo 105 e 512k para o grupo 118.





Outra dúvida, faço isso an serial visto que o asterisk e meu servidor de internet linux tem IP válido do bloco da LAN do roteador??

se sim ficaria mais ou menos assim:

interface Serial0/0/0 -->minha wan que está ativada.
ip address --> não se é preciso visto que minha wan já está ativada e funcionando.
ip load-sharing per-destiny
service-policy output QOS1



se estiver correto faria o mesmo com o QOS2?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: cisco 1841+QoS voip   Dom Ago 03, 2008 6:21 pm

No seu servidor não há possibilidade de mandar os pacotes já marcados? Se conseguir fazer isso fica bem mais fácil a acl da classe:

class-map match-any SIP-voice
match dscp EF

Você não consegue aplicar 2 policys na mesma interface, então devemos fazer uma unica policy e aplica-la na interface.

Como você esta utilizando voz, é recomendado a configuração dentro de um multilink, ou frame-relay, devido a fragmentação e interleave de pacotes, assim como marcar os pacotes como EF para que os demais equipamentos do backbone possam reconhecer estes pacotes como de voz.

Podemos fazer isso de varios modos diferentes, seguem algumas sugestões:

------------------------------------------------------------------------------------------------

1A - Utilizar uma unica classe para ambas ACLs (Atentar ao match-any e não match-all):

class-map match-any SIP-voice
match access-group 105
match access-group 118

policy-map QOS1
class SIP-voice
priority 512
police 512000 conform-action set-dscp-transmit ef exceed-action drop

interface Serial0/0/0
bandwidth 1024
service-policy output QOS1
max-reserved-bandwidth 95 (se você não aplicar este comando, poderá utilizar apenas 75% da banda da interface)

------------------------------------------------------------------------------------------------

1B - Utilizar uma unica classe para ambas ACLs (Atentar ao match-any e não match-all) com multilink:

class-map match-any SIP-voice
match access-group 105
match access-group 118

policy-map QOS1
class SIP-voice
priority 512
police 512000 conform-action set-dscp-transmit ef exceed-action drop

interface Serial0/0/0
bandwidth 1024
no ip address
ppp multilink
ppp multilink group 1

interface Multilink1
bandwidth 1024
ip address X.X.X.X
ppp multilink
ppp multilink fragment delay 10
ppp multilink interleave
ppp multilink group 1
service-policy output QOS1
max-reserved-bandwidth 95 (se você não aplicar este comando, poderá utilizar apenas 75% da banda da interface)

------------------------------------------------------------------------------------------------

2A - Utilizar um cascateamento de classes:

class-map match-any SIP
match access-group 105
class-map match-any voice-traffic
match access-group 118

policy-map QOS2
class voice-traffic
priority 512
police 512000 conform-action set-dscp-transmit ef exceed-action drop

policy-map QOS1
class SIP
priority 512
service-policy output QOS2

interface Serial0/0/0
bandwidth 1024
service-policy output QOS1
max-reserved-bandwidth 95 (se você não aplicar este comando, poderá utilizar apenas 75% da banda da interface)

------------------------------------------------------------------------------------------------

2B - Utilizar um cascateamento de classes com multilink:

class-map match-any SIP
match access-group 105
class-map match-any voice-traffic
match access-group 118

policy-map QOS2
class voice-traffic
priority 512
police 512000 conform-action set-dscp-transmit ef exceed-action drop

policy-map QOS1
class SIP
priority 512
service-policy output QOS2

interface Serial0/0/0
bandwidth 1024
no ip address
ppp multilink
ppp multilink group 1

interface Multilink1
bandwidth 1024
ip address X.X.X.X
ppp multilink
ppp multilink fragment delay 10
ppp multilink interleave
ppp multilink group 1
service-policy output QOS1
max-reserved-bandwidth 95 (se você não aplicar este comando, poderá utilizar apenas 75% da banda da interface)

------------------------------------------------------------------------------------------------

3 - Aplicar uma classe dentro de outra:

class-map match-any voice-traffic
match access-group 118

class-map match-any SIP
match access-group 105
match class-map voice-traffic

policy-map QOS1
class SIP
priority 512
police 512000 conform-action set-dscp-transmit ef exceed-action drop

------------------------------------------------------------------------------------------------

Você pode também fazer a reserva de banda por percentagem, subtituindo o comando priority:
priority percent 50

Seria recomendável criar uma classe default manual, assim você pode configura-la para controlar melhor a banda, aplicando na classe de voz LLQ com CBWFQ, e na classe default WRED:

class-map match-any be
match any

policy-map QOS1
class SIP-voice
priority 512
police 512000 conform-action set-dscp-transmit ef exceed-action drop
class be
bandwidth 460 (este valor não é 512Kbps, pois existe o overhead de pacotes "max-reserved-bandwidth 95", portanto 1024*0.95=972.8 )
random-detect dscp-based
random-detect dscp 0 162 486 1
set ip dscp default

------------------------------------------------------------------------------------------------

obs1. Você tem outro link balanceado com este? Porque esta utilizando um comando de balanceamento:
"ip load-sharing per-destiny"
Se tiver balanceamento, pode acredito que seria melhor faze-lo por pacote
"ip load-sharing per-packet"

obs2. Esta policy é apenas output então o ideal é que a outra ponta também possua uma policy aplicada.

obs3. Aplica o bandwith na interface

Comandos para checagem e ts:
* Monitoração das classes
show policy map interface mul1 (se aplicada no multilink)
show policy-map interface serial 0/0/0 (se aplicada na serial)

* Checagem das marcações do pacotes (este comando pode subir um pouco a CPU da caixa, então confere no show proc cpu hist se ela esta alta antes de habilita-lo) Este comando pega apenas a entrada dos pacotes (input)

conf t
interface mul1 (se aplicada no multilink)
ip route-cache flow (lembrar de desabilitar depois)
end
show ip cache verbose flow (olhar o campo TOS)

conf t
interface serial 0/0/0 (se aplicada na serial)
ip route-cache flow (lembrar de desabilitar depois)
end
show ip cache verbose flow (olhar o campo TOS)

abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Seg Ago 04, 2008 10:48 am

sobre o link só tenho um de 1mb, na interface serial eu já tinha aplicado o bandwith com 1024 e não tenho como mandar do servidor e agradeço muito a ajuda mas vamos lá para ver se eu entendi...então para o que eu preciso ficaria assim:



access-list 105 remark VOIP (SIP/IAX/IAX2) traffic gets top priority (5)
access-list 105 permit udp any any eq 5060
access-list 105 permit ip host proxy-nyc.broadvoice.com any #outbound_proxy_server
access-list 105 permit ip any host proxy-nyc.broadvoice.com #outbound_proxy_server
access-list 105 permit ip host sip.broadvoice.com any #registro sip broadvoice
access-list 105 permit ip any host sip.broadvoice.com #registro sip broadvoice
access-list 118 remark VOIP (RTP) traffic gets top priority (5)
access-list 118 permit udp any any range 10000 20000
access-list 118 permit udp any any range 16384 32767



class-map match-any SIP-voice
match access-group 105
match access-group 118

policy-map QOS1
class SIP-voice
priority 512
police 512000 conform-action set-dscp-transmit ef exceed-action drop

interface Serial0/0/0
bandwidth 1024
service-policy output QOS1
max-reserved-bandwidth 95 (se você não aplicar este comando, poderá utilizar apenas 75% da banda da interface)

agora vamos as minhas dúvidas:

1)Então o QoS1 pega nos dois grupos priorizando 512k do link para todas as portas e ips passados? e se eu quiser posso deixar um grupo só reunindo todas as linhas:


access-list 105 remark VOIP (SIP/RTP) traffic gets top priority (5)
access-list 105 permit udp any any eq 5060
access-list 105 permit udp any any range 10000 20000
access-list 105 permit udp any any range 16384 32767
access-list 105 permit ip host 147.135.12.128 any #outbound_proxy_server
access-list 105 permit ip any host 147.135.12.128 #outbound_proxy_server
access-list 105 permit ip host 147.135.32.221 any #registro sip broadvoice
access-list 105 permit ip any host 147.135.32.221 #registro sip broadvoice



class-map match-any SIP-voice
match access-group 105


policy-map QOS1
class SIP-voice
priority 512
police 512000 conform-action set-dscp-transmit ef exceed-action drop

interface Serial0/0/0
bandwidth 1024
service-policy output QOS1
max-reserved-bandwidth 95




??



2)desculpe a ignorância mas não entendo muito do cisco mas essa linha quer dizer o q: (police 512000 conform-action set-dscp-transmit ef exceed-action drop)
3)max-reserved-bandwidth 95 (se você não aplicar este comando, poderá utilizar apenas 75% da banda da interface), os 25% ficam onde então?
4)A opção de PPP multilink só funciona quando temos 2 ou mais de 2mb de link correto para fazer o balanceamento?
5)COm esse procedimento vou ter na hora de um gargalo 512k para a voz e oq ue sobrar para dados correto?porque vou fazer um QoS interno

se não estiver certo o que pode ser alterado para ficar ok se puder me ajudar pois vou ligar minha rede voip hoje.


OBs.:os modos diferentes só mudam os modos mesmo ou de um para o outro tem diferença na qualidade do serviço?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: cisco 1841+QoS voip   Seg Ago 04, 2008 6:28 pm

1)Então o QoS1 pega nos dois grupos priorizando 512k do link para todas as portas e ips passados? e se eu quiser posso deixar um grupo só reunindo todas as linhas:

Exato, você pode associar quantas acls quiser numa unica classe, apenas fique atento para não configurar como match-all

2)desculpe a ignorância mas não entendo muito do cisco mas essa linha quer dizer o q: (police 512000 conform-action set-dscp-transmit ef exceed-action drop)

Enquanto seu tráfego estiver abaixo de 512Kbps o pacote será setado com o valor DSCP EF e transmitido, se o tráfego ultrapassar a reserva de 512 Kbps ele será dropado.
Gosto da analogia da Cisco de um balde, se você tem um balde que cabe um litro, quando você ultrapassa ele transborda.

3)max-reserved-bandwidth 95 (se você não aplicar este comando, poderá utilizar apenas 75% da banda da interface), os 25% ficam onde então?

Ela fica reservada para o overhead de pacotes e roteamento, cada tipo de pacote diferente possui um cabeçalho (header), ex:
* Cada pacote UDP (incluindo RTP e voice payload) é encapsulado em um pacote IP, com 20 bytes de header.
* Cada pacote RTP (mais voice payload) é encapsulado em um pacote de transporte UDP, cujo header tem 12 bytes de tamanho.
* Se o link utilizar cRTP, o overhead dos protocolos RTP, UDP e IP fica reduzido a 4 bytes, por causa da compressão.
* Se o link utilizar MPLS, o overhead dos protocolos RTP, UDP e IP (considerando o efeito do cRTP, se for o caso) aumenta em 4 bytes.
* Links Ethernet (IEEE 802.3) - 14 bytes.
* Links seriais com encapsulamento PPP - 6 bytes.
* Links seriais com encapsulamento frame-relay - 4 bytes.
Portanto o overhead é considerado o cabeçalho de cada pacote, que pode variar dependendo desde o tipo de tecnologia utilizado (frame-relay, atm, mpls, ...) ou do tipo de pacote (UDP, TCP, IP, RTP).

Segue link de referencia:
http://www.cisco.com/en/US/docs/ios/12_3/qos/command/reference/qos_m1g.html#wp1113113


4)A opção de PPP multilink só funciona quando temos 2 ou mais de 2mb de link correto para fazer o balanceamento?

Uma das funções do multilink é balancear interfaces, mas em muitos casos podemos ter o multilink de um link só.
Isso ocorre devido a fragmentação e interleave de pacotes.
Imagine um pacote de dados com 1500 bytes (----) e um de voz de 80 bytes (-) quando eles são colocados na fila do roteador eles são transmitidos aleatoriamente:

(----) (----) (-) (----) (-) (----) (----) (----) (-)
| 80 ms |20ms| 40ms |20ms| 160ms | 20ms

Percebe que isso pode gerar jitter (jitter = diferença do tempo entre cada pacote), os pacotes de voz são extremamente sensiveis a jitter, então existem 2 mecanismos que podemos utilizar para evita-los.

1 - Frame-relay
2 - PPP Multilink

Isto é chamado de LFI (Link Fragmentation and Interleaving)

Segue link de referencia do multilink para voip:
http://www.cisco.com/en/US/tech/tk652/tk698/technologies_tech_note09186a0080094660.shtml

Como seu link é de 1M, pode ser que não sinta muita diferença sem o LFI, mas quanto menor o link, maior a necessidade desta implementação.

5)COm esse procedimento vou ter na hora de um gargalo 512k para a voz e o que sobrar para dados correto? porque vou fazer um QoS interno

Exato, esta sua configuração prioriza 512 Kbps de sua banda para voz, e 512 Kbps para dados. Caso voz não esteja utilizando sua banda, dados irá conseguir utilizar, no entanto voz jamais irá ultrapassar a reserva de 512Kbps.
Se você quiser que dados jamais ultrapasse a reserva, podemos criar uma classes para o tráfego default de dados. Apesar que esta classe default de dados é legal criarmos mesmo se você não quiser limita-lo em 512 Kbps, pois podemos aplicar um WRED para controlar o tráfego com mais precisão (evitando que a alta utilização atrapalhe voz).
Segue sua conf, sem limitar a classe de dados a metade, mas utilizando WRED para auxilio no controle de congestionamento:

access-list 105 remark VOIP (SIP/RTP) traffic gets top priority (5)
access-list 105 permit udp any any eq 5060
access-list 105 permit udp any any range 10000 20000
access-list 105 permit udp any any range 16384 32767
access-list 105 permit ip host 147.135.12.128 any #outbound_proxy_server
access-list 105 permit ip any host 147.135.12.128 #outbound_proxy_server
access-list 105 permit ip host 147.135.32.221 any #registro sip broadvoice
access-list 105 permit ip any host 147.135.32.221 #registro sip broadvoice

class-map match-any SIP-voice
match access-group 105
class-map match-any BE
match any

policy-map QOS1
class SIP-voice
priority 512
police 512000 conform-action set-dscp-transmit ef exceed-action drop
class BE
bandwidth 460
random-detect dscp-based
random-detect dscp 0 162 486 1
set ip dscp default

interface Serial0/0/0
bandwidth 1024
service-policy output QOS1
max-reserved-bandwidth 95

Os modos diferentes só mudam os modos mesmo ou de um para o outro tem diferença na qualidade do serviço
Existem algumas diferenças entre as configurações, mas se não tiver a real necessidade de diferenciar o tráfego de ambas ACLs, acredito que a melhor seria esta q vc escolheu.

abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Seg Ago 04, 2008 8:56 pm

poxa cara que aula muito obrigado mesmo...então tem só mais algumas dúvidas...vc colcou algumas coisas diferentes na resposta do que fiz:

access-list 105 remark VOIP (SIP/RTP) traffic gets top priority (5)
access-list 105 permit udp any any eq 5060
access-list 105 permit udp any any range 10000 20000
access-list 105 permit udp any any range 16384 32767
access-list 105 permit ip host 147.135.12.128 any #outbound_proxy_server
access-list 105 permit ip any host 147.135.12.128 #outbound_proxy_server
access-list 105 permit ip host 147.135.32.221 any #registro sip broadvoice
access-list 105 permit ip any host 147.135.32.221 #registro sip broadvoice

class-map match-any SIP-voice
match access-group 105
class-map match-any BE
match any

policy-map QOS1
class SIP-voice
priority 512
police 512000 conform-action set-dscp-transmit ef exceed-action drop
class BE
bandwidth 460
random-detect dscp-based
random-detect dscp 0 162 486 1
set ip dscp default

interface Serial0/0/0
bandwidth 1024
service-policy output QOS1
max-reserved-bandwidth 95



1) vc deixou um grupo só, tb não tem problema não é?
2)na conf que vc passou não tem a default que vc aconselha, se for preciso mesmo como devo proceder? faço primeiro essa acima depois a default? como ficaria a default?

2)pela sua experiência, é preciso limitar uma reserva e deixa 512k para voz e 512k para dados sem que um use o link do outro quando não utilizado ou eu deixo dessa forma que quando a voz por exemplo esteja consumindo 250k os 750k restante fique para dados? é dessa forma que está acima correto?

3)Essas regras que postou acima está numa resposta anterior sua dizendo que é uma classe default para melhor gerenciar...aplicando essas conf acima que vc passou preciso aplicar a que fiz anteriormente tb:

access-list 105 remark VOIP (SIP/IAX/IAX2) traffic gets top priority (5)
access-list 105 permit udp any any eq 5060
access-list 105 permit ip host proxy-nyc.broadvoice.com any #outbound_proxy_server
access-list 105 permit ip any host proxy-nyc.broadvoice.com #outbound_proxy_server
access-list 105 permit ip host sip.broadvoice.com any #registro sip broadvoice
access-list 105 permit ip any host sip.broadvoice.com #registro sip broadvoice
access-list 118 remark VOIP (RTP) traffic gets top priority (5)
access-list 118 permit udp any any range 10000 20000
access-list 118 permit udp any any range 16384 32767



class-map match-any SIP-voice
match access-group 105
match access-group 118

policy-map QOS1
class SIP-voice
priority 512
police 512000 conform-action set-dscp-transmit ef exceed-action drop

interface Serial0/0/0
bandwidth 1024
service-policy output QOS1
max-reserved-bandwidth 95

ou só a sua resolve meu problema? vc disse que a minha está exata então vc só adiciou nas minhas conf e adaptou melhor algumas coisas como evitar congestionamento exemplos de linhas adicionadas:(class BE
bandwidth 460
random-detect dscp-based
random-detect dscp 0 162 486 1
set ip dscp default
)?


depois de aplicar a conf que vc postou no tópico anterior usando o wired sem ou com limite de banda(aguardo sugestão se devo reservar/limitar os outros 512k para dados já que minha inteção é deixar 512lk voz e 512k dados mesmo) existe algum utilitário cisco ou não para eu testar o uso do link e o tráfego para saber se a voz está com priooridade mesmo?

4)Nas regaras que te passei para saber se estavam corretas:

...
class-map match-any SIP-voice
match access-group 105
match access-group 118

policy-map QOS1
class SIP-voice
priority 512
police 512000 conform-action set-dscp-transmit ef exceed-action drop

interface Serial0/0/0
bandwidth 1024
service-policy output QOS1
max-reserved-bandwidth 95

ei apliquei-as hoje mas sem salvar mas ao tentar ligar para a empresa de um celular para teste a voz picotou no começo, será que é porque faltava as configurações alteradas que vc passou na resposta anterior com wired?


cara desde já agradeço a ajuda pois preciso muito dela para aplicar na empresa.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: cisco 1841+QoS voip   Seg Ago 04, 2008 10:32 pm

1) vc deixou um grupo só, tb não tem problema não é?
Não, a menos que você pretenda futuramente colocar elas em classes diferentes não tem problema.

2)na conf que vc passou não tem a default que vc aconselha, se for preciso mesmo como devo proceder? faço primeiro essa acima depois a default? como ficaria a default?
A classe default esta representada pela classe BE. (best effort)

2)pela sua experiência, é preciso limitar uma reserva e deixa 512k para voz e 512k para dados sem que um use o link do outro quando não utilizado ou eu deixo dessa forma que quando a voz por exemplo esteja consumindo 250k os 750k restante fique para dados? é dessa forma que está acima correto?
A principio não precisa limitar a classe, podemos apenas fazer o controle.

3)Essas regras que postou acima está numa resposta anterior sua dizendo que é uma classe default para melhor gerenciar...aplicando essas conf acima que vc passou preciso aplicar a que fiz anteriormente tb:
Te passei a conf completa.

4)Nas regaras que te passei para saber se estavam corretas:
Esta conf q vc passou esta correta, se não quiser utilizar a mesma ACL, pode deixar elas separadas, mas mesmo assim é recomendável que crie a classe be (ou default) para que possa controlar o tráfego dela também
Lembrei de outro ponto, sempre cuidado com o nome das classes pois elas são sensitive case (diferenciam maiusculo e minusculo)

Quanto aos picotes, eles realmente não devem ocorrer em hipotese nenhuma. Quando se trabalha com a parte de qualidade de VoIP, podem ocorrer falhas no começo, principalmente se nunca fez estes tipos de configuração, pois as configurações tem que ser bem adequadas.

Nos equipamentos que você aplicou QoS você pode monitorar como ele esta se comportando através do comando:

show policy-map interface serialX

Se quiser postar o output dele te explico os parametros.
Este seria o primeiro passo.

Outro detalhe é garantir que TODOS os seus equipamentos estejam com QoS aplicado, existe uma frase que representa bem isso:
"A força de uma corrente é a força do elo mais fraco"

A garantia de ter aplicado o QoS em todos os pontos, e a monitoração destes pontos pode resolver a maior parte dos problemas.

Se explicar um pouco da topologia fica mais facil de entender o que pode estar acontecendo.

Se esta ligando através de um celular, deve ter alguma interface E1 conectada a PSTN, correto?

Seu escritorio fica no mesmo roteador desta interface E1?

Ou possui um link entre este CPE e o escritorio para aonde ligou?

Se possuir um link, ele é deterministico? MPLS?

Se possuir um link, já efetuou algum teste para garantir a integridade dele? Voz é bem mais sensivel que dados, as vezes pode haver alguma perda de pacote ou taxa de erro que não tenha percebido.

Outro ponto a ser analisado é se todos os pacotes estão classificados corretamente, e se a classe de voz não esta ultrapassando a reserva (ja peguei casos de aplicações que usam o range de portas udp padrões de voip por exemplo).

Para saber se a banda não esta ultrapassando pode usar o comando q citei acima.

Para saber se os pacotes estao sendo marcados corretamente, faz uma ligação e habilita um cache-flow.

se quiser me add no msn (costumo ficar on mais a noite)
mauriguinakano@hotmail.com

abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Ter Ago 05, 2008 8:24 am

te adicionei no msn para explicar como está minha rede.


então com a classe default be posso controlar os dados tb correto mas preciso criar outra regra para isso certo? como que faço?



fiz assim hoje reiniciei o router para apagar as conf que tinha feito anteriormente e apliquei essas:

access-list 105 remark VOIP (SIP/RTP) traffic gets top priority (5)
access-list 105 permit udp any any eq 5060
access-list 105 permit udp any any range 10000 20000
access-list 105 permit udp any any range 16384 32767
access-list 105 permit ip host 147.135.12.128 any #outbound_proxy_server
access-list 105 permit ip any host 147.135.12.128 #outbound_proxy_server
access-list 105 permit ip host 147.135.32.221 any #registro sip broadvoice
access-list 105 permit ip any host 147.135.32.221 #registro sip broadvoice

class-map match-any SIP-voice
match access-group 105
class-map match-any BE
match any

policy-map QOS1
class SIP-voice
priority 512
police 512000 conform-action set-dscp-transmit ef exceed-action drop
class BE
bandwidth 460
random-detect dscp-based
random-detect dscp 0 162 486 1
set ip dscp default

interface Serial0/0/0
bandwidth 1024
service-policy output QOS1
max-reserved-bandwidth 95

1)Então com essa regra já vou ter prioridade de 512k com qualidade correto? se sim, vamos se assim não vai picotar.

2)Depois de aplicada essas regras como faço para controle a parte de dados já fizemos uma classe default?

A noite estou no msn e passo os equipamentos que estou usando na rede wireless, voip e cabeada e servidor.


depois dei o comando: show policy-map interface serial0/0/0 mas não retornou nada só me retornou o comando sem a interface: show policy-map interface

que te mostro a noite no msn os resultados. Me parece que os dados já ficam reservados com 460k ou estou enganado?


meu msn: lfernandosg@hotmail.com

Fernando Galvão
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: cisco 1841+QoS voip   Ter Ago 05, 2008 1:10 pm

1)Então com essa regra já vou ter prioridade de 512k com qualidade correto? se sim, vamos se assim não vai picotar.
Com esta configuração, você terá um controle melhor sobre sua classe default.

2)Depois de aplicada essas regras como faço para controle a parte de dados já fizemos uma classe default?
Quando você aplicou esta config:
bandwidth 460
random-detect dscp-based
random-detect dscp 0 162 486 1
set ip dscp default
Já esta fazendo de certo modo um controle para dados, caso constatemos que a classe de dados esta atrapalhando voz, podemos alterar a configuração para que seja mais "rígida"


depois dei o comando: show policy-map interface serial0/0/0 mas não retornou nada só me retornou o comando sem a interface: show policy-map interface
tem algo de errado então, a politica não esta rodando no seu equipamento, deveria ter vindo algo parecido:

ROUTER# sh policy-map interface serial 0/0
Serial0/0

Service-policy output: QoS1

Class-map: SIP-voice (match-any)
0 packets, 0 bytes
30 second offered rate 0 bps, drop rate 0 bps
Match: access-group 105
Queueing
Strict Priority
Output Queue: Conversation 520
Bandwidth 460 (kbps) Burst 57500 (Bytes)
(pkts matched/bytes matched) 0/0
(total drops/bytes drops) 0/0

Class-map: BE (match-any)
973 packets, 119822 bytes
30 second offered rate 2000 bps, drop rate 0 bps
Queueing
Output Queue: Conversation 521
Bandwidth 5 (%)
Bandwidth 51 (kbps)
(pkts matched/bytes matched) 419/61810
(depth/total drops/no-buffer drops) 0/0/0
exponential weight: 9
mean queue depth: 0

dscp Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
af11 0/0 0/0 0/0 32 40 1/10
af12 0/0 0/0 0/0 28 40 1/10
af13 0/0 0/0 0/0 24 40 1/10
af21 0/0 0/0 0/0 32 40 1/10
af22 0/0 0/0 0/0 28 40 1/10
af23 0/0 0/0 0/0 24 40 1/10
af31 0/0 0/0 0/0 32 60 1/12
af32 0/0 0/0 0/0 28 40 1/10
af33 0/0 0/0 0/0 24 40 1/10
af41 0/0 0/0 0/0 32 40 1/10
af42 0/0 0/0 0/0 28 40 1/10
af43 0/0 0/0 0/0 24 40 1/10
cs1 0/0 0/0 0/0 22 40 1/10
cs2 0/0 0/0 0/0 24 40 1/10
cs3 0/0 0/0 0/0 26 40 1/10
cs4 0/0 0/0 0/0 28 40 1/10
cs5 0/0 0/0 0/0 30 40 1/10
cs6 0/0 0/0 0/0 32 40 1/10
cs7 0/0 0/0 0/0 34 40 1/10
ef 0/0 0/0 0/0 36 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
default 0/0 0/0 0/0 15 50 1/5

1 - confirma que o ip cef esta habilitado
2 - Dá um show run na interface e vê se a policy esta realmente habilitada.
3 - Se estiver retira ela e faz este procedimento, se não estiver faz só ele
terminal monitor
conf t
int s0/0/0
service-policy output QOS1

vem algum erro?

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Ter Ago 05, 2008 4:41 pm

como faço para habilitar o ip cef(ele não é para balanceamento)? aparece uma tela semelhante a essa de cima mas sem colocar a interface só digitando:

router# sh policy-map.


como faço para pegar os resultador e colar na minha área de trabalho para te mostrar? estou acessando via telnet


acho a política está ativada mas não está funiconando na interface serial 0/0/0


se eu quiser remover tudo que fiz para fazer de novo tem algum comando para reiniciar o router pois estou muito distante dele.


Outra coisa só para confirmar ,quando termino de aplicar as regras tenho que dar o comando end correto? e outra quando eu estava aplicando as regras e estava em tipo:
router# conf t
router(conf t)xxxxxxxx
ele entrava na conf da linha por exemplo:
router(xxx)entao eu continuei dando o comando e nao volteo com o Crtl+Z para voltar para tela router(conf f) correto? ate porque para entrar nas conf da interface tive que digitar: interface serial0/0/0
Voltar ao Topo Ir em baixo
Ver perfil do usuário
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Ter Ago 05, 2008 7:53 pm

vamos lá vou mostrar o passo a passo que fiz dentro do roteador e vou te passar a respostas dos comandos aqui:

primeiro a configuração:

ibacem(config)#access-list 105 remark VOIP (SIP/RTP) traffic gets top priority (5)
ibacem(config)#access-list 105 permit udp any any range 5060 5061
ibacem(config)#access-list 105 permit udp any any range 10000 20000
ibacem(config)#access-list 105 permit udp any any range 16384 32767
ibacem(config)#access-list 105 permit ip host 147.135.12.128 any
ibacem(config)#access-list 105 permit ip any host 147.135.12.128
ibacem(config)#access-list 105 permit ip host 147.135.32.221 any
ibacem(config)#access-list 105 permit ip any host 147.135.32.221
ibacem(config)#class-map match-any SIP-voice
ibacem(config-cmap)#match access-group 105
ibacem(config-cmap)#class-map match-any BE
ibacem(config-cmap)#match any
ibacem(config-cmap)#policy-map QOS1
ibacem(config-pmap)#class SIP-voice
ibacem(config-pmap-c)#priority 512
ibacem(config-pmap-c)#police 512000 conform-action set-dscp-transmit ef exceed-action drop
ibacem(config-pmap-c-police)#class BE
ibacem(config-pmap-c)#bandwidth 460
ibacem(config-pmap-c)#random-detect dscp-based
ibacem(config-pmap-c)#random-detect dscp 0 162 486 1
ibacem(config-pmap-c)#set ip dscp default
ibacem(config-pmap-c)#interface Serial0/0/0
ibacem(config-if)#bandwidth 1024
ibacem(config-if)#service-policy output QOS1
I/f Serial0/0/0 class BE requested bandwidth 460 (kbps), available only 256 (kbps)
ibacem(config-if)#max-reserved-bandwidth 95
ibacem(config-if)#end

agora respostas aos comandos:

ibacem#sh policy-map interface serial0/0/0
ibacem#
não tenho resposta mas se eu der:

ibacem#sh policy-map
Policy Map QOS1
Class SIP-voice
Strict Priority
Bandwidth 512 (kbps) Burst 12800 (Bytes)
police cir 512000 bc 16000
conform-action set-dscp-transmit ef
exceed-action drop
Class BE
Bandwidth 460 (kbps)
exponential weight 9
dscp min-threshold max-threshold mark-probablity
----------------------------------------------------------

af11 - - 1/10
af12 - - 1/10
af13 - - 1/10
af21 - - 1/10
af22 - - 1/10
af23 - - 1/10
af31 - - 1/10
af32 - - 1/10
af33 - - 1/10
af41 - - 1/10
af42 - - 1/10
af43 - - 1/10
cs1 - - 1/10
cs2 - - 1/10
cs3 - - 1/10
cs4 - - 1/10
cs5 - - 1/10
cs6 - - 1/10
cs7 - - 1/10
ef - - 1/10
rsvp - - 1/10
default 162 486 1/1

set ip dscp default
ibacem#

porque não aceita com a serial??

show run da interface:

ibacem#show run interface serial0/0/0
Building configuration...

Current configuration : 134 bytes
!
interface Serial0/0/0
bandwidth 1024
ip address 200.x.x.x.x 255.255.255.252
encapsulation ppp
max-reserved-bandwidth 95
end

está tudo ok?todos comandos aqui peguei direto do roteador..reiniciei ele com reload e fiz tudo novamente mas não sai nada quando coloco a interface mas pode ser algo nessa IOS 12.4 que dê resposta diferente...mas aguardo um feedbak seu.


se estiver ok preciso algo a mais a não ser salvas as configurações? com essas regras acima vou estar priorizando 512k do meu link para voz e evitando picotamento e também com a classe default(BE)estou reservando 460k para dados certo?se estiver tudo correto vou salvar e volto aqui só para entender algumas linhas novas.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: cisco 1841+QoS voip   Qua Ago 06, 2008 9:33 am

Então aplica o comando service-policy output qos1 de novo.

O problema é a ordem que vc configurou.

Lembra que comentei que se não colocasse o max-reserved-bandwidth 95 teria disponivel apenas 75%?

Aplica nesta ordem:

ibacem(config-pmap-c)#interface Serial0/0/0
ibacem(config-if)#bandwidth 1024
ibacem(config-if)#max-reserved-bandwidth 95
ibacem(config-if)#service-policy output QOS1
ibacem(config-if)#end

Depois disso pode repetir o comando que você vai ver que o output aparece

abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Qua Ago 06, 2008 10:08 am

certo antes de fazer isso queria tirar uma dúvida contigo...no caso da forma que vamos deixar na hora de um gargalo teremos 512k para voz correto?

mas se não tiver no gargalo e o servidor asrterisk precisar de mais de 512k na hora de um pico ele usa a parte do link dados ou não? se não tem como fazer dessa forma?


Obs.: falei isso pois estou achando que tem horas que os 512k ficam estourados as vezes....


pronto fiz a conf com a sequência que vc passou e agora apareceu:




Serial0/0/0

Service-policy output: QOS1

Class-map: SIP-voice (match-any)
5 packets, 3600 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 105
5 packets, 3600 bytes
5 minute rate 0 bps
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 512 (kbps) Burst 12800 (Bytes)
(pkts matched/bytes matched) 3/2160
(total drops/bytes drops) 0/0
police:
cir 512000 bps, bc 16000 bytes
conformed 5 packets, 3600 bytes; actions:
set-dscp-transmit ef
exceeded 0 packets, 0 bytes; actions:
drop
conformed 0 bps, exceed 0 bps

Class-map: BE (match-any)
75 packets, 15069 bytes
5 minute offered rate 4000 bps, drop rate 0 bps
Match: any
Queueing
Output Queue: Conversation 265
Bandwidth 460 (kbps)
(pkts matched/bytes matched) 2/3008
(depth/total drops/no-buffer drops) 0/0/0
exponential weight: 9
mean queue depth: 0

dscp Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
af11 0/0 0/0 0/0 32 40 1/10
af12 0/0 0/0 0/0 28 40 1/10
af13 0/0 0/0 0/0 24 40 1/10
af21 0/0 0/0 0/0 32 40 1/10
af22 0/0 0/0 0/0 28 40 1/10
af23 0/0 0/0 0/0 24 40 1/10
af31 0/0 0/0 0/0 32 40 1/10
af32 0/0 0/0 0/0 28 40 1/10
af33 0/0 0/0 0/0 24 40 1/10
af41 0/0 0/0 0/0 32 40 1/10
af42 0/0 0/0 0/0 28 40 1/10
af43 0/0 0/0 0/0 24 40 1/10
cs1 0/0 0/0 0/0 22 40 1/10
cs2 0/0 0/0 0/0 24 40 1/10
cs3 0/0 0/0 0/0 26 40 1/10
cs4 0/0 0/0 0/0 28 40 1/10
cs5 0/0 0/0 0/0 30 40 1/10
cs6 0/0 0/0 0/0 32 40 1/10
cs7 0/0 0/0 0/0 34 40 1/10
ef 0/0 0/0 0/0 36 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
default 221/27403 0/0 0/0 162 486 1/1

QoS Set
dscp default
Packets marked 215

Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: cisco 1841+QoS voip   Qua Ago 06, 2008 12:24 pm

Neste caso voz fica restrito a 512 Kbps, você pode monitorar se é necessário alterar algum parametro de banda.

Faz o seguinte, coleta depois de algum tempo o mesmo comando,

Class-map: SIP-voice (match-any)
5 packets, 3600 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group 105
5 packets, 3600 bytes
5 minute rate 0 bps
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 512 (kbps) Burst 12800 (Bytes)
(pkts matched/bytes matched) 3/2160
(total drops/bytes drops) 0/0 <--------- se ocorrer incremento de algum pacote exceeded quer dizer que o trafego de voz ultrapassou a reserva
police:
cir 512000 bps, bc 16000 bytes
conformed 5 packets, 3600 bytes; actions:
set-dscp-transmit ef
exceeded 0 packets, 0 bytes; actions: <--------- se ocorrer incremento de algum pacote exceeded quer dizer que o trafego de voz ultrapassou a reserva
drop
conformed 0 bps, exceed 0 bps

Class-map: BE (match-any)
75 packets, 15069 bytes
5 minute offered rate 4000 bps, drop rate 0 bps
Match: any
Queueing
Output Queue: Conversation 265
Bandwidth 460 (kbps)
(pkts matched/bytes matched) 2/3008
(depth/total drops/no-buffer drops) 0/0/0 <--------- o segundo e o terceiro zero indicam drops na classe de dados
exponential weight: 9
mean queue depth: 0


Ao configurarmos o LLQ para voz, ao mesmo tempo que priorizamos os pacotes de voz, também restringimos a classe.

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Qui Ago 14, 2008 7:08 pm

olha estou com as regras ativas...estou testanto e já salvei com wr...mas se um dia eu quiser remover as regras como faço?quais comandos usar?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: cisco 1841+QoS voip   Sex Ago 15, 2008 8:11 am

conf t

interface Serial0/0/0
no service-policy output QOS1
no max-reserved-bandwidth 95
end

wr


Com isso a policy vai continuar configurada no modo global, mas não vai estar mais aplicada na interface.
Se quiser desconfigura-la:

conf t

no policy-map QOS1
no class-map match-any BE
no class-map match-any SIP-voice
no access-list 105
end

wr

abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Qui Ago 21, 2008 11:32 am

outra coisa...estou testando o QoS mas usando o voip + download o download está usando toda a banda...está baixando arquivo a 115KB/s, oque pode ser pois acho que o router não está limitando.


Editado:

o servidor voip está com um ip valido e o servidor linux da rede interna com outro...para testes agora, tentei limitar a banda do linux a 512k com o htb+tc dando prioridade ao temrinal service 3389 fiz um download e parece que funcionou: 36KB/s. mas acho que continua afetando os outros 512 pois o voip praticamente não faz ligações ou fica picotando.

dei os comandos para analisar e está em 0/0 então o voip não está passando dos 512 mas o cisco não está limitando para o voip pois ao fazer um download ele usa todo o link:


portas voip:

5060-5061
10000-20000

e os ips que te passei do provedor voip.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Qui Ago 13, 2009 11:46 am

assim esqueci de dizer um cara tentou configurar o QoS pra mim e as regras estão diferentes mas não se se estão funcionando olha:

IBACEM-># show policy-map interface serial0/0/0
Serial0/0/0

Service-policy output: qos_policy_1

Class-map: voip_traffic (match-any)
388130 packets, 32680310 bytes
5 minute offered rate 26000 bps, drop rate 0 bps
Match: access-group name voip_traffic
388130 packets, 32680310 bytes
5 minute rate 26000 bps
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 50 (%)
Bandwidth 500 (kbps) Burst 12500 (Bytes)
(pkts matched/bytes matched) 10716/953863
(total drops/bytes drops) 0/0
QoS Set
dscp ef
Packets marked 388130

Class-map: class-default (match-any)
1015871 packets, 194279872 bytes
5 minute offered rate 57000 bps, drop rate 0 bps
Match: any
Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 256
(total queued/total drops/no-buffer drops) 0/0/0


como falei preciso QoS para priorizar 512k do link para voz portas e Ips passados anteriormente.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: cisco 1841+QoS voip   Qui Ago 13, 2009 1:17 pm

Ola, Boa tarde,

Esta serial 0/0/0 é seu link com a internet? Se for a policy esta aplicada de output e o tráfego de download costuma ser pesado no sentido input, com isso a policy não tem nenhum efeito sobre seu link.
Neste caso poderia tentar duas coisas, a primeira é aplicar a mesma policy no outro CPE, mas como eu imagino que não tem acesso, pois deve ser do provedor, esta solução fica inviavel (Se possuir pode aplicar a mesma policy no outro roteador, mas não estou vendo nenhuma limitação para a classe default é interessante configurar uma limitação de banda dentro dela).

Considerando que não tenha acesso ao roteador da outra ponta, eu sugiro que limite o tráfego de dados, deixando sempre uma banda específica reservada para voz, nem que seja menos que estes 512 (pelo menos uns 256kbps), pois estamos falando de tráfego de internet e download de arquivos.

abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Qui Ago 13, 2009 2:02 pm

cara obg por responder...então vamos lá...essa interface é que entra o link da operadora embratel sim de internet.

então vamos fazer o serguinte...vamos começar o zero e voltar as configurações que eu tinha feito contigo...como faço para remover essas regras que meu amigo colocou?

vou postar aqui as regras antigas que você me passou e que vou colocar novamente no roteador:


ibacem(config)#access-list 105 remark VOIP (SIP/RTP) traffic gets top priority (5)
ibacem(config)#access-list 105 permit udp any any range 5060 5061
ibacem(config)#access-list 105 permit udp any any range 10000 20000
ibacem(config)#access-list 105 permit udp any any range 16384 32767
ibacem(config)#access-list 105 permit ip host 147.135.12.128 any
ibacem(config)#access-list 105 permit ip any host 147.135.12.128
ibacem(config)#access-list 105 permit ip host 147.135.32.221 any
ibacem(config)#access-list 105 permit ip any host 147.135.32.221
ibacem(config)#class-map match-any SIP-voice
ibacem(config-cmap)#match access-group 105
ibacem(config-cmap)#class-map match-any BE
ibacem(config-cmap)#match any
ibacem(config-cmap)#policy-map QOS1
ibacem(config-pmap)#class SIP-voice
ibacem(config-pmap-c)#priority 512
ibacem(config-pmap-c)#police 512000 conform-action set-dscp-transmit ef exceed-action drop
ibacem(config-pmap-c-police)#class BE
ibacem(config-pmap-c)#bandwidth 460
ibacem(config-pmap-c)#random-detect dscp-based
ibacem(config-pmap-c)#random-detect dscp 0 162 486 1
ibacem(config-pmap-c)#set ip dscp default
bacem(config-pmap-c)#interface Serial0/0/0
ibacem(config-if)#bandwidth 1024
ibacem(config-if)#max-reserved-bandwidth 95
ibacem(config-if)#service-policy output QOS1
ibacem(config-if)#end

depois disso como faço para saber se realmente está limitando pois antes não estava...eu fazia um download e ele usava todo o link de 1mb.Aguardo como apagar as regras atuais para poder colocar essas acima regras no ar que já limita 512 como quero para voz.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: cisco 1841+QoS voip   Qui Ago 13, 2009 2:46 pm

Acho que não me expressei bem, este tipo de policy só vai funcionar se for aplicada nos dois roteadores, podeobservar que ela esta ecrita na interface como output.

Bom tenta fazer o seguinte, aplica isso no seu router e testa, deve funcionar.

access-list 105 remark VOIP (SIP/RTP) traffic gets top priority (5)
access-list 105 permit udp any any range 5060 5061
access-list 105 permit udp any any range 10000 20000
access-list 105 permit udp any any range 16384 32767
access-list 105 permit ip host 147.135.12.128 any
access-list 105 permit ip any host 147.135.12.128
access-list 105 permit ip host 147.135.32.221 any
access-list 105 permit ip any host 147.135.32.221
access-list 106 deny udp any any range 5060 5061
access-list 106 deny udp any any range 10000 20000
access-list 106 deny udp any any range 16384 32767
access-list 106 deny ip host 147.135.12.128 any
access-list 106 deny ip any host 147.135.12.128
access-list 106 deny ip host 147.135.32.221 any
access-list 106 deny ip any host 147.135.32.221
access-list 106 permit ip any any

Interface serial 0/0/0
no service-policy output qos_policy_1
rate-limit input access-group 105 512000 512000 512000 conform-action transmit exceed-action transmit
rate-limit input access-group 106 768000 768000 768000 conform-action transmit exceed-action drop
rate-limit output access-group 105 512000 512000 512000 conform-action transmit exceed-action transmit
rate-limit output access-group 106 768000 768000 768000 conform-action transmit exceed-action drop

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Qui Ago 13, 2009 6:15 pm

certo..só me explica como remover todas as regras de QoS...e se não me engano depois de aplicar essas suas regras tem um comando para salvar no final correto?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Qui Ago 13, 2009 6:27 pm

ah quando passar como remover as regras antigas...me passa como posso testar essas regras novas para saber se estão funcionando e limitando a banda para o voip.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Qui Ago 13, 2009 6:56 pm

bom acho que consegui remover as regras antigas seguindo uma dica sua la em cima...

então a ordem que apliquei as regras no roteador:

IBACEM->#conf t
Enter configuration commands, one per line. End with CNTL/Z.
IBACEM->(config)#access-list 105 remark VOIP (SIP/RTP) traffic gets top priority (5)
IBACEM->(config)#access-list 105 permit udp any any range 5060 5061
IBACEM->(config)#access-list 105 permit udp any any range 10000 20000
IBACEM->(config)#access-list 105 permit udp any any range 16384 32767
IBACEM->(config)#access-list 105 permit ip host 147.135.12.128 any
IBACEM->(config)#access-list 105 permit ip any host 147.135.12.128
IBACEM->(config)#access-list 105 permit ip host 147.135.32.221 any
IBACEM->(config)#access-list 105 permit ip any host 147.135.32.221
IBACEM->(config)#access-list 105 permit ip host 201.20.20.139 any
IBACEM->(config)#access-list 105 permit ip any host 201.20.20.139
IBACEM->(config)#access-list 106 deny udp any any range 5060 5061
IBACEM->(config)#access-list 106 deny udp any any range 10000 20000
IBACEM->(config)#access-list 106 deny udp any any range 16384 32767
IBACEM->(config)#access-list 106 deny ip host 147.135.12.128 any
IBACEM->(config)#access-list 106 deny ip any host 147.135.12.128
IBACEM->(config)#access-list 106 deny ip host 147.135.32.221 any
IBACEM->(config)#access-list 106 deny ip any host 147.135.32.221
IBACEM->(config)#access-list 106 deny ip host 201.20.20.139 any
IBACEM->(config)#access-list 106 deny ip any host 201.20.20.139
IBACEM->(config)#access-list 106 permit ip any any
IBACEM->(config)#Interface serial 0/0/0
IBACEM->(config-if)#no service-policy output qos_policy_1
% policy map qos_policy_1 not configured
IBACEM->(config-if)#rate-limit input access-group 105 512000 512000 512000 conform-action transmit exceed-action transmit
IBACEM->(config-if)#rate-limit input access-group 106 768000 768000 768000 conform-action transmit exceed-action drop
IBACEM->(config-if)#rate-limit output access-group 105 512000 512000 512000 conform-action transmit exceed-action transmit
IBACEM->(config-if)#rate-limit output access-group 106 768000 768000 768000 conform-action transmit exceed-action drop
IBACEM->(config-if)#end
IBACEM->#show policy-map interface serial0/0/0

só que quando digito o show class-map interface serial0/0/0 não aparece nada..fiz algo de errado?vi que não criado nenhuma policy como vc tinha me passado anteriormente então como faço para saber se está funcionando?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: cisco 1841+QoS voip   Qui Ago 13, 2009 10:23 pm

Este tipo de configuração não é uma policy e não tem classes, é rate-limit.

Se nao me engano o comando para ver isso é algo do tipo show interface s0/0/0 rate-limit

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
computacaofernando
Associate


Número de Mensagens : 27
Reputação : 0
Pontos : 22
Data de inscrição : 02/08/2008

MensagemAssunto: Re: cisco 1841+QoS voip   Sex Ago 14, 2009 7:10 am

ai o comando:

IBACEM->#show interface serial0/0/0 rate-limit
Serial0/0/0
Input
matches: access-group 105
params: 512000 bps, 512000 limit, 512000 extended limit
conformed 51674 packets, 7079010 bytes; action: transmit
exceeded 0 packets, 0 bytes; action: transmit
last packet: 1852ms ago, current burst: 0 bytes
last cleared 12:16:33 ago, conformed 1000 bps, exceeded 0 bps
matches: access-group 106
params: 768000 bps, 768000 limit, 768000 extended limit
conformed 351031 packets, 217968461 bytes; action: transmit
exceeded 0 packets, 0 bytes; action: drop
last packet: 1096ms ago, current burst: 0 bytes
last cleared 12:16:25 ago, conformed 39000 bps, exceeded 0 bps
Output
matches: access-group 105
params: 512000 bps, 512000 limit, 512000 extended limit
conformed 35783 packets, 7300505 bytes; action: transmit
exceeded 0 packets, 0 bytes; action: transmit
last packet: 672ms ago, current burst: 0 bytes
last cleared 12:16:14 ago, conformed 1000 bps, exceeded 0 bps
matches: access-group 106
params: 768000 bps, 768000 limit, 768000 extended limit
conformed 318456 packets, 45114494 bytes; action: transmit
exceeded 0 packets, 0 bytes; action: drop
last packet: 908ms ago, current burst: 0 bytes
last cleared 12:16:05 ago, conformed 8000 bps, exceeded 0 bps

duas últimas perguntas:

1)onde tem " exceeded 0 packets," é onde vejo se o voip está consumindo mais do que 512k de link??se sim e aonde vejo quando ele está cosumindo em quanto em uso tipo: um comando vai mostrar que no momento que eu executar o voip está consumindo 300kpbs do meu link entendeu?

2)Se eu notar que essas regras não estão limitando e priorizando o voip como posso removê-las?

Desde já agradeço a disposição e atenção.


Fernando.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: cisco 1841+QoS voip   Hoje à(s) 1:03 pm

Voltar ao Topo Ir em baixo
 
cisco 1841+QoS voip
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 2Ir à página : 1, 2  Seguinte
 Tópicos similares
-
» como configurar no-ip em cisco 1841
» COMO MONTAR SERVIDOR VOIP
» Redirecionar dominio por ip
» como bloquear dhcp vindo do cliente
» Bloquear uma range de ip e libera um por um

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Forum :: Suporte-
Ir para: