Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 DESAFIO BGP NIVEL 1

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: DESAFIO BGP NIVEL 1   Qui Jul 17, 2008 1:08 am

Tirei umas horinhas hoje para postar o primeiro desafio, escolhi o protocolo BGP que é um dos meus preferidos.

Este LAB não é muito complexo, mas exige um conhecimento legal de BGP.

Sua tarefa estara completa quando:

1 - O CEA e o CEB estiverem com 1 vizinhança BGP, e o PE com 2 vizinhanças BGP estabilizadas:

CEA
EBGP entre CEA e PE (4 Prefixos)

PE
EBGP entre PE e CEA (2 Prefixos)
EBGP entre PE e CEB (2 Prefixos)

CEB
EBGP entre CEB e PE (4 Prefixos)

2 - A loopback do CEA estiver pingando a loopback do CEB e vice-versa

obs. Nada de usar roteamento estático nem outro protocolo para resolver o item 2, este LAB é apenas de BGP.

Topologia



Config dos routers:

********* CEA *********

conf t

service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service compress-config
hostname CEA
logging buffered 16000 debugging
no logging console
ip subnet-zero
ip cef
ip classless
interface Loopback0
ip address 192.168.1.1 255.255.255.255
interface Serial1/0
no shut
ip address 200.0.0.1 255.255.255.252
router bgp 64000
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 200.0.0.2 remote-as 64002
no auto-summary
end
wr

********* CEB *********

conf t

service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service compress-config
hostname CEB
logging buffered 16000 debugging
no logging console
ip subnet-zero
ip cef
ip classless
interface Loopback0
ip address 192.168.1.3 255.255.255.255
interface Serial1/0
no shut
ip address 200.0.1.2 255.255.255.252
router bgp 64000
no synchronization
bgp log-neighbor-changes
neighbor 200.0.1.2 remote-as 64001
no auto-summary
end
wr

********* PE *********

conf t

service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service compress-config
hostname PE
ip subnet-zero
ip cef
ip classless
interface Loopback0
ip address 192.168.1.2 255.255.255.255
interface Serial1/0
no shut
ip address 200.0.0.2 255.255.255.252
interface Serial1/1
no shut
ip address 200.0.1.2 255.255.255.252
router bgp 64001
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 200.0.0.1 remote-as 64000
neighbor 200.0.1.1 remote-as 64000
no auto-summary
end
wr

arquivo Dynamips (este arquivo foi gerado para o dynamips padrão, caso resolva utilizar o GNS será necessário montar a topologia na hora, não esqueça de corrigir o caminho do IOS e de fazer o idlepc)

autostart = False
[localhost:7200]
[[7200]]
image = .\c7200-jk8s-mz[1].122-15.T17.bin
ram = 128
ghostios = True
sparsemem = True
[[ROUTER CEA]]
console = 2000
slot1 = PA-8T
s1/0 = PE s1/0
[[ROUTER PE]]
console = 2001
slot1 = PA-8T
s1/1 = CEB s1/0
[[ROUTER CEB]]
console = 2002
slot1 = PA-8T

IOS para download:
/http://www.4shared.com/file/9914030/50c618/c7200-jk8s-mz122-15T17.html

Vai uma dica, vocês vão encontrar 3 configurações faltando neste LAB e 1 errada.

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
marcelosguerra
Admin


Número de Mensagens : 81
Idade : 33
Localização : Sao Paulo - SP
Reputação : 16
Pontos : 80
Data de inscrição : 24/07/2007

MensagemAssunto: Re: DESAFIO BGP NIVEL 1   Sex Jul 18, 2008 8:02 pm

BOA NOITE A TODOS.


SEGUE ABAIXO CONFIGURAÇÃO E SOLUÇÃO DESTE DESAFIO



################### CEA ######################


CEA#sh run
Building configuration...
!
interface Loopback0
ip address 192.168.1.1 255.255.255.255

interface Serial1/0
ip address 200.0.0.1 255.255.255.252
serial restart_delay 0
!
!
router bgp 64000
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 200.0.0.2 remote-as 64001
neighbor 200.0.0.2 allowas-in
no auto-summary
!
!

################# CEB ###########################################

CEB#sh run
Building configuration...

interface Loopback0
ip address 192.168.1.3 255.255.255.255
!
!
interface Serial1/0
ip address 200.0.1.1 255.255.255.252
serial restart_delay 0
!
router bgp 64000
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 200.0.1.2 remote-as 64001
neighbor 200.0.1.2 allowas-in
no auto-summary
!
end

##################### PE ###############################

PE#sh run
Building configuration...
!
!
interface Loopback0
ip address 192.168.1.2 255.255.255.255
!
interface Serial1/0
ip address 200.0.0.2 255.255.255.252
serial restart_delay 0
!
interface Serial1/1
ip address 200.0.1.2 255.255.255.252
serial restart_delay 0
!
router bgp 64001
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 200.0.0.1 remote-as 64000
neighbor 200.0.1.1 remote-as 64000
no auto-summary
!
end

##################### Confirmação ##########################

CEA#sh ip bgp summary

BGP activity 17/12 prefixes, 35/29 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
200.0.0.2 4 64001 142 144 53 0 0 00:06:19 4


PE# sh ip bgp summary
BGP activity 54/49 prefixes, 65/58 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
200.0.0.1 4 64000 148 146 10 0 0 00:10:27 2
200.0.1.1 4 64000 137 156 10 0 0 00:10:26 2

CEA#sh ip bgp
BGP table version is 53, local router ID is 197.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 192.168.1.1/32 0.0.0.0 0 32768 ?
*> 192.168.1.2/32 200.0.0.2 0 0 64001 ?
*> 192.168.1.3/32 200.0.0.2 0 64001 64000 ?
* 200.0.0.0/30 200.0.0.2 0 0 64001 ?
*> 0.0.0.0 0 32768 ?
*> 200.0.1.0/30 200.0.0.2 0 0 64001 ?

CEA#sh ip route
Gateway of last resort is not set

200.0.0.0/30 is subnetted, 1 subnets
C 200.0.0.0 is directly connected, Serial1/0
200.0.1.0/30 is subnetted, 1 subnets
B 200.0.1.0 [20/0] via 200.0.0.2, 00:17:35
192.168.1.0/32 is subnetted, 3 subnets
C 192.168.1.1 is directly connected, Loopback0
B 192.168.1.3 [20/0] via 200.0.0.2, 00:17:35
B 192.168.1.2 [20/0] via 200.0.0.2, 00:17:08

Log. 2 - Ping de CEA para CEB.

CEA#ping 192.168.1.3 r 50

Type escape sequence to abort.
Sending 50, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (50/50), round-trip min/avg/max = 32/56/132 ms

Log-3 ping de CEB para CEA.
CEB#ping 192.168.1.1 r 50

Type escape sequence to abort.
Sending 50, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (50/50), round-trip min/avg/max = 12/56/148 ms


Resolvido:

1: Configuração errada do IP: 200.0.1.2 - PE - CEB estava duplicado
2: Ausencia do redistribute connected
3: Não existia este AS 64002, foi substituido
4: E adicionado o allowas-in no CEA e CEB devido ser o mesmo AS 64000 na mesma topologia.

Abracos a todos, valeu Nakano pelo Desafio. Configurações estão acima.

Att;
Marcelo Guerra

Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: DESAFIO BGP NIVEL 1   Sab Jul 19, 2008 7:58 pm

marcelosguerra escreveu:
BOA NOITE A TODOS.


SEGUE ABAIXO CONFIGURAÇÃO E SOLUÇÃO DESTE DESAFIO



################### CEA ######################


CEA#sh run
Building configuration...
!
interface Loopback0
ip address 192.168.1.1 255.255.255.255

interface Serial1/0
ip address 200.0.0.1 255.255.255.252
serial restart_delay 0
!
!
router bgp 64000
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 200.0.0.2 remote-as 64001
neighbor 200.0.0.2 allowas-in
no auto-summary
!
!

################# CEB ###########################################

CEB#sh run
Building configuration...

interface Loopback0
ip address 192.168.1.3 255.255.255.255
!
!
interface Serial1/0
ip address 200.0.1.1 255.255.255.252
serial restart_delay 0
!
router bgp 64000
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 200.0.1.2 remote-as 64001
neighbor 200.0.1.2 allowas-in
no auto-summary
!
end

##################### PE ###############################

PE#sh run
Building configuration...
!
!
interface Loopback0
ip address 192.168.1.2 255.255.255.255
!
interface Serial1/0
ip address 200.0.0.2 255.255.255.252
serial restart_delay 0
!
interface Serial1/1
ip address 200.0.1.2 255.255.255.252
serial restart_delay 0
!
router bgp 64001
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 200.0.0.1 remote-as 64000
neighbor 200.0.1.1 remote-as 64000
no auto-summary
!
end

##################### Confirmação ##########################

CEA#sh ip bgp summary

BGP activity 17/12 prefixes, 35/29 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
200.0.0.2 4 64001 142 144 53 0 0 00:06:19 4


PE# sh ip bgp summary
BGP activity 54/49 prefixes, 65/58 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
200.0.0.1 4 64000 148 146 10 0 0 00:10:27 2
200.0.1.1 4 64000 137 156 10 0 0 00:10:26 2

CEA#sh ip bgp
BGP table version is 53, local router ID is 197.168.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 192.168.1.1/32 0.0.0.0 0 32768 ?
*> 192.168.1.2/32 200.0.0.2 0 0 64001 ?
*> 192.168.1.3/32 200.0.0.2 0 64001 64000 ?
* 200.0.0.0/30 200.0.0.2 0 0 64001 ?
*> 0.0.0.0 0 32768 ?
*> 200.0.1.0/30 200.0.0.2 0 0 64001 ?

CEA#sh ip route
Gateway of last resort is not set

200.0.0.0/30 is subnetted, 1 subnets
C 200.0.0.0 is directly connected, Serial1/0
200.0.1.0/30 is subnetted, 1 subnets
B 200.0.1.0 [20/0] via 200.0.0.2, 00:17:35
192.168.1.0/32 is subnetted, 3 subnets
C 192.168.1.1 is directly connected, Loopback0
B 192.168.1.3 [20/0] via 200.0.0.2, 00:17:35
B 192.168.1.2 [20/0] via 200.0.0.2, 00:17:08

Log. 2 - Ping de CEA para CEB.

CEA#ping 192.168.1.3 r 50

Type escape sequence to abort.
Sending 50, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (50/50), round-trip min/avg/max = 32/56/132 ms

Log-3 ping de CEB para CEA.
CEB#ping 192.168.1.1 r 50

Type escape sequence to abort.
Sending 50, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (50/50), round-trip min/avg/max = 12/56/148 ms


Resolvido:

1: Configuração errada do IP: 200.0.1.2 - PE - CEB estava duplicado
2: Ausencia do redistribute connected
3: Não existia este AS 64002, foi substituido
4: E adicionado o allowas-in no CEA e CEB devido ser o mesmo AS 64000 na mesma topologia.

Abracos a todos, valeu Nakano pelo Desafio. Configurações estão acima.

Att;
Marcelo Guerra



boa sem chance eheheheheh resolve os outros dois que logo mais posto um nivel 2.

abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
Conteúdo patrocinado




MensagemAssunto: Re: DESAFIO BGP NIVEL 1   Hoje à(s) 2:47 am

Voltar ao Topo Ir em baixo
 
DESAFIO BGP NIVEL 1
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Tutorial Sign, nivel Medio.
» [TUTORIAL] Borda Tech - Nivel 1 - Facil
» Tutorial Borda Modelada Nivel Medio/Avançado
» [Tutorial] Borda Modelada Nivel Medio
» Como Fazer Inimigo , passar para o outro nivel e quando bater o tijolo aparecer uma moeda e ganhar pontos???

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Simuladores e Aplicativos :: Dynamips :: Desafio Dynamips-
Ir para: