Forum Cisco-BR

Simulados, simuladores, apostilas, forum brasileiro
 
InícioInício  CalendárioCalendário  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  LoginLogin  
Buscar
 
 

Resultados por:
 
Rechercher Busca avançada
Últimos assuntos
» Preparatório CCNA R&S
Ter Abr 05, 2016 2:10 pm por Sávio Augusto

» Problema roteamento
Ter Mar 22, 2016 5:51 pm por joaormv

» Avaliação do curso de suporte a redes do SENAI
Ter Mar 22, 2016 4:55 pm por joaormv

» Relatório syslog
Ter Mar 22, 2016 4:51 pm por joaormv

» DDNS NO-IP CISCO 1905
Sex Mar 11, 2016 10:23 pm por diegofrancaa

» Air Point Cisco 1041 ACESSAR
Sex Mar 11, 2016 10:08 pm por diegofrancaa

» Luz Power Piscando Direto
Seg Set 28, 2015 1:17 pm por AndreH

» Modem: TP-LINK8816 com roteador Linksys WRT54g: Problema
Sex Set 11, 2015 2:49 pm por lepokoloko

» VIRTUAL SWITCHING SYSTEM - VSS 1440
Ter Set 08, 2015 8:45 am por wstaenle

Navegação
 Portal
 Índice
 Membros
 Perfil
 FAQ
 Buscar
Fórum
Parceiros

Compartilhe | 
 

 CONFIGURANDO DHCP SERVER NO ROTEADOR

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: CONFIGURANDO DHCP SERVER NO ROTEADOR   Qui Jun 26, 2008 5:21 pm

Primeiro vamos excluir do pool DHCP o IP da Fast do Equipamento, podemos excluir outros IPS diferentes:

ip dhcp excluded-address 172.1.1.1

Agora vamos incluir a configuração de DHCP no CPE:

ip dhcp pool XXXX
network 172.1.1.0 255.255.255.0
domain-name XXX.XX
dns-server 201.1.1.1 201.1.1.2 201.1.1.3 (IPS DOS SERVIDORES DNS)
netbios-name-server 200.0.0.1 200.0.0.2 (IPS DOS WINS)
default-router 172.1.1.1
lease 3


interface FastEthernet0/0
ip address 172.1.1.1 255.255.255.0

Um dos comandos para troubleshooting pode ser:

show ip dhcp binding (relação de IPs fornecidos)

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
MOSCA
Associate


Número de Mensagens : 34
Reputação : 0
Pontos : 12
Data de inscrição : 19/04/2008

MensagemAssunto: Re: CONFIGURANDO DHCP SERVER NO ROTEADOR   Ter Mar 23, 2010 9:44 pm

E se eu quiser excluir um range específico dentro desse escopo, é possível?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: CONFIGURANDO DHCP SERVER NO ROTEADOR   Sab Mar 27, 2010 6:12 am

ip dhcp excluded-address <IP INICIAL> <IP FINAL>

exemplo:

ip dhcp excluded-address 172.1.1.1 172.1.1.10

Excluirá do pool os IPs de 1 a 10.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
MOSCA
Associate


Número de Mensagens : 34
Reputação : 0
Pontos : 12
Data de inscrição : 19/04/2008

MensagemAssunto: Re: CONFIGURANDO DHCP SERVER NO ROTEADOR   Sab Mar 27, 2010 12:28 pm

Show.. valeu Ronaldo.
Mais uma dúvida...

No dhcp há duas maneiras de se "reservar" um ip. Uma dela seria a exclusão do escopo, e a outra seria a reserva, ou seja, estou atribuindo determinado ip a um mac-address, ou seja, aquele mac-address irá sempre pegar o mesmo ip. Isso também é possível fazer no cisco?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ronaldobf
Specialist


Número de Mensagens : 189
Idade : 35
Localização : São Paulo-SP
Reputação : 25
Pontos : 202
Data de inscrição : 16/06/2008

MensagemAssunto: Re: CONFIGURANDO DHCP SERVER NO ROTEADOR   Dom Mar 28, 2010 7:03 am

Sim! Há como fazer.

Chama-se manual bind.

Basicamente, você tem que criar pools para cada host que deseja que receba o mesmo IP.

Exemplo:

ip dhcp excluded-address 172.1.1.1
ip dhcp excluded-address 172.1.1.10 172.1.1.20
!
ip dhcp pool DHCP_EXAMPLE
network 172.1.1.0 255.255.255.0
domain-name example.dhcp.com
dns-server 10.1.1.1 10.2.2.2
netbios-name-server 10.3.3.3 10.4.4.4
default-router 172.1.1.1
lease 3
!
ip dhcp pool STATIC_IP_01
host 172.1.1.2 255.255.255.0
hardware-address aaaa.bbbb.cccc
client-name StaticHost1
!
ip dhcp pool STATIC_IP_02
host 172.1.1.3 255.255.255.0
hardware-address cccc.bbbb.aaaa
client-name StaticHost2






Neste caso, temos o seguinte:


ip dhcp excluded-address 172.1.1.1
ip dhcp excluded-address 172.1.1.10 172.1.1.20

Os comandos acima excluem os IPs 172.1.1.1 e 172.1.1.10 a 20 do DHCP.


ip dhcp pool DHCP_EXAMPLE
network 172.1.1.0 255.255.255.0
domain-name example.dhcp.com
dns-server 10.1.1.1 10.2.2.2
netbios-name-server 10.3.3.3 10.4.4.4
default-router 172.1.1.1
lease 3

O pool acima, é a configuração do serviço DHCP. Ele fornece IPs dentro do range 172.1.1.1 a 172.1.1.254 (172.1.1.0/24), lembrando que fornecerá apenas IPs que não estão listados pelo comando excluded-address
Portanto, em nosso caso, fornecerá: 172.1.1.2 a 172.1.1.9 e 172.1.1.21 a 172.1.1.254

Comando domain-name fornece um dominio para os hosts.
DNS e netbios servers são para consulta de nomes. Pode-se colocar vários servidores separados por espaço. Neste exemplo, temos 2 servers.
Lease é o tempo em que o IP fica atrelado a um host, em dias. Em nosso caso, 3 dias.



ip dhcp pool STATIC_IP_01
host 172.1.1.2 255.255.255.0
hardware-address aaaa.bbbb.cccc
client-name StaticHost1
!
ip dhcp pool STATIC_IP_02
host 172.1.1.3 255.255.255.0
hardware-address cccc.bbbb.aaaa
client-name StaticHost2


Acima, temos dois hosts que são estaticamente mapeados (manual bind).

No exemplo 1, pool STATIC_IP_01, o host 172.1.1.2 possui o MAC address aaaa.bbbb.cccc. Como opcional, pode-se colocar o hostname do host.
Quando colocar o hostname, não deve-se colocar o domínio, pois este será fornecido pelo pool DHCP_EXAMPLE, que já possui o domínio configurado.

A mesma coisa acontece com o STATIC_IP_02.

Para cada host que deseja configurar manual biding, deve-se criar um novo pool. Logo, é permitido apenas 1 host por pool.



http://www.cisco.com/en/US/docs/ios/12_2/ip/configuration/guide/1cfdhcp.html
Voltar ao Topo Ir em baixo
Ver perfil do usuário
MOSCA
Associate


Número de Mensagens : 34
Reputação : 0
Pontos : 12
Data de inscrição : 19/04/2008

MensagemAssunto: Re: CONFIGURANDO DHCP SERVER NO ROTEADOR   Seg Mar 29, 2010 7:33 am

Valeu rodolfo.. show de bola suas explicacoes
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Nakano
Admin


Número de Mensagens : 467
Idade : 34
Localização : São Paulo
Reputação : 43
Pontos : 336
Data de inscrição : 21/07/2007

MensagemAssunto: Re: CONFIGURANDO DHCP SERVER NO ROTEADOR   Seg Abr 26, 2010 2:37 pm

Quando o host encaminha a identificação de DHCP (61) o comando correto é o client-identifier ou client-id.

Se quisermos criar um pool para cada entrada estática, usamos o client-identifier, se quisermos utilizar o mesmo pool usamos o client-id.

Quando o host não encaminhar a identificação o comando correto é o hardware-address.

Com isso segue script testado em laboratório:

ip dhcp pool TESTE
network 1.1.1.0 255.255.255.0
default-router 1.1.1.1
dns-server 208.67.220.220 208.67.222.222
domain-name cisco
address 1.1.1.123 client-id 0100.90f5.7bf8.82

http://cisco.forumeiros.com/suporte-f42/como-especificar-dhcp-para-que-o-host-pegue-ip-do-dhcp-certo-t580.htm?highlight=dhcp


abs

_________________
CCNA / CCDA
Cisco Data Center AS Support Specialist;
Cisco Data Center Support for UC Specialist;
Cisco Routing and Switching Field Specialist;
Cisco Unified Fabric Technology Support Specialist;
Cisco Unified Computing Technology Support Specialist
Cisco Data Center Unified Computing Support Specialist;
Cisco Data Center Storage Networking Support Specialist;
Cisco Data Center Application Services Support Specialist;
Cisco Advanced Data Center Networking Infrastructure Support Specialist;
CCNP / CCIP / CCDP
ITILF v2 / ITILF v3
CCIE SP #34881
CCIE RS Written

-----------------------------------------

Mind Wide Open
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://cisco.forumeiros.com
petros



Número de Mensagens : 1
Idade : 26
Localização : Rio Branco/AC
Reputação : 0
Pontos : 1
Data de inscrição : 07/10/2012

MensagemAssunto: Funcionou Filé Porem....   Dom Out 07, 2012 3:08 pm

funcionou Apenas na interface fast na interface Dot11Radio0 não ta funcionando segue abaixo as configurações

meu router é um 877w

ajuda aew pessoal


Código:


adsl_cisco#show run
Building configuration...

Current configuration : 2561 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname adsl_cisco
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid Petros_Barreto
 authentication open
 authentication key-management wpa
 guest-mode
 wpa-psk ascii 0 JCPhcD_l7JSa~)x3
!
ip source-route
!
!
ip dhcp excluded-address 192.168.0.1
!
ip dhcp pool server
  network 192.168.0.0 255.255.255.0
  domain-name petros.local.com
  dns-server 8.8.8.8 201.10.128.2
  default-router 192.168.0.1
  lease 3
!
!
ip cef
ip name-server 8.8.8.8
ip name-server 201.10.128.2
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface ATM0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 ip flow ingress
 pvc 0/35
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 no ip address
 !
 encryption mode ciphers tkip
 !
 ssid Petros_Barreto
 !
 speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 b
asic-18.0 basic-24.0
 channel 2452
 station-role root
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 ip address 192.168.0.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1452
!
interface Dialer0
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication chap callin
 ppp chap hostname 6832291500@oi
 ppp chap password 0 12345
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run

!
!
!
!
!
control-plane
!
!
line con 0
 no modem enable
 transport output telnet
line aux 0
 transport output telnet
line vty 0 4
 login
 transport input telnet
!
scheduler max-task-time 5000
scheduler allocate 4000 1000
scheduler interval 500
end

adsl_cisco#
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: CONFIGURANDO DHCP SERVER NO ROTEADOR   Hoje à(s) 2:50 am

Voltar ao Topo Ir em baixo
 
CONFIGURANDO DHCP SERVER NO ROTEADOR
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» SCRIPT PARA LIMPAR LISTA NO DHCP SERVER EM LEASES
» Controle de banda por IP em DHCP Server
» DHCP Server Authoritative E Bootp
» Dhcp server status busy
» como bloquear dhcp vindo do cliente

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Forum Cisco-BR :: Artigos :: Artigos de usuários-
Ir para: